Aurora R4 - AlienFX - Windows 8.1

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Aurora R4 - AlienFX - Windows 8.1

This question is answered

So I've followed nearly all the online guides for this and I can't seem to find an answer. Now, Windows 8.1 nestles 4.5 as a package with the Operating system, so you can't really uninstall / re install that easily I saw some post in my searches that said Dell was aware of this issue are there any plans to release an updated version of the command center that's compatible with Windows 8.1? Or has anyone who had windows 8.1 been able to get it functional? 

Thanks, 

Verified Answer
  • So I figured it out, took a bit but I got it, Turns out... that you actually have to power the machine off. See I had just been restarting it. But a full and actual power cycle corrected this. Like just physically powering it of... who would have thunk it. 

All Replies
  • Hi!

    The new Command Center 3.5 is compatible with Windows 8.1. Try following the steps on this article to troubleshoot the Command Center.

    If issue persists, try the steps below:

    1. Uninstall Alienware Command Center
    2. Download latest Command Center 3.5
    3. Uninstall .Net Framework 3.5, 4.0 and 4.5
    4. Restart
    5. Install .Net Framework 3.5 and 4.5
    6. Run Windows Updates and verify there is no pending updates. Avoid installing hardware driver updates
    7. Restart
    8. Install the Command Center.
    9. If issue remains, go to Programs and Features and choose uninstall Command Center, when setup loads, run the Repair

    Let me know how it goes!

    Alienware-Naomi
    Dell | Alienware Technical Support Alienware Arena
    Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
    I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

  • Hi Naomi, 

    I followed the instructions as you noted, perhaps there is some confusion though. I see no way to uninstall the .net Framework / Reinstall in Windows 8.1. I can turn them off as Windows Features (and did so for the troubleshooting / then turned them back on and checked for any pending updates). Even after running the repair, I am still unable to change the color of the device. 

    I wouldn't be so upset, but I'm using it as a server so it needs to be on 24/7 (Or best possible uptime) which would be fine and all, but there are times I'd like the lights off on it. 

    Is there some method I am unaware of for removing and re installing .net 4.5 / 3.0 / etc. in Windows 8.1? 

    Worth noting some additional troubleshooting steps. I have checked this against the Dell Service Tag service which shows no driver updates for the device. I attempted to run command center as administration, changed the compatibility to Windows 7. No effect. 

    I followed the full uinstall (including the removal of the %appdata% folder (which did not appear to be created). And the deletion of the AlienFX registry Keys. 

  • fullphaser
    I see no way to uninstall the .net Framework / Reinstall in Windows 8.1.

    AFAIK, you can't uninstall the version of .Net that Windows ships with (never have been able to since days of Win-7) . I've told Dell before you can't, but yet they still insist you can.


    Alienware Aurora ~ Intel i7-930 ~ 12gb ram ~ AMD HD-5870
    256gb Samsung 830 SSD / 1tb HDD ~ LG Blu-Ray ~ USB 3.0 PCIe
    Dell 24" UltraSharp u2410 LCD ~ Dell 22" LCD

    All my Dell Machines and Specs

    Wiki-like Threads I've written and other Favorites

    Posting Tips:
    - Always provide machine make, model, specs and software versions.
    - Click the button if we answered your question.

    Registered Microsoft Partner
    & Apple Developer:

    Gaming when I'm not programming.

    I answer questions here, but
    I'm not a Dell employee.

  • It may also be worth noting that 

    DISM /Online /Cleanup-Image /RestoreHealth

    Fails to correct the issue as well, so the issue doesn't appear to be with Microsoft's side of the .net Framework, what hooks are being used to change the LED colors for the case exactly, is it a chipset issue where the OS isn't aware of the case lights? 

  • Follow the installation instructions above, but instead try to turn it off, restart, then turn the .Net Framework on again. 

    If issue persists, I recommend you get in touch with the Technical Support department in your region, or if you're in the US or Canada, send me a private message with your Service Tag so I can assist you further. 

    Alienware-Naomi
    Dell | Alienware Technical Support Alienware Arena
    Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
    I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

  • So I figured it out, took a bit but I got it, Turns out... that you actually have to power the machine off. See I had just been restarting it. But a full and actual power cycle corrected this. Like just physically powering it of... who would have thunk it.