AlienFX not working after update to windows 8

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

AlienFX not working after update to windows 8

This question is answered

Hi!

After upgrading my X-51 to windows 8 professional AlienFX stopped working.

AlienFX launches fine and I can see the green icon in the notification area, but trying a quick change for the led panels or going trough the Command Center has no effect. After a while a balloon pops up from the notification area saying that AlienFX could not communicate with the hardware. Running the AlienFX test tool gives me a "no board detected" message. LED panels work just fine, the system boots up with my last color theme.

What would you suggest?

Verified Answer
  • Hi agnul,

    Request you to follow the below steps:

    (1) Take the mouse pointer to the right top corner a ‘charms bar’ appears.

    (2) Now click on search and type ‘Programs and Features’ and hit enter.

    (3) Now detect Alienware command center, right click on it and uninstall

    Now use the below links and download, BIOS, Chipset and Alienware Command Center:

    http://dell.to/SE8HKX BIOS

    http://dell.to/PFYKPq Chipset

    http://dell.to/RZl0Aj Alienware Command Center

    If you have any further questions please reply to the same post.

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

All Replies
  • Hi agnul,

    Request you to follow the below steps:

    (1) Take the mouse pointer to the right top corner a ‘charms bar’ appears.

    (2) Now click on search and type ‘Programs and Features’ and hit enter.

    (3) Now detect Alienware command center, right click on it and uninstall

    Now use the below links and download, BIOS, Chipset and Alienware Command Center:

    http://dell.to/SE8HKX BIOS

    http://dell.to/PFYKPq Chipset

    http://dell.to/RZl0Aj Alienware Command Center

    If you have any further questions please reply to the same post.

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Hi Kiran,

    I have an Alienware M14x R1 and I have followed your above steps (except I used the software for the M14x) and I am still unable to change alter the alien lighting fx. Anymore suggestions?

    Thanks,

    Peter

  • Hi Static Image,

    I request you to follow the above steps and then use the below links in the sequence given below only:

    http://dell.to/PUN1u1 BIOS

    http://dell.to/TCgBTH CHIPSET

    http://dell.to/XAsQat CHIPSET

    http://dell.to/RQCeDw Alienware Command Center

    If you have any further questions please reply to the same post.

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Thanks for the link to the updated  Alienware Commad Center.  My X51 is happy now!

  • I know this is a little bit after this topic was closed, but i'm having some problems still with my Alienware m14x R1. I unistalled the command Center, then re installed everything in order on the list. Still doesn't work. What else can I do?

  • Hi JollyGeneral,

    Have you also tried updating the drivers and BIOS as mentioned by me in the above posts?

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • I too had re-installed all officially-suggested drivers on my X51 under Windows 8, to no avail.

    However, as suggested by other forum members, installing 2.8.11.0 (as bundled with the TactX drivers) solved the issue. I would hope an updated AWCC package is released for the X51 post-haste.

  • Hello 

    I have tried on Alienware Fx ,but doesn't work on Win 8 ,so I have Alienware M17X R3...Please help

  • Hi Rayn506,

    I will be glad to help you. Request you to use the below link which is the latest version for Alienware command center:

    http://dell.to/122rsBv

    Do reply with your findings.

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Thank you ...it's great.

  • I saw you helping people in this AlienFX problem with download links, hope you help me too

    I have the same problem with my Alienware M11x R3 I would like to have the AlienFX driver for windows 8

    Thank you

  • Hi ashifsharif,

    Request you to refer my previous responses then install BIOS and Alienware command center by using the below links:

    http://dell.to/12zLfq6   BIOS

    http://dell.to/1aGGnol  Command centre

    Now try accessing the AlienFX and check if it works. Do reply with your responses.

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Hey, i got a weird problem

    You know that you can customize the colors of the keyboard to make it look cool?

    Wel for me it has this weird black screen that makes no sense, whenever i try to change the keyboard color, a black screen appears and i can't see anything, although the computer still works, because if i plug it into my tv, everything shows and works fine. In those cases i just have to change the keyboard back to blue (the only color it decides to work with) and the screen looks fine (no longer a black screen).

    This fights with some games like Xcom enemy unknown or the witcher 2, where usually the keyboard changes depending on what's happening. In those cases if the game changes the keyboard color, the black screen appears.

    I really need help, i don't know if it's a problem with windows 8 or the computer itself but it's really annoying!!

  • Hi ,
                                   I have alienware 14 .i have done my reboot recently.My lights are not changing but my lights are fine.do have any solutions for this please do help.