New Aurora BIOS

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

New Aurora BIOS

  • Looked at the downloads and saw a AO10 BIOS,but cant download . Also what processor does it support . Thanks

    Aurora i7-975 @ 4.1 ghz ,6gb corsair DDR3 @ 1800 mhz , radeon 1 GB HD 5850,875 psu ,custom cooling ,DVDCD drive,BLURAY drive,media reader ,window 7 64

  • I had the same problem also.

  • i just tried to download also and got this screen

    Alienware Aurora(nonalx) bios A11       
    Intel i7-920(2.67GHz)          CCv.2.6.1.0 
    12gb 1333 ddr3 ram
    2x1tb wdc1001faes(raid1)   1x1tb wdc(data)  1x1tb wdc(data)
    GTX 570   v.334.89
    Dual drives>~hl-dt-st dvdrwbd ch20n>>plds dvd+rw dh-24aas
    Soundblaster xfi-titanium                    
    ASUS VG248QE monitor
    Razer deathadder mouse

    Tt eSPORTS POSEIDON cherry brown keyboard
    windows7 home premium 64-bit
       

  • * Remove the Dell Download Manager from Control Panel- Add/Remove Programs
    * Reboot the PC
    * Go here
    * Choose the option to let your browser download the file

    (Liaison for Desktops, Alienware, Monitors)
    Would you like to be a Dell Community Rockstar?

  • Ehhh...Does it boot faster? My machine still takes a good 20 secs. to get past the BIOS screen...

    Intel i7 3770K @ 4.24GHz, Liq. Cooled | 16GB RAM @ 1600MHz
    30" IPS Monitor @ 2560x1600 | Dual 6GB GeForce GTX Titans SLI
    240GB SSD, 640GB, two 1TB HDDs | 1TB Passport | 24x DVD+/-RW+DL
    WinTV-HVR 2250 with Remote | XBOX 360 Wireless Controller
    PIXMA MG6220 AIO | C920 HD Pro | G19 Keyboard | G700s Mouse
    RealTek ALC892 Audio | X-540 5.1 Speakers | G930 7.1 Headset
    Sabertooth Z77 | Biometric Reader | 1.2KW PSU | 1500VA and 550VA UPS
    Windows 8.1 Pro with Media Center, 64-bit | Corsair 600T with LEDs

  • Having finally managed to download the file, I've flashed the bios of my Aurora but it still says it's version A09.

    Running it again I was still given the option to upgrade from A09 to A10.

    So, either the flashing process has not worked, or the file is the wrong version ?!?!?!?!?!

    Confused

     

     

     

    Alienware Aurora (2009) | Intel Core I7-920 2.66GHz @ 3.20GHz

    6Gb RAM | Windows 7 64-Bit

    Bios Version A11 | Command Centre 2.6.10

    Nividia GeForce GTX460 1Gb | Realtek HD Onboard Audio

    OCZ Alchemy Keyboard | Logitech G5 Mouse

  • i installed A10  lastnight and so far it is running fine,,,,although it did put my command center back to all the defaults so i had to go in and redo my manual settings again..............so far so good.............does seem to boot a little faster...

     

    Alienware Aurora(nonalx) bios A11       
    Intel i7-920(2.67GHz)          CCv.2.6.1.0 
    12gb 1333 ddr3 ram
    2x1tb wdc1001faes(raid1)   1x1tb wdc(data)  1x1tb wdc(data)
    GTX 570   v.334.89
    Dual drives>~hl-dt-st dvdrwbd ch20n>>plds dvd+rw dh-24aas
    Soundblaster xfi-titanium                    
    ASUS VG248QE monitor
    Razer deathadder mouse

    Tt eSPORTS POSEIDON cherry brown keyboard
    windows7 home premium 64-bit
       

  • I re-downloaded the file, and re-flashed the bios.

    Now it displays as version A10.....

    .....but, I haven't noticed anything different or any extra options in the bios Huh?

    Anyone know what changes/enhancements have been introduced ?

     

    Alienware Aurora (2009) | Intel Core I7-920 2.66GHz @ 3.20GHz

    6Gb RAM | Windows 7 64-Bit

    Bios Version A11 | Command Centre 2.6.10

    Nividia GeForce GTX460 1Gb | Realtek HD Onboard Audio

    OCZ Alchemy Keyboard | Logitech G5 Mouse