I am happy to announce a new version of the PowerShell Module for vWorkspace. This new module adds many new features that should be able to take your automation efforts in the newest version of vWorkspace to new levels. In addition to vWorkspace 8.0 support, there are also new CMDlets to automate vWorkspace features like Web Access, delegated control and multitenancy.

IMPORTANT: Please note that this version of the vWorkspace PowerShell module has a new system requirement. The PowerShell module now requires .NET 4.0 and supports PowerShell v3. Installing the Windows Management Framework v3 will take care of the .NET 4.0 requirement and install PowerShell v3. If you do not wish to install WMF3, you can just install .NET 4.0 before installing the PowerShell module. The installer will not take care of the pre-requisite itself.

New Features

  • vWorkspace 8.0 Support
  • Cmdlets for Web Access website configuration management
  • Cmdlets for managed domain configuration
  • Cmdlets for managing delegated permissions
  • More comprehensive managed application cmdlets

New cmdlets

New objects

Download

The new beta version of the vWorkspace PowerShell can be downloaded here:

x86 vWorkspace PowerShell module
(build 8.0.306.0031)

x64 vWorkspace PowerShell module
(build 8.0.306.0031)

If you have any questions or feedback about this beta the vWorkspace PowerShell Module, we would love to hear it! Just post a question or comment here on the beta community or email vworkspace_beta@quest.com.

We look forward to hearing from you!

Full documentation on the module can be found here: http://wiki.vworkspace.inside.quest.com/index.php/Main_Page

If you have any questions or feedback about the vWorkspace PowerShell Module, we would love to hear it! Just post a question or comment here on the community.

Happy PowerShelling!