OpenManage Support for VMware ESXi 5.x - Systems Management - Wiki - Systems Management - Dell Community
Wikis - Title

OpenManage Support for VMware ESXi 5.x

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Systems Management - Wiki

OpenManage Support for VMware ESXi 5.x

Systems Management - Wiki

This page outlines OPENMANAGE SUPPORT FOR VMWARE ESXi 5.x / vSphere v5.x

(Updated July 1st, 2013)

As of late March 2012, Dell PowerEdge 12th Generation servers were supported by the Dell OMSA VIB for VMware vCenter ESXi 5.x. 

The current version can be downloaded here:

 Dell OMSA 7.3 Virtual Install Bundle for VMware vCenter ESXi 5.x

For instructions on how to install OpenManage Server Administrator  on VMware ESXi, refer to the "Installing Managed System Software on Supported Linux and VMware ESX" section of the OpenManage Server Administrator Installation Guide

For full documentation and support information about OpenManage and ESXi 5, visit the OpenManage  Server Administrator Documentation page.


Monitoring Consoles

The OpenManage Essentials console allows you to monitor your ESXi 5.x systems in a one to many fashion. For more information about OME, visit

If you are interested in using the VMware vSphere console for managing your physical and virtual servers, consult the Dell TechCenter page outlining the Dell Management Plug-in for VMware vCenter.


Legacy Info:

Dell OpenManage Server Administrator agent officially supported vSphere v5.0 / ESXi 5 as of December 2011, starting with OMSA 6.5 A02.

Dell uses VMware's VIB mechanism to load the Dell OpenManage Server Administrator (OMSA) monitoring agent into ESXi. To complete the install, you will need to download the OpenManage 6.5 A02 OMSA vCenter Install Bundle (VIB). 

Prior to December 2011, OMSA 6.5 A01 only partially supported ESX5i with caveats. Historical information is avalable in this document that outlined limited Dell OpenManage 6.5 A01 support of ESXi 5 . The content is provided “as is” and without express or implied warranties of any kind.

  • Any news on a fully supported release ?

  • Download of the *.exe or *.zip ends in a "file not found" and also on isnt available yet :(

  • Using the download manager option works fine

  • I tested this VIB (version 6.5 A02), and using it with OpenManage 6.5 on esxi 5.0.  There is a little bug on the VIB that needs to be fixed.

    When using OpenManage web server to login, you will get "Login Failed" and "Internal Error."

    Causes: The Web Services Management daemon failed to start after reboot.

    Root cause:

    There is an extra trailing newline on file /etc/cim/openwsman/dcim.conf.  This is causing the Web Services Management daemon (/etc/init.d/wsman) to fail in generating the needed configuration file on "/etc/openwsman/openwsman.conf" *IF* you have other files in /etc/cim/openwsman directory.

    You will get an error from /bin/sed about unmatching "|" pattern.

    To fix that, I simply did:

    echo -n > /etc/cim/openwsman/dcim.conf

    Then just simply restart wsman:

    /etc/init.d/wsman restart

    Unfortunately, all of the changes on /etc/cim/openwsman/dcim.conf will be gone once esxi server is restarted.  Thus, Please fix this on your next release of the vib.

  • I'v installed OM 6.5 on my ESXi 5.0 server, and after a reboot, I cannot connect to OMSA using https://<esxi ip>:1311

    What is the problem?

  • This was the issue for us...


    WS-Man fails when multiple CIM VIBs are installed.   WS-Management requests fail when directed to an ESX/ESXi system that has more than one CIM provider VIB installed. This problem does not occur when only one VIB containing CIM providers is installed. This problem occurs when installation of a second VIB containing CIM providers corrupts the WS-Man configuration,

    Workaround:   To correct the WS-Man configuration, modify the file /etc/init.d/wsman.

       Open a shell window connected to the ESX/ESXi server.

       Set the sticky bit on /etc/init.d/wsman.

            chmod +t /etc/init.d/wsman

       Open /etc/init.d/wsman with a text editor and find the following line:

            local oem_lines=$(cat /etc/cim/openwsman/*.conf 2>/dev/null | sed -e 's-\n-,-g')

       Replace the line with the following:

            local oem_lines=$(awk '{ printf "%s,", $0 }' /etc/cim/openwsman/*.conf 2>/dev/null \| sed -e 's-,\{2,\}-,-g' -e 's-,$--')

       Restart the WS-Man server.

            /etc/init.d/wsman start

  • Having issues with the A02 tools I can use Dell OMSA to connect to the machines just fine.

    Installed a new machine with Dell OpenManage Essentials, since our old ITA machine needed many updates anyways. Btw, concerning OME, have you gone mental? No, seriously... Listing a 6G minimum memory requirement? All I want is some alerts if a piece of hardware dies... There was a time I ran GUI's in 4MB.

    Anyways, OME doesn't recognize the machines. See some people here with issues starting the wsman service, it seems to run fine here (not sure how to test it). They also point to release notes that were released way before the A02 release.

    OME is probably buggy too. The iDRAC of our 106 server comes and goes and the one of our 105 server is more off than on according to OME...

    A lot of SNMP traps are not recognized, whilst it should have a vmware MIB. See these for example:

    Enterprise: . Trap Ids:Generic:6 Specific:401; (;0= 07 db 0c 17 0b 14 07;1=

    Have a lot of those. Also just notice we can not select any text in the alerts pane, nor the details of an alert. Have to export them first to copy/paste, highly annoying.

    Not sure what to do with the OEM CIM Providers variable. Several blog posts state to enable it. It's no longer in the manual however (not in the vSphere 5 section anyways) and see alot of other variables that might enable it now:

    /tmp/ vicfg-advcfg -l | grep -i provider

    UserVars.CIMvmw_OpenManageProviderEnabled : Enable or disable the CIM vmw_OpenManage provider

    UserVars.CIMvmw_hdrProviderEnabled : Enable or disable the CIM vmw_hdr provider

    UserVars.CIMvmw_kmoduleProviderEnabled : Enable or disable the CIM vmw_kmodule provider

    UserVars.CIMvmw_swmgtProviderEnabled : Enable or disable the CIM vmw_swmgt provider

    UserVars.CIMvmw_pciProviderEnabled : Enable or disable the CIM vmw_pci provider

    UserVars.CIMvmw_hhrcwrapperProviderEnabled : Enable or disable the CIM vmw_hhrcwrapper provider

    UserVars.CIMvmw_viProviderEnabled : Enable or disable the CIM vmw_vi provider

    UserVars.CIMvmw_sfcbInteropProviderEnabled : Enable or disable the CIM vmw_sfcbInterop provider

    All of these are enabled.

    The VIB was installed with update manager from vcenter. According to the manual that came with it, this is a supported method.

    ~ # esxcli software vib list

    Name                  Version                             Vendor  Acceptance Level  Install Date

    --------------------  ----------------------------------  ------  ----------------  ------------

    OpenManage            6.5-0000                            Dell    VMwareAccepted    2011-12-17  

    ata-pata-amd          0.3.10-3vmw.500.0.0.469512          VMware  VMwareCertified   2011-12-17  

    ata-pata-atiixp       0.4.6-3vmw.500.0.0.469512           VMware  VMwareCertified   2011-12-17  

    ata-pata-cmd64x       0.2.5-3vmw.500.0.0.469512           VMware  VMwareCertified   2011-12-17  

    ata-pata-hpt3x2n      0.3.4-3vmw.500.0.0.469512           VMware  VMwareCertified   2011-12-17  

    ata-pata-pdc2027x     1.0-3vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    ata-pata-serverworks  0.4.3-3vmw.500.0.0.469512           VMware  VMwareCertified   2011-12-17  

    ata-pata-sil680       0.4.8-3vmw.500.0.0.469512           VMware  VMwareCertified   2011-12-17  

    ata-pata-via          0.3.3-2vmw.500.0.0.469512           VMware  VMwareCertified   2011-12-17  

    block-cciss           3.6.14-10vmw.500.0.0.469512         VMware  VMwareCertified   2011-12-17  

    ehci-ehci-hcd         1.0-3vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    esx-base              5.0.0-0.7.515841                    VMware  VMwareCertified   2011-12-17  

    esx-tboot             5.0.0-0.0.469512                    VMware  VMwareCertified   2011-12-17  

    ima-qla4xxx           2.01.07-1vmw.500.0.0.469512         VMware  VMwareCertified   2011-12-17  

    ipmi-ipmi-devintf     39.1-4vmw.500.0.0.469512            VMware  VMwareCertified   2011-12-17  

    ipmi-ipmi-msghandler  39.1-4vmw.500.0.0.469512            VMware  VMwareCertified   2011-12-17  

    ipmi-ipmi-si-drv      39.1-4vmw.500.0.0.469512            VMware  VMwareCertified   2011-12-17  

    misc-cnic-register    1.1-1vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    misc-drivers          5.0.0-0.7.515841                    VMware  VMwareCertified   2011-12-17  

    net-be2net          VMware  VMwareCertified   2011-12-17  

    net-bnx2              2.0.15g.v50.11-5vmw.500.0.0.469512  VMware  VMwareCertified   2011-12-17  

    net-bnx2x             1.61.15.v50.1-1vmw.500.0.0.469512   VMware  VMwareCertified   2011-12-17  

    net-cnic              1.10.2j.v50.7-2vmw.500.0.0.469512   VMware  VMwareCertified   2011-12-17  

    net-e1000            VMware  VMwareCertified   2011-12-17  

    net-e1000e            1.1.2-3vmw.500.0.7.515841           VMware  VMwareCertified   2011-12-17  

    net-enic           VMware  VMwareCertified   2011-12-17  

    net-forcedeth         0.61-2vmw.500.0.0.469512            VMware  VMwareCertified   2011-12-17  

    net-igb             VMware  VMwareCertified   2011-12-17  

    net-ixgbe        VMware  VMwareCertified   2011-12-17  

    net-nx-nic            4.0.557-3vmw.500.0.0.469512         VMware  VMwareCertified   2011-12-17  

    net-r8168             8.013.00-3vmw.500.0.0.469512        VMware  VMwareCertified   2011-12-17  

    net-r8169             6.011.00-2vmw.500.0.0.469512        VMware  VMwareCertified   2011-12-17  

    net-s2io         VMware  VMwareCertified   2011-12-17  

    net-sky2              1.20-2vmw.500.0.0.469512            VMware  VMwareCertified   2011-12-17  

    net-tg3               3.110h.v50.4-4vmw.500.0.0.469512    VMware  VMwareCertified   2011-12-17  

    ohci-usb-ohci         1.0-3vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    sata-ahci             3.0-6vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    sata-ata-piix         2.12-4vmw.500.0.0.469512            VMware  VMwareCertified   2011-12-17  

    sata-sata-nv          3.5-3vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    sata-sata-promise     2.12-3vmw.500.0.0.469512            VMware  VMwareCertified   2011-12-17  

    sata-sata-sil         2.3-3vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    sata-sata-svw         2.3-3vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    scsi-aacraid         VMware  VMwareCertified   2011-12-17  

    scsi-adp94xx        VMware  VMwareCertified   2011-12-17  

    scsi-aic79xx          3.1-5vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    scsi-bnx2i            1.9.1d.v50.1-3vmw.500.0.0.469512    VMware  VMwareCertified   2011-12-17  

    scsi-fnic            VMware  VMwareCertified   2011-12-17  

    scsi-hpsa             5.0.0-17vmw.500.0.0.469512          VMware  VMwareCertified   2011-12-17  

    scsi-ips              7.12.05-4vmw.500.0.0.469512         VMware  VMwareCertified   2011-12-17  

    scsi-lpfc820        VMware  VMwareCertified   2011-12-17  

    scsi-megaraid-mbox        VMware  VMwareCertified   2011-12-17  

    scsi-megaraid-sas     4.32-1vmw.500.0.0.469512            VMware  VMwareCertified   2011-12-17  

    scsi-megaraid2        2.00.4-9vmw.500.0.0.469512          VMware  VMwareCertified   2011-12-17  

    scsi-mpt2sas     VMware  VMwareCertified   2011-12-17  

    scsi-mptsas       VMware  VMwareCertified   2011-12-17  

    scsi-mptspi       VMware  VMwareCertified   2011-12-17  

    scsi-qla2xxx          901.k1.1-14vmw.500.0.0.469512       VMware  VMwareCertified   2011-12-17  

    scsi-qla4xxx       VMware  VMwareCertified   2011-12-17  

    uhci-usb-uhci         1.0-3vmw.500.0.0.469512             VMware  VMwareCertified   2011-12-17  

    vmware-fdm            5.0.0-455964                        VMware  VMwareCertified   2011-11-12  

    tools-light           5.0.0-0.7.515841                    VMware  VMwareCertified   2011-12-17

  • I'm having the same issue, after getting a successful install ofOMSA 6.5 on ESXi5 using PowerCLI.  Uservars.CIMvmwOpenManageProviderEnabled is 1.  I cannot connect to my ESXi host iva is the Ip of my Esxi host server and where I installedOMSA 6.5 successfully and restarted, then took it out of maintenance mode. Nada.

  • I'v installed OM 6.5 A02 on my ESXi 5.0 server, and after a reboot, I cannot connect to OMSA using https://<esxi ip>:1311, https://<esxi ip>:80 is ok.

    What is the problem?

    1.Install is ok:

    Enter username: root

    Enter password:

    Installation Result

      Message: The update completed successfully, but the system needs to be reboot

    ed for the changes to be effective.

      Reboot Required: true

      VIBs Installed: Dell_bootbank_OpenManage_6.5-0000

      VIBs Removed:

      VIBs Skipped:

    2.Current SNMP agent settings:

    Enabled  : 1

    UDP port : 161

    Communities :


    Notification targets :

    "management server"@162/public

    Options :


    3.wsman restart is ok

    4.UserVars.CIMvmw_OpenManageProviderEnabled : Enable or disable the CIM vmw_OpenManage provider

    5.ESXi network firewall unload

  • I'm still getting the Login Failed and Internal Error messages when trying to use this VIB through OMSA installed on another machine.  Have tried the solution below with removing the extra line in the dcim.conf file, but didn't have an extra line.  Used the OMSA on a Windows XP (previous install) and Windows Server 2003 (fresh install) machine.  Also had this issue with OMSA 6.5 A01 VIB with the OMSA web server installed on only an XP machine.

    In both the XP and 2003 installs, I can access the VIB's on our two ESXi4 machines (using the previous 4.1 compatible VIB - 6.4.0).

    I'm using the standard VMware ESXi 5 install ISO and using the remote CLI to add the VIB to this.  I can see it listed in the installed VIB list after the restart, but no joy getting onto it so far.  I've tried this on two machines, a Gen 2 2950 and a Gen 1 2950 using both the root user and an AD account that has admin privileges.

    Anyone got any ideas?

    To those of you trying to access the VIB using https://<esx-ip>:1311 - there is no web manager in the current VIB bundles.  This has been true since ESXi 4.  You need to install the OMSA web service on another machine, then access this machine on port 1311 and then make the connection to your ESXi box.

  • With esxi you are not installing Open manage on the server just a managment agentso you cannot access it by https://<esxi ip>:1311 you have to open up a web browser to another box with Open manage installed and in tiny print below the submit button there is a link that says manage remote node. If you click that you then specify the ip address or hostname of your esxi box and log into open manage.

    I managed to get my VIB installed and even managed to get OME to inventory it by creating a discovery range that only used ws-man credentials. I first did it with ws-man and snmp but it wouldnt recognize it was a dell server. After I deleted it out and rediscovered only using ws-man its recognized as a dell server however I have one little hickup in that its device status is warning because the server administrator agent version is listed as N/A. Has anyone else come across that?

  • Anyone have any idea IT Assistant 8.9 is compatible with OSMA 6.5 and ESXi 5. We are planning to upgrade to OME for a while yet and I would like to get ITA working if possible. It was working fine until We upgraded to ESXi 5. I have verified that SNMP is working on the ESXi 5 servers since we are monitoring those servers with SolarWinds Orion and it's SNMP communication is working perfectly.

  • We loaded Dell OMSA 7.0 using the Virtual Install Bundle for VMware vCenter ESXi 5.0 and it worked great with our three ESXi 5.0.0 GA (build-515841) Kernel 5.0.0 (x86_64) Servers [I think this build was what was current at the time of the release of OMSA 7.0 A0].

    However, our ESXi 5.0.0 Update 1 (build-623860) Kernel 5.0.0 (x86_64) [which includes patches released after OMSA 7.0 A0] are not being recognised by Open Manage Essentials as having any software agents installed (ie neither Dell Server Administrator or VMWares embedded ESX Agent is appearing).

    Both the ESXi 5.0.0 GA and ESXi 5.0.0 Update 1 servers were loaded with the same OMSA 7.0 A0 VIB and had SNMP configured with the same PowerCLI commands. Neither server groups were loaded with any previous OMSA agents. Beside the ESXi  5 patch levels, the only difference we are aware of is that the ESXi 5.0.0 GA servers are Power Edge 6850s and the ESXi 5.0.0 Update 1 servers are PowerEdge R900s

    The Dell Troubleshooting tool appears to be indicating that the OME Server can access and find 19 WSMAN profiles including the OpenManage. We can get to the OMSA Web Interface on the ESXi 5.0.0 Update 1 servers. The vSphere client is able to dispaly the hardware status - it also shows the OpenManage Version 7.0-0000 Release Date: 02/15/2012 4:32:12PM Install Date: 04/25/2012 3:15:13 PM Description: Dell OpenManage 7.0 for esxi500.

    Has anyone else seen this symptom? Is this a known issue?

  • Further to my last RE OMSA 7.0 A0 on ESXi 5.0.0 Update 1 - this is now WORKING.

    Unfortunately I don't know what changed to cause it work.

    We are also now seeing the VMWare ESXi 5.0.0 build-623960 Embeede ESX Agent  appearing as a Software Agent within the OME7 Device Details on ESXi Servers that do not have the OMSA 7 agent install. Therefore, I'm presuming it must have been a configuration issue within our OME Discovery and Inventory and nothing associated with OMSA 7.

  • The link for "Dell OMSA 7.1 Virtual Install Bundle for VMware vCenter ESXi 5.0" goes to a German site.   What is the correct link for USA?