Dell Client Configuration Toolkit - CCTK - Systems Management - Wiki - Systems Management - Dell Community
Wikis - Title

Dell Client Configuration Toolkit - CCTK

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Systems Management - Wiki

Dell Client Configuration Toolkit - CCTK

Systems Management - Wiki

NOTE: The latest version of CCTK is now Dell Command | Configure and is a part of the Dell Client Command Suite.  Click HERE to go to the new page.

This page is being retained for customers who are still using CCTK 2.2.1 or earlier.

The Dell Client Configuration Toolkit (CCTK) software provides configuration capability to Dell Enterprise client systems. This product consists of a Command Line Interface (CLI) and Graphical User Interface (GUI) to configure various BIOS features. You can use CCTK on Microsoft Windows Pre-installation Environment (Windows PE), Microsoft Windows XP, Windows Vista, Windows 7, Windows 8, and Windows 8.1 operating systems, and Red Hat Enterprise Linux environments.

If you're familiar with the Dell OpenManage™ Deployment Toolkit (DTK) software for servers, CCTK should feel pretty natural to you as it uses the same syntax and has similar features.


The latest version of CCTK is 2.2.1 (Released 18/Oct/2013).

Enhancements included in the new version

- Support for Microsoft Windows 8.1
- Support for the following BIOS options:    
  • Dell Reliable Memory Technology
  • Dell Wyse P25 Bios Access
  • Pci Mmio Size
  • Pci Allocation Priority
  • Intel Platform Trust Technology
  • Deep Sleep Control


The following CCTK related whitepapers are available from the OpenManage Whitepapers page:


  • Having some issues on the new Latitude E Series (E6230/E6330/E6430/E6530) getting the --tpmactivation=activate command to work.  Works fine on older models, just not the new ones.  --tpm=on works perfect.

  • Hello dhedges,

    I'm experiencing same pain like you do with E6430/E6420. With latest CCTK 2.1, I'm able to set setup password, enable TPM and also activate TPM. But when I go to BIOS, TPM is enabled but in de-activated state. I'm using CCTK with SCCM 2007.

  • Had also problems with E Serie. First time it worked, but when trying again (after resetting bios to default), I had the problem, that TPM was enabled but NOT activated --> CLEAR the TPM Settings in BIOS solved the problem!

  • I have been getting exit code 255 recently when running CCTK with an input file with system credentials in a startup script.  Follows is WPKG output:

    2012-09-14 05:10:40, ERROR   : Could not process (upgrade) package 'bios-settings' (bios-settings):|Exit code returned non-successful value (255) on command 'cctk -i "%BIOSDEFAULT%" --valsetuppwd=%BIOSPASS%'.

    When I run it manually, it seems to succeed returning 0 and correct output.

    I plan to consider 255 a "successful" exit code.

  • I have been testing SCCM 2012 and CCTK 2.1 does not seem to activate the TPM on the Latitude E-Series 6400 I am testing with.  With 2.01 and SCCM 2007 everything seemed to work.  Trying to move to CCTK 2.1 to support the new models.

  • CCTK 2.1.1 crashes, if setuppwd includes a "

  • CCTK 2.2.0 just crashes on W7 x64 while exporting exe, works OK on W7 x86