Dell Server MP agent Proxy not enabled i SCOM - OpenManage Integrations with Microsoft SCCM and SCOM - Systems Management - Dell Community
Systems Management Forums

Dell Server MP agent Proxy not enabled i SCOM

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Dell Server MP agent Proxy not enabled i SCOM

  • Dell Server MP agent Proxy not enabled i SCOM

    Just upgraded from 6.2 to 6.3 and after that I'm getting warnings that agent Proxy isn't enabled.
    This is happening for VM's that shouldn't even try to be discovered/monitored.
    Anyone seeing simular warnings or now why this would suddenly pop up?

    The warnings are green when checking Health Explorer.

  • Hi,

    same here. We have about 1000k Servers (200 physical) and SCOM want to activate the Agent on a very huge amount of the VM's.

    Br

    Sergej

    EDIT:

    Just found this one:

    http://www.dell.com/support/manuals/us/en/19/server-management-pack-suite-v6.3/ServerMPv6.3UGPubs/Issues-and-resolutions-?guid=GUID-28A5148C-22D3-4B4A-98DF-C9E3EB299B3E&lang=en-us

    To resolve this issue, perform the following steps:

    1. Navigate to the Feature Management Dashboard, and click Server and Rack Workstation Monitoring (Licensed).
    2. In the right pane, under Dell Monitoring Feature Tasks, click Enable Agent Proxying.

      The Run Task - Enable Agent Proxying window is displayed.

    3. Click Override, and then click the field under New Value for the AutoResolve Warnings/Errors parameter and set the value as True.
    4. Now click Override and then click Run.
    5. Close the task status window.

    Clear the existing alerts from the active alerts list. These alerts will no longer be displayed for future discoveries.

  • Hi,

    it seems that the override is not working. After executing the Task, the Value is still false and the Agent notifications shows up.

  • Feedback would be nice ...

  • Hi PatrikHansson , SergejM ,

    Enable Agent proxing task needs to be executed corresponding to Servers and Rack workstation monitoring.

    In ServerMP6.2, Two types of monitoring
     - Servers and Rack work Station monitoring(Agent Based)
           - OMSA installed on Host
     - Servers and Rack Workstation Monitoring(Licensed)
           - WSMAN Template

    In ServerMP6.3,
    Added a new method using iSM(iDRAC Service Module) which is associates to Servers and Rack Workstation Monitoring(Licensed).
     - Servers and Rack Workstation Monitoring(Licensed)
      - iSM-WMI

    In the above case, Enabling the Agent Proxy which is associating to iSM.

    Seems like in this issue, Servers are discovered using OMSA(associate to Servers and Rack Workstation Monitoring).

    Can you please try the below step to resolve this issue:
    1. Navigate to the Feature Management Dashboard, and click Server and Rack Workstation Monitoring.
    2.In the right pane, under Dell Monitoring Feature Tasks, click Enable Agent Proxying.
    The Run Task - Enable Agent Proxying window is displayed.
    3. Click Override, and then click the field under New Value for the AutoResolve Warnings/Errors parameter and set the value as True.
    4. Now click Override and then click Run.
    5. Close the task status window.

    Thanks,
    Sai

  • Hi, tnx for your answer, but this is the same what i write above.

    If i set the override, run the task, close the window and open it again. The override is not working and the value is still false.

    No idea what else i can do.

    Br

    Sergej

  • Hi SERGEJM,

    This task is used to enable for agent proxy for all Agents where it is disabled.

    Whatever the case, when you close and open it will show false only. Everytime we need to set it as "true" using overrides drop down.

    Applicable for discovered using "Servers and Rack Workstation Monitoring".(FMP -> Servers and Agent Free Monitoring -> Enable Agent Proxing). 

    Override is works here and provides the functionalities like. If there is no agent proxy enable is not required then it shows the below message

    "INFO: There are no Agent Managed computers or Dell Servers (Agent-based) that need Agent Proxying.
    Done"

    And another one is, suppose if the user is not selected the override value Drop down to "true". Then it will show as below

    "WARNING: To run this task, Auto Resolve Warnings/Errors should be true
    Success"

    Please try this if it works. Otherwise I will share the process with snapshots .

    Thanks,

    Sai

  • Hi and tnx for your help,

    sry but not sure where i can find the "Servers and Agent Free Monitoring" in the Future Mgmt Dashboard.

    Also i don't understand why he want to enable the Proxy on virtual machines.

    Br

    Sergej

  • Hi,

    any news?

    Still get a lot of alerts, if our virtual servers reboot.

    Br

    Sergej

  • Hi

    In the Feature management dashboard, it will be populated.

    I will send the screenshot for same.

    Thanks,

    Sai