DSDP 3.0 - Question download and execute? - OpenManage Integrations with Microsoft SCCM and SCOM - Systems Management - Dell Community
Systems Management Forums

DSDP 3.0 - Question download and execute?

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

DSDP 3.0 - Question download and execute?

  • Hi,

    I'm testing some of the OSD deployment functionality of the DSDP 3.0 in our development environment.  I was able to capture the settings that I like and was able to deploy these configurations to a test server.    However, it seems like in order for the DSDP tools to work, the Task Sequence deployment must be set to "run over the network" "instead of the download and execute". 

    Does anyone know if this is true requirement? 

    When I tried the DSDP Task Sequence in our DMZ where only DOWNLOAD and EXECUTE (port 80) is available.  (SMB is blocked to the DP's).  The deployment will not work..

  • Are you using stand alone media ?

  • nope

  • Can you attach smsts.log file.

  • Hi.. I'm just looking for the basic requirements of using the tool.

    Can Download and Execute be used to provision an OS with, say, the Dell toolkit actions to create a RAID set and set the BIOS options.

    In my testing, the answer is no.  You must use Run over the Network type of deployment.  However, I need to confirm this.  I believe I saw notes about this in the Dell documentation but am having trouble finding at the moment.   I will look again.. and post the if I find first.

  • http://www.dell.com/support/manuals/us/en/04/Topic/dell-srvr-dplymnt-pck-v2.1-for-systm-center-config-mangr/DSDPv2_1UGPubs-v3/en-us/GUID-AF143621-C5AA-4008-9A39-6F0A9D2CAAC5

    I think you are talking about this.

  • Yes, this is similar to what I am referring to.  Though this document is for an SCCM 2007 and an older DSDP.. but this is similar to what I found in the modern documentation.

  • Unfortunately, changing the deployment option to “download content” will not be possible if you are doing baremetal deployments where the RAID controller has not been configured, and at least one logical drive has not been partitioned and formatted for use.  This is because there simply is no place to download the scripts and other packages to so they can run locally. 

     

    The only possible solution I have been able to come up with would involve taking all of the scripts and adding them into the boot image so that they are available on the X drive.  But that would require writing new scripts, gathering all of the necessary files and injecting them into each boot image that might need this functionality.  But then you would only be able to have one set of configurations for all machines this way.  That would certainly be very time consuming and is not something that will be supported.

     

    When running the task sequence with the deployment set to “download content” we get see:

     ---------------

    DownloadOnDemand flag is true. Attempting to download content locally for Package XXXXXXXX.                InstallSoftware 8/25/2015 5:17:34 PM    1888 (0x0760)

    pszNewPath[0] != L'\0', HRESULT=80070057 (e:\nts_sccm_release\sms\framework\core\ccmcore\path.cpp,469)                InstallSoftware 8/25/2015 5:17:34 PM    1888 (0x0760)

    RecursiveCreatePath(sPath.substr(0, nPos), psa), HRESULT=800700a1 (e:\nts_sccm_release\sms\framework\core\ccmcore\path.cpp,104)     InstallSoftware 8/25/2015 5:17:34 PM    1888 (0x0760)

    DownloadContentLocally (pszSource, sSourceDirectory, dwFlags, hUserToken, mapNetworkAccess), HRESULT=800700a1 (e:\nts_sccm_release\sms\framework\tscore\resolvesource.cpp,3582)      InstallSoftware                8/25/2015 5:17:34 PM    1888 (0x0760)

    Failed to resolve the source for SMS PKGID=XXXXXXXX, hr=0x800700a1

    ---------------

     

    There are several more lines in the same operation of trying to create a folder structure and download the content.  These errors mean that first it can’t create the folder structure anywhere since the WinPE scratch space is the only location that is currently accessible.  And then that the local source cannot be found, since it wasn’t able to download it locally.

     

    Here are several more links that discuss the same issues.

     

    http://elgwhoppo.com/2012/07/02/today-in-my-scc/ - “…the task sequence deployment option could be set to “Access content directly from a distribution point when needed by the running task sequence”.  I needed to this because when running a task that needs to access package content before the local disk is partitioned there is nowhere to download the data to, so it must be run directly from the distribution point.”

     

    This forum post is the exact same error and the answer came from an SCCM MVP who says, in different words, that you have to have a drive ready to download content to.  https://social.technet.microsoft.com/Forums/systemcenter/en-US/3e1c8d51-9b5e-4021-9ab5-854e860f736c/error-failed-to-resolve-the-source-for-sms-pkgidgrp03bf4-hr0x800700a1?forum=configmgrosd

     

    http://sccm2o12.blogspot.com/2010/07/troubleshooting-winpe-and-task-sequence.html - Task sequence fails because the package is not downloading

    In WinPE, the default option of “Download content locally when needed by running task sequence” will not work. When in WinPE, the task sequence engine will ignore (and fail) all actions that have packages set for this option.

    Set all packages needed for use in WinPE to “Access content directly from a distribution point when needed by the running task sequence.”