Issue with Dell Server Management Pack 5.0.1 on SCOM 2012 SP1 - OpenManage Integrations with Microsoft SCCM and SCOM - Systems Management - Dell Community
Systems Management Forums

Issue with Dell Server Management Pack 5.0.1 on SCOM 2012 SP1

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Issue with Dell Server Management Pack 5.0.1 on SCOM 2012 SP1

  • Hi,

    We have SCOM 2012 SP1 running on Windows Server 2008 R2, I have installed the Dell Server Management Pack 5.0.1 and imported the Server (In-band) Monitoring feature.

    Since installing this feature we are unable to create any dashboards or performance views in SCOM. I am trying to create a dashboard looking at specific ports on a network device using a performance widget, but when you try to search for the specific port to monitor, the search times out and reports an error. The error received is: 

    Please provide the following information to the support engineer if you have to contact Microsoft Help and Support :
    Microsoft.EnterpriseManagement.Presentation.DataAccess.DataAccessDataNotFoundException: Exception reading objects ---> Microsoft.EnterpriseManagement.Common.UnknownDatabaseException: The query processor ran out of internal resources and could not produce a query plan. This is a rare event and only expected for extremely complex queries or queries that reference a very large number of tables or partitions. Please simplify the query. If you believe you have received this message in error, contact Customer Support Services for more information.
       at Microsoft.EnterpriseManagement.Common.Internal.ServiceProxy.HandleFault(String methodName, Message message)
       at Microsoft.EnterpriseManagement.Common.Internal.EntityObjectsServiceProxy.GetManagedEntitiesByManagedEntityTypesAndCriteriaWithInstanceQueryOptions(IList`1 managedEntityTypeIds, IList`1 managedEntityBaseTypeIds, IList`1 criterias, String languageCode, InstanceQueryOptions instanceQueryOptions)
       at Microsoft.EnterpriseManagement.InstancesManagement.GetObjectsReaderInternal[T](ICollection`1 criteriaCollection, ObjectQueryOptions queryOptions)
       at Microsoft.EnterpriseManagement.Management.DataProviders.ManagedEntityProvider.GetManagedEntitiesByClass(ICollection`1 baseTypeNames, String criteriaString, List`1 valueDefinitions, List`1 sortValueDefinitions, Int32 maxEntities, String typePropertyName, String typeWithIconPropertyName, Boolean propertyCollectionRequested)
       --- End of inner exception stack trace ---
       at Microsoft.EnterpriseManagement.Presentation.DataAccess.DataProviderCommandMethodInvoker.Invoke()
       at Microsoft.EnterpriseManagement.Monitoring.DataProviders.RetryCommandExecutionStrategy.Invoke(IDataProviderCommandMethodInvoker invoker)
       at Microsoft.EnterpriseManagement.Presentation.DataAccess.DataProviderCommandMethod.Invoke(CoreDataGateway gateWay, DataCommand command)
       at Microsoft.EnterpriseManagement.Presentation.DataAccess.CoreDataGateway.ExecuteInternal[TResult](DataCommand command)
       at Microsoft.EnterpriseManagement.Presentation.DataAccess.CoreDataGateway.<ExecuteAsync>b__0[TResult](<>f__AnonymousType0`1 data)

    This only started happening after importing the Server (In-band) Monitoring feature into the MP. As soon as I remove the Dell Server Management Pack 5.0.1 from our SCOM server, I am able to search for specific ports etc without issue.

    Has anyone experience this issue or similar issue? If so, is there any fix for this?

    Thanks in advance.

  • Server MP 5.0 will not affect the SCOM functionality.

    Any way can you please specify the problem steps clearly like

    After selecting new dash board view and performance widget,

    what is the Group/Object you selected ?

    Under Object what are the properties you selected?

    Please mention the steps so that i can work on repro and get back to you

  • Hi,

    Here are the exact steps I am taking:

    Create a new Dashboard View with a Grid Layout

    Click the option called 'Click to add widget....' which runs the 'New Dashboard and Widget Wizard'

    Choose to create a new 'Performance Widget'

    Give the Widget a name and description then clicking next

    Here is where the problem is. I click on the button to browse for a particular object to monitor. When the new window appears, I select 'Groups and Objects' and then enter a specific port name which is located on a switch currently being monitored by SCOM. For example 'Port-1.5'. I then click search, but after approx 3 minutes of searching I receive the error message stated above. i have tried various different ports and interfaces etc but the same error appears every time.

    This started happening as soon as I installed the Dell MP. As soon as I remove the MP I can search for objects successfully again.

    Please let me know if you need any further information.

    Thanks

  • Exactly the same problem for me!

    Thanks,

    Bernd

  • Server MP 5.0.1 will not monitor the switches. I am unable to work on repro as we won't support monitoring for switches. Can you tell me how you are monitoring the switches.

  • Hi,

    I think you have misunderstood. I am not using the Dell MP to monitor switches. I am using the built-in network monitoring feature within SCOM 2012 to monitor switches. But once the Dell MP is installed I am unable to add any new ports or interfaces to monitor as explained in my previous posts (using the built in network monitoring).

    Thanks

  • Do you have any update on this?

  • Hi!

    I have the same problem, anyone know how to solve this?