OME 2.3? - Dell OpenManage Essentials - Systems Management - Dell Community
Systems Management Forums

OME 2.3?

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

OME 2.3?

  • The form one fills out to download OME says it's for version 2.3.  If you fill out the form, you get a download button.  You click the download button and are presented with a page stating the file you seek cannot be found.

    Is 2.3 available or not?

  • Hi,

    The 2.3 release is in progress and hence you might be seeing the changes. It will be available soon.

    Thanks,
    Vijay

  • I am sure you are aware. OME 2.3 is available now!

    Do visit: en.community.dell.com/.../1989.openmanage-essentials

    Thanks,

    Shivendra

  • Wish we could skip the form instead of filling it out every time a new version comes out.  When clicking the link from within OME, it should go directly to the download page and not to the stupid marketing form.

  • I'll take that sentiment a step further - the download of the updated version should be available from within the current version.  From there, you could chose to stage, verify prerequisites, or upgrade.

  • Thanks for your valuable feedback and suggestion.

    Thanks,

    Shivendra

  • Yes, this!  The pre-download form is super annoying.

  • If you want to skip the pre-download form, download it from the Dell Support website drivers & downloads page for your particular server. It will be under the Systems Management section.