VMware ESX 4.x Inventory Issue - Dell OpenManage Essentials - Systems Management - Dell Community
Systems Management Forums

VMware ESX 4.x Inventory Issue

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

VMware ESX 4.x Inventory Issue

  • I must be doing something stupid... Huh?

    We are running ESX 4.0 (not ESXi) and have installed OMSA 6.5 on all of our servers. I have configured SNMP on the ESX host servers and we are able to access the OMSA Web interface on all of the servers  so I know OMSA is installed properly. The issue is that in OME they show up as a VMware ESX Server but purple, it has some basic information (vm guests running) regarding the server but not the service tag, model, etc... So I am missing something here just not sure what.

    Any input would be great?

  • Hi Ron,

    Setting ESX and ESXi up for management does take a bit of effort :-)

    I meant to post a tutorial on this, so thanks for the reminder.  Have a look at this new thread and see if it helps.

    Let me know,



    DELL-Rob C
    Social Media Support

  • I have that process already.....

    I have installed OMSA with the -x switch to install everything and enabled the vnware firewall port 1311 to access the web console.

    I have configured SNMP and tested it with the Dell Troubleshooting tool and it is configured properly.

    After that I am stuck, I get minimal iformation about the servers, as I said no Dell specific info. Is there something else that neesd to be open in the ESX firewall cfg?

  • Thanks.

    Just to confirm.  When you did the SNMP test in the TS tool, you saw the OMSA version return in the success message.  Is that correct?

    Also a few other config items to review:

    • chkconfig snmpd on

    • Since SNMP is not started by default, this command ensures it will be started after a reboot of the ESX server.

    • esxcfg-firewall –e snmpd

    • This command line allows SNMP traffic through the built-in ESX firewall.


    DELL-Rob C
    Social Media Support

  • We've also seen a reboot may be required as some of the omsa services don't always get started right (for whatever reason).

    The TS results should look similar to below:

    DELL-Rob C
    Social Media Support

  • Thank you for the pic of your TS, getting closer.

    I dont see the Server Administrator or the Inventory Collector in my results for SNMP, Odd!!!

    OMSA is fully installed, used the -x switch and I am able to access the OMSA web interface on the ESX hosts so I know its installed and working.

  • Ok, what about my post from 2:51pm?  Anything useful there?  Looks to be some last config item on ESX to iron out...hmmm...

    DELL-Rob C
    Social Media Support

  • I did both of those command prior, sorry should have said that. I restarted the host server as well to get a clean restart and still the same.

  • A few other tips.  I think you've tried a few of these but I will include all for others.

    1. Reboot target if not already done

    2. Check snmp settings

     Check the SNMP settings as shown in the OMSA installer guide, Page 37 here:

    <ADMIN NOTE: Broken link has been removed from this post by Dell>

    3. Check omsa services running

    [root@PE2950-ESX4U1 ~]# rpm -qa | grep srvadmin
























    4. Uninstall OMSA, reboot, re-install OMSA, reboot, try t-shoot tool again

    DELL-Rob C
    Social Media Support

  • Another tip from a buddy of mine...

    If he is able to view the OMSA web console page for the ESX server, but not see the data in the TST, you may need to add the proxy line (step 2 below) in the snmpd.conf file….

    To configure the proxy and enable the VMware SNMP agent

    1 Stop the snmpd service through the service console on the ESX host.

    service snmpd stop

    2 Add a proxy line to /etc/snmp/snmpd.conf.

    proxy -v 1 -c public udp: .

    In this example, -v 1 reports the Net‐SNMP version to proxy, -c specifies the community string for

    Net‐SNMP, udp: specifies the localhost IP address and the port number for the VMware

    SNMP agent to proxy through. This example uses port 171 (you might choose a different port number).

    The port number must be the same as the one you specify for the VMware SNMP agent, as described in

    the next step. refers to the enterprise object identifier (OID) of the VMware MIBs.

    3 Using the VMware vSphere™ CLI, configure /etc/vmware/snmp.xml to bind the VMware SNMP agent

    to port 171 and start the service.

    vicfg-snmp.pl --server <hostname|IP address> --username <username> --password <password> -E -c

    public --port 171

    In this example, -E enables the VMware SNMP agent, -c public sets communities to public, and

    --port 171 changes the default port of the VMware SNMP agent to 171.

    The command adds the following entries into /etc/vmware/snmp.xml (VMware recommends you use

    the vicfg-snmp.pl command to change this file instead of editing the file itself):






    <targets>IP address@162 private</targets>



    4 Restart the mgmt‐vmware service (hostd) and the snmpd service. On the ESX host from the service

    console, use these commands.

    service mgmt-vmware restart

    service snmpd restart

    DELL-Rob C
    Social Media Support

  • source doc for prev post:


    DELL-Rob C
    Social Media Support

  • I started working on the Procy config and still had a problem.... but I finally figured it out. I missed a line in the snpd.conf file com2sec notConfigUser default <community_name> once i set that and restarted everything, it is up and running....

    Thank you or all your help.

  • Hey that's great news Ron.  Thanks for taking time to provide feedback on OME OpenEval.  Please post any more updates or questions for the forum.


    DELL-Rob C
    Social Media Support

  • Guys!  Very timely advice.  I have been battling this for the last week with bits and pieces of information from VM, Dell, and other tech sites.  You provided me with the last steps.  Thanks a bunch.  I can probably turn a weeks work into 15 mins now.

    I am/was trying to get an ESX4 (PE2900) with Server Administrator 6.5 to talk to my W2K8 OpenManage Essentials Manager (PE T310).  It is now working thanks for the help.

  • I'm really glad to hear that.  Please keep us updated on your progress with OME on the forum.

    Best regards,


    DELL-Rob C
    Social Media Support