Can Not Inventory iDRAC hosts, returns "unknown" host. OME 2.3 - Dell OpenManage Essentials - Systems Management - Dell Community
Systems Management Forums

Can Not Inventory iDRAC hosts, returns "unknown" host. OME 2.3

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Can Not Inventory iDRAC hosts, returns "unknown" host. OME 2.3

  • Hi,

    I'm using a Windows 2012R2 system, looking to better manage R730 systems. Firmware on the systems is at 2.43.43.

    When I go to inventory the systems, they show up, but as "Unknown". 

    Here's the error I get:

    Using TLS 1.0 for SSL/TLS handshake.
    Error: A complete request could not be sent to the remote server.
    Using TLS 1.1 for SSL/TLS handshake.
    TLS 1.1 Handshake successful.

    The WS-Man target has TLS 1.1 enabled. If OME is unable to discover this device, install the required updates on the system where OME is installed. For more details, see “Enabling support for TLS 1.1 or 1.2” at delltechcenter.com/ome.

    I read a post about the 'easy fix', but that doesnt apply to Windows2012R2 systems.

    Any suggested support path here?
    Thanks!

  • Hi, thanks for the query.

    You can set the registry keys manually if the easy-fix does not apply. After making the changes, reboot the system to proceed. Directions from the MS KB below:

    The DefaultSecureProtocols registry entry can be added in the following path:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp

    On x64-based computers, DefaultSecureProtocols must also be added to the Wow6432Node path:

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Internet Settings\WinHttp

    The registry value is a DWORD bitmap. The value to use is determined by adding the values corresponding to the protocols desired. 

    Take the value for TLS 1.1 (0x00000200) and the value for TLS 1.2 (0x00000800) then add them together in calculator (in programmer mode), the resulting registry value would be 0x00000A00.

    Thanks,

    Shivendra

  • Hi,

    I implemented the registry settings you suggested. I'm still showing hosts as 'unknown'.

    As a test,  spun up a second vm, implemented the settings, still showing as unknown. 

    What else should I be doing to remedy the issue?

    Thanks

  • Are you having latest Windows Updates also installed on the operating system?

    Thanks,

    Shivendra

  • Hi,

    Thanks for responding. I'm still not able to properly access using wsman from my ome host. I did confirm the host wasnt fully updated, but now it is. I've also removed and readded the the two registry entries... still not able to access. 

    Here's what my registry entries look like... (see attachment)

  • Can you try setting it to 0x00000A00 (followed by reboot) and see if it works out?

    Also check what are TLS settings on target iDRACs. They should also be configured for 1.1 and above.

    Thanks,

    Shivendra

  • Hi,

    Thanks again. 

    I've updated the registry setting, and its now displaying what you included in your attachment. I rebooted once the setting was put in place -- still shows systems as 'unknown'. I've confirmed the TLS status on the drac is set to 1.1+...

    Not sure what I'm missing here, any ideas?

    Appreciate you help!

  • Running out of ideas now. I would recommend you to get in touch with Dell Support to resolve this problem.

    Thanks,

    Shivendra

  • Hi,
    Thanks for the reply.

    I am able to add the hosts in via snmp, just not using wsman. 

    If you are out of solutions or ideas I'll reach out to support.

    Thanks,