Discovery of I/O modules in FX2s chassis - Dell OpenManage Essentials - Systems Management - Dell Community
Systems Management Forums

Discovery of I/O modules in FX2s chassis

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Discovery of I/O modules in FX2s chassis

This question is not answered

We are doing inventory and discovery of our FX2s chassis via the "Chassis (CMC) Discovery - All Components" device type, which uses WS-MAN. Our CMC, servers, and I/O modules are all discovered as expected.

However, when I go to the Discovery Range Details page in OME for my I/O modules, it shows the discovery range configuration is using ICMP and SNMP. Is this expected, and where does OME get the SNMP Community value from, as it can't be set in the discovery configuration?

All Replies
  • Hi, thanks for the query.

    Yes, this is expected. I/O modules are discovered using SNMP protocol.

    The chassis facilitates the community name required to discover the I/O modules. This information is only available once OME successfully connects to the chassis over WSMAN protocol.

    Thanks,

    Shivendra

  • Thanks for the reply.

    Where do I set the community name required to discover the I/O modules?

  • Hi,

    There are two ways you can set community name to discover the I/O modules using CMC discovery in OME:

    1. In the CMC UI, go to IO module overview->setup screen and there will be provision to configure community name for each IOA (sample screenshot attached here) (Recommended).

    2. Also, in the respective IOA UI, the SNMP settings can be done in initial setup.

    Now, as Shivendra mentioned above, when OME discovers the CMC, the CMC provides details about the IOA IP and community sting which is used by OME to inventory the IOAs.

    Thanks,
    Vijay.

  • Thanks, but I don't appear to have that option in my FX2s CMC GUI:

  • Hi,

    Thanks for the details.

    Can you share the details of the firmware of FX2 and IOMs and mode of the IOMs?

    For FX2 also, the option is available unless the IOM is in mode like "Full Switch" which is not managed by CMC. (screen below - the switch in A2 is in full switch mode where the option is not available).

    NOTE: Automatic discovery of IOA switches is supported only if CMC firmware version 5.1 or later is installed on PowerEdge M1000e and CMC firmware version 1.3 or later is installed on PowerEdge FX2/FX2s.

    Thanks,
    Vijay.

  • I'm up to date on the CMC firmware, and the IOMs are in "Full Switch" mode, so where is OME getting the SNMP community name? Is it from the upstream switches?

  • Hi,

    The community name should be something like "N/A" in this case.

    Can you try the below command and confirm the output if that is the case for full switch IOMs.

    winrm e schemas.dell.com/.../Dell_IOMPackage -u:<username> -p:<password> -r:https://<ip>/wsman -SkipCNcheck -SkipCAcheck -encoding:utf-8 -a:basic

    If it is not "N/A", then try resetting the CMC and try again.

    Delete the IOM discovery ranged in OME and rediscover the CMC. OME does not discover the IOM if the community string is "N/A" which should be the case in full switch IOMs.

    Thanks,
    Vijay.

  • Hello,

    Thanks for the reply. Can you give me the full command you want me to run? The website seems to have truncated it.

    Also, where am I supposed to run this command?

    Thanks.

  • Hi,

    Attaching the command so that it does not get truncated.

    Thanks,
    Vijay.

  • Hi,

    You can run the command from the command prompt from the box where OME is installed.

    Thanks,
    Vijay.

  • Thanks. I tried running the command but it came back with an "Access is denied" error. Not sure why - OME can use WS-MAN with the same credentials to log into the chassis without a problem.

    Error number:  -2147024891 0x80070005
    Access is denied.

    The OME troubleshooter also is able to connect via WS-MAN.

  • Hi,

    This is strange that winrm command is not working with same ip/credentials.

    However, this is what should be happening in the original case you mentioned:

    a.  If CMC is providing community string value, OME will discover that IOM ("CMC reset" clears the community string value for IOMs in full switch mode.)

    b.  If CMC is not providing community string value (value N/A), OME will not discover that IOM.

    Try deleting, the IOM IP range in OME and rediscover the CMC to see if IOM IP range re-appear. If it does, then it can be due to case a.

    Thanks,
    Vijay.