Discovering ESXi5.0 - two issues - Dell OpenManage Essentials - Systems Management - Dell Community
Systems Management Forums

Discovering ESXi5.0 - two issues

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Discovering ESXi5.0 - two issues

  • We  upgrade our virtual environment to ESXi5.0Update1 and we are experiencing problem : OME doesnt properly discover  ESXi5.0Update1 server.
    We assure you that we've got well installed and configurated latest updates of software.

    As OMSA WebServer works properly, we caught  packets transmition between OMSA and ESXi5.0 and compared with similiar transmition between OME and ESXi5.0.

    Packets analyse shows that autentication goes correctly in both cases and sessions starts.  OMSA session goes seamlessly.  OME session starts with


    and after response : VMWare ESX5.0, OME queeries


    on this querry there is no response - it seems that there is no such object on  ESX , session  ends rapidly with no retrys.

    OME correctly discovers servers ESX 4.1


    The second issue is that OME uses only one protocol to discover server. When you use SNMP you get another set of parameters then you use WSMAN, but both  consist of valuable information.

     Can we possibly ask DELL to enable multiprotocol discovery?

  • Hi and thanks for the post.

    Just to clarify, are you saying that you had OME discovery working ok for ESXi5...but then you udpated to "update 1" and it does not work?



    p.s.  also note the whitepaper on for setting up ESXi...

    DELL-Rob C
    Social Media Support

  • No, we just use Update1 . We didn't try to discover ESX 5.0 without Update as we didn't have one.

    thanks for p.s.


  • Regarding the multi protocol discovery, OME does allow that. There is a priority order for protocols and usually SNMP is higher priority since it is commonly used across wide range of devices and it provides most amount of information for physical servers.

    Regarding ESXi, WS-MAN protocol provides more information than SNMP. OME doesn't really get much information outside of WS-MAN for ESXi.

    For ESXi 5.0 update 1, you will have to install OMSA 7.0 VIB available here:



  • I embraced that link & kissed both chicks :)

    Thank you, Abhijit


  • You are welcome Andrzej. Let us know how it goes.

  • Cant get the OME to inventory my ESXi 5.0 U1 server. Just installed both OME and ESXi 5 so it has never worked.

    I installed the "" and restarted.

    Did a "esxcli software vib list" and it says "OpenManage 7.0-0000 Dell VMwareAccepted  2012-03-21"

    Then I did a new discovery with only one ip-address in it and disabled all other tests then WS-man.

    In WS-Man settings I put User ID: root

    Password: same as the servers ssh use (Here is where im not sure if that is right)

    Secure Mode: yes (Port changed to 443)

    Skip Common name check: yes

    Trusted Site: yes

    But still only get "Unclassified" and not a ESX

    Any advice?

  • The credentials and discovery settings look alright. Did you get the chance to look at the white paper below?

    You can also use the Dell Troubleshooting tool WS-MAN test to verify that the port and credentials are working for connecting to the target IP address.

  • Done all that in the PDF file.

    Still no luck.

    And when I run the DTT WSMAN test I get this error:

    Protocols Selected are:


    Error An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)

    But I get the same error when I try on any server that dont even got agent installed.

  • Thanks for the update.

    Are you getting this error from DTT for running WS-MAN test or any other test. Just want to check if DTT is running any test at all?

  • Tried a few of the test (Database, Name Resolution and SSH) and it works fine.

    Im using version 1.0 of the Dell TroubleShoot Tool.

    Tried to connect to a blade chassie with WSMAN but the same error.

  • There is version 3.0 of troubleshooting tool which ships with OME 1.0.1 release. You might be able to uninstall DTT 1.0 and install 3.0. It may help to debug this.

  • Ah, yes. Found it.
    Ok, so the test on the chassie was Ok and now even the test with ESXI is ok :-)

    So on a ESXi with out the OM installed:

    WSMAN profiles found on the remote device are:
    1. Job Control
    2. Software Update
    3. PCI Device
    4. Software Inventory
    5. Indications
    6. IPMI OEM Extension
    7. Sensors
    8. Software Inventory
    9. Profile Registration
    10. System Memory
    11. Record Log
    12. CPU
    13. Fan
    14. Base Server
    15. Battery
    16. Physical Asset
    17. Power Supply
    18. Power State Management


    On a ESXi with OM installed:

    WSMAN profiles found on the remote device are:
    1. Job Control
    2. Software Update
    3. PCI Device
    4. Software Inventory
    5. Indications
    6. IPMI OEM Extension
    7. OpenManage
    8. Sensors
    9. Software Inventory
    10. Profile Registration
    11. System Memory
    12. Record Log
    13. CPU
    14. Fan
    15. Base Server
    16. Battery
    17. Physical Asset
    18. Power Supply
    19. Power State Managemen

    So it is there but still dont it to work in OME
    Still progress :-)

    One question. When I edit the Discovery Range of the one I did the password is blank again. It feels like that may be the problem.

  • Oh, its working. Changed the timeout and retries in the test.

    Got a few more ESXi to try on before I can say I made it! But that is for tomorrow to tell

  • Thanks for the updates.

    If you edit the existing discovery range the passwords have to be entered again for security reasons. If you don't edit the ranges, discovery will run on schedule and you will not have to re-enter passwords.