Re-installation unable to find local SQL instance - Dell OpenManage Essentials - Systems Management - Dell Community
Systems Management Forums

Re-installation unable to find local SQL instance

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Re-installation unable to find local SQL instance

  • Greetings,

    I had to re-install our test copy of OpenManage due to a crash, and during the installation procedure the installer is failing to locate the SQL server that the dependancy scanner installed in the previous step.

    I have verified that it is running and can access it from a remote machine running SQL Server Management Studio with both user and admin credentials.

    Even after entering my own domain admin credentials when connecting, I am not presented with the correct selection during the configuration of OpenManage.

    Does Dell have any troubleshooting tips they recommend to diagnose such issues?

  • Hi,

    Thanks for the post. Can you confirm if you are using default install or custom install option?

    Can you do a custom install and type in the name of the local SQL Server?




  • Greetings,

    I had actually tried both options, with the same result. I actually ended up completely removing the SQL server instance and IIS role at the same time and rebooting the server, which resolved the problem.

  • I have the same issue trying to reinstall.  I receive the following error:

    Message:  [Microsoft][ODBC SQL Server Driver]Login timeout expired


    I have tried removing SQL and IIS and I still receive the error.

    If I try the custom option, the database server is listed as (local)\SQLEXPRESS, I select Windows authentication, and use a domain account with local admin rights, and I get:

    Cannot connect to '(local)\SQLEXPRESS'.  Login failed for user '<domain\user>'

  • Thanks for the post.

    To characterize this correctly, you are saying you don't have SQL and IIS currently installed on the server. After that you installed SQL server and tried to run OME installer in custom mode and you are getting the error while connecting to the SQL server. Is my understanding correct?

  • I solved the issue by uninstalling/reinstalling Microsoft Visual C++ 2008 Redistributable -x86

    When I was getting the errors, I was trying to re-install using the Typical settings option and I received the Login timeout expired error.  If I clicked Back and selected Custom, I got login failed for whatever user I tried to use, local or domain account.

    If you're curious, this is the sequence of events:

    I had OME Eval installed with the included version of SQL Express, and set a discovery IP range of 12 servers, but only 11 showed up.  All 12 worked on an older version of ITA as well as an OME server I had setup on our production network.  I tried to perform another discovery/inventory only to find that the tasks would not submit (no errors)

    I upgraded to the just released 1.0.1 version only to have the same issue.

    I uninstalled OME and SQL, rebooted, tried to reinstall, only to get the errors I posted above.

    I uninstalled OME, SQL, and IIS, rebooted, same problem

    I noticed that the SQL instance name was different between the Eval and 1.0.1 versions (MSSQLSERVER vs SQLEXPRESS) as well as some of the SQL configuration settings (SQL Server Browser Enabled vs Disabled) so I tried re-installing the OME Eval version, same problem.

    Then I uninstalled/reinstalled the Visual C++ component, and OME 1.0.1 installed with no issues.  All 12 servers showed up

  • Thanks for the updates. I'm glad to hear that the issue is resolved for you. Let us know if you have any feedback regarding OME features.