Systems Management Forums

Inventory DMZ Server

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

Inventory DMZ Server

  • Hi There,

    This is another port related question - i've reviewed some of the threads about this and have opened ports 161/162, 1311 and 2794 between my OME server and my DMZ server.

    I am unable to inventory the server out in the DMZ.

    I have verified SNMP connectivity (I can do SNMP gets so port 161 is working properly)

    I can also connect to OMSA via port 1311.

    Any idea which port (or set of credientials) specifically the inventory uses to gather it's information?

    I've checked through the troubleshooting tools and most of them seem to work


  • Update - looks like SNMP has managed to grab some of the information (it now knows it's a server) but it's incomplete - can't grab the service tag or the model, health status is unknown

  • if you are not passing snmp information you could be getting some information from the WMI.  i would suggested verifying the community name(case sensitive) and then running the troubleshooting tool on snmp to see what mibs are responding.  (you should get your open manage version and not just your hostname)

  • Seems that SNMP is working, but WMI is not (maybe i need additional ports for WMI to work?)

    Here's a screenshot of the troubleshooting tool for SNMP and below it, you can see what is returned - (if you go into the details, a lot of the information is listed, but no service tag or model and no health status)

    Edit - removed screenshot

  • that all seems correct.  if you get the details of the target it should show you the agents that have been used to gather the information.  

    you don't have to use wmi to gather the proper information.  snmp should be all you need.  

  •  Seems like it's partially working, just missing some info

  • OME seems to be functioning.   does the open manage on the server show the hardware?

  • yes, seems to be OK on OMSA

    Edit - removed screenshot

  • Hi Blake, thanks for the questions.

    Can we try this:  Delete your other disc ranges and just create a single range that just has that single ip address of the server itself (not the drac) and only snmp protocol.  That way we can ensure nothing else is getting overwritten.

    Not sure if this is a production system or a lab where you can play around, but if we can try this test, it would help.

    Agree that the TS tool seems to indicate SNMP and OMSA are good on the box.


  • actually it's already setup like that - we only have 1 server out in the DMZ, so i didn't bother with an IP range - just the single IP

    It originally had WMI and SNMP but i have removed WMI.  I deleted the device from the "servers" list and did a new discovery and inventory

    It's production, but not a critical system...

    Same result


  • Thanks Blake.  Something is up here.  I'll need to see if you can open a ticket at 800-945-3355 .  They can collect more data and see what the issue is.    If you feel like digging more you can get a mib walk tool like mg-soft (demo) and  do an SNNP walk of .  branch to see how that looks.

    Thanks for your feedback thus far.


  • Tried the MIB browser from the OME server to the DMZ IP on that OID.  seems like everything is good there:  (i ommitted the service tag but it's in the MIB walk as well)

    3759: internet.4.1.674.10892.1.300. (octet string) Main System Chassis [4D.61.69.6E. (hex) Size = 19]

    3760: internet.4.1.674.10892.1.300. (octet string) Dell Inc. [44.65.6C.6C.20.49.6E.63.2E (hex) Size = 9]

    3761: internet.4.1.674.10892.1.300. (octet string) PowerEdge 2900 [50.6F. (hex) Size = 14]

    3762: internet.4.1.674.10892.1.300. (octet string) (zero-length)

  • Ok, good data.  But still odd and unexplainable here :)  Need to see if you can open a ticket.  Does this happen if you try to discover a different server?



  • Only have 1 physical server out in the DMZ :)

    all other servers internally are reporting correctly

    Unfortunatley i'm away for a few week from work, so will have to open a ticket when i get back - maybe OME 1.0.1 will be out by then :D