racadm unable to connect after firmware upgrade to 2.41.40.40 - Dell Systems Management General Forum - Systems Management - Dell Community
Systems Management Forums

racadm unable to connect after firmware upgrade to 2.41.40.40

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

racadm unable to connect after firmware upgrade to 2.41.40.40

  • Hi,

    I have several R730 with iDRAC8 Enterprise.

    I used racadm utility on Linux Centos 6.6 to connect to iDRACs, to power up/down servers.

    After upgrading iDRAC firmware from 2.10.10.10 to 2.41.40.40 I can no longer connect to iDRACs.

    # racadm -r <IP> -u root -p <PASSWORD> getsysinfo
    ERROR: Unable to connect to RAC at specified IP address.

    At the same time using racadm to connect to another server with the old firmware works ok.

    The upgraded server has proper IP settings, ping works, web management works well, Remote RACADM is enabled.

    Also ssh root@IP to the upgraded server's idrac works:

    # ssh root@IP
    Password: ***********
    /admin1-> getsysinfo
    [a lot of interesting output goes on]

    Can it be a problem related to SSL?

    # yum list installed | grep openssl
    openssl.x86_64 1.0.1e-30.el6.8 @updates
    openssl098e.x86_64 0.9.8e-18.el6_5.2 @base

    I've even upgraded racadm to the latest version from OM-MgmtStat-Dell-Web-LX-8.4.0-2193_A00.tar.gz and still no luck with racadm.

    Any help is welcome :)

    Kind regards,

    Michal

  • Update to a later version of RACADM.  We had to move to 8.4.0 with the update to 2.41.40.40. RHEL 6.8

    Then check order of operations on the command line.  They've screwed things about.   Next make sure you use --nocertwarn if you don't have your own certs installed.

    Have you strace'd the racadm? are you using the  wrapper or the raw script?

    ie: /opt/dell/srvadmin/sbin/racadm or /opt/dell/srvadmin/sbin/racadm-wrapper-rac5

    Ed

  • You could also run racadm through ssh from a remote server to the drac:

    ssh dracusername@ip racadm getsysinfo

    This does not require racadm to be installed on the remote server.

    If you have ssh keys of the remote server added to the drac user you will not be prompted for a password AND you can pipe to grep the results.

    You said you are seeing odd output when you run the racadm getsysinfo command directly on the drac. Are you not seeing all the normal informational output?

  • Hi,

    Ed, thanks for your suggestions.

    I've updated to 8.4.0:

    # rpm -Uvh --force srvadmin-racadm5-8.4.0-2193.9883.el6.x86_64.rpm srvadmin-hapi-8.4.0-2193.9883.el6.x86_64.rpm srvadmin-omilcore-8.4.0-2193.9883.el6.x86_64.rpm smbios-utils-bin-2.3.1-2193.9883.el6.x86_64.rpm libsmbios-2.3.1-2193.9883.el6.x86_64.rpm srvadmin-racadm4-8.4.0-2193.9883.el6.x86_64.rpm srvadmin-argtable2-8.4.0-2193.9883.el6.x86_64.rpm

    I use just racadm which is located in /opt/dell/srvadmin/sbin/ and is a symlink to /opt/dell/srvadmin/sbin/racadm-wrapper-rac5.

    Still no luck.

    I haven't used strace. AFAIK racadm is a script that finally executes /opt/dell/srvadmin/bin/idracadm with the same command line. I tried to execute it by myself and it returns the same error.

    I wonder if it could be related to openssl library but installing openssl-devel as advised on some blog didn't help.

    Thanks,

    Michal

  • Well, this is my last line of defence it all else fails. :)

    But for future reference I'd like to know the *real* solution and understand the cause of this problem.

    Thanks,

    Michal