OMSA 8.3: "This page can’t be displayed" - Dell Systems Management General Forum - Systems Management - Dell Community
Systems Management Forums

OMSA 8.3: "This page can’t be displayed"

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

OMSA 8.3: "This page can’t be displayed"

  • Had the same issue, and after searching through numerous blogs, sites, and recommended Docs, the only thing I could think to try next (and what was recommended) was a re-install. After going to Uninstall a program I figured I would run the repair option which worked. Don't know how it became corrupt or non-functioning but this worked. Wish I would have attempted this first before spending hours going down the rabbit hole.

  • I am having the same problems using OMSA 8.4.
    i pushed out the update to about 60 servers through OME, and i am not able to open the OMSA web Interface on any of them after.

    OME still have Connection to the servers and does work.

    is there any way to run the reinstall from OME?

  • Hello Svepau,

    Thank you for posting this. Which browser you are using to launch the OMSA? Can you please try to launch with Chrome and let us know the behaviour?

    We have similar issue with IE browser due to Ciphers.

    Regards

    Chandra

  • Hi again.

    i have tried both Firefox and IE from another server.
    i also tried IE and Chrome locally on a few of the servers With this problem.
    IE ESC is disabled.

    it was working through IE on a server i manually updated though.

    the port 1311 is open and connectible but i do not get any response on it. (even tried connecting with telnet)

    when i restart the service the connection to port 1311 closes, but the problem is still there after that.
    restarting the servers with this problem does not help either.

    i did also try a command to generate a New certificate (omconfig) wich said sucess, but that does not seem to work even on the server i updated manually.

    and to be clear, this problem occurs after update from various versons of OMSA both on server 2008 and 2012 + the R2 versions

  • Thank you for your response. Can you please tell us the JRE version OMSA is using on your server where you are observing this issue?

    Please run the following command to get the JRE version:

    omreport preferences webserver attribute=getjre

    Regards

    Chandra

  • JRE Information

    Version : 1.8.0_74 (Bundled)
    Path    : C:\Program Files\Dell\SysMgt\jre

  • Thanks for providing this. Can you also please provide what is the exact error message or code on Firefox when you see this issue?

    Are you seeing the following message ?

    ==================================

    Secure Connection Failed

    An error occurred during a connection to <ServerName>:1311. SSL received a weak ephemeral Diffie-Hellman key in Server Key Exchange handshake message. Error code: SSL_ERROR_WEAK_SERVER_EPHEMERAL_DH_KEY

    =======================================

     Also, Please provide us the latest log files from this location so that we can investigate further

    C:\Program Files\Dell\SysMgt\apache-tomcat\logs

  • i do not get any response in firefox or any other browser, it tries to load the page until i stop the service.

    here is the tomcat log file: http://pastebin.com/RuMxFh4y

    i did not think to read that log.. (i did check Windows eventlog though!)

    as i understand something happened to the keystore.

  • Hi Svepau,

    Thanks a lot for sharing the logs. Looks like keystore password comparison has some issue.

    Meanwhile, Can you please do the OMSA repair on one of the servers and see issue disappears?

    Aslo share us the log file created in the following path: C:\Program Files\Dell\SysMgt\oma\log

    Regards

    Chandra

  • i tried running repair and got an error.

    "Error 1316. The specified account already exists"

    here is the Upgrade log from when i upgraded OMSA: http://pastebin.com/XNvhPh2n

    other than that log there is only omcmdlog and Inventory.xml.1 wich is not empty.

    the info in those does not seem relevant (hardware Inventory and user accounts)

  • Hi Svepau,

    Thank your for providing us these logs. We are looking into this issue. Can you please run the following command which will enable the logs during repair operation and share us that logs?

    Command: msiexec.exe /fpoedcaumsv <MSI PATH>\SysMgmtx64.msi /l*v <LogfilePath>\OMSA_Repair.log

     

    Example: msiexec.exe /fpoedcaumsv C:\OpenManage\windows\SystemsManagementx64\SysMgmtx64.msi /l*v C:\OpenManage\windows\SystemsManagementx64\OMSA_Repair.log

     

    I recommend you to execute the above command with the user who has full administrator previleges.

    Let us know whether you have used user with full administrator rights when you couldn't repair successfully.

    Appreciate your help on this.

    Regards

    Chandra

  • Hello again.

    here is the log from the provided command: http://pastebin.com/TAJa1uPG

  • Hello Svepau,

    Thanks for sharing the logs. We have analyzed the repair logs and found the following:

    During the first time OMSA installation, the MSI file name used was 'SysMgmt.msi'. However, the file name ‘SysMgmt.msi’ used was 64 Bit installer file. Now, the repair operation tried with the MSI with the original file name – ‘SysMgmtx64.msi’, due to that you are experiencing Error – 1316.

     

    So we request you to change your MSI name to ‘'SysMgmt.msi’ and try the same repair operation and see this resolves. Please refer the below example.

     

    Example: msiexec.exe /fpoedcaumsv C:\OpenManage\windows\SystemsManagementx64\SysMgmt.msi /l*v C:\OpenManage\windows\SystemsManagementx64\OMSA_Repair.log

     

    Thanks once again for your continued support.

     

    Regards

    Chandra

  • Hello again.

    i have now renamed the file and ran the command again, this time With no errors.

    i am still not able to Access the OMSA web Interface (same problems as before.)

    here is a link to the log file from the installation: https://1drv.ms/u/s!AgmBd0d81c1Kn5U0OcLd0Pf77_6uNg

    the file was too big to upload to pastebin.

  • Hello Svepau,

    Thanks for performing the repair operation and sending the logs. Based on the repair logs, the repair operation is successful and OMSA is upgraded to 8.4.0 version.

    Can you please double check OMSA connection service (DSM SA Connection Service) is running?

    Also, share us the latest tomcat log and upgrade log from server where this repair operation is successful.

    Please copy the exact error code and message you are seeing.

    Regards

    Chandra