OMSA 7.4.0.2 won't update. Service won't Stop. - Dell Systems Management General Forum - Systems Management - Dell Community
Systems Management Forums

OMSA 7.4.0.2 won't update. Service won't Stop.

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

OMSA 7.4.0.2 won't update. Service won't Stop.

  • So we have an R310 server running Server 2008 R2 SP1 that was running OMSA 6.5.  I saw that 7.4.0.2 was recommended under the Drivers & Downloads page so I decided to install that.  I have to install 7.4.0 first as the 7.4.0.2 file is just a patch.  I got 7.4.0 installed fine and it works fine as well.  However, I then tried to install the patch and ran into a problem.  The patch was hanging at the "Stopping Services" screen and never moved.

    I checked ot services and found that the DSM SA Data Manager service was hung and would not stop.  I couldn't stop it manually and the update program couldn't stop it either.  I ended up having to kill it via Taskkill.  This allowed the installer to continue but if went a bit further and then rolled back the changed and didn't install.

    Since the services were now stopped I tried it again but it did the same thing.

    I tried uninstalling OMSA completely and installing it fresh with reboots between each step but nothing is changing.  The reason I'm trying to get it updated is our OME server doesn't ever get the updated info on BIOS versions and things like that with the 7.4.0.2 version.  OME thinks this server is out of date on most things even though the server itself shows it's up to date.

    Anyone have any idea why this one service isn't working properly and how I can get the x.2 patch installed?

  • I see the same thing here, and killing the datamanager process from task manager is my workaround too.

    Solution to applying the 7.4.0.2 update is simple.

    Open an elevated command prompt (run as Administrator) and invoke OM_7402_Sysmgmtx64_Patch.msp from the commandline.

    Then all will be well.

    Cheers,

    Phil

  • Ah, running it from an elevated cmd prompt seems to have worked.

    Thanks!

  • Hi,

    Just signed up to say this really helped me out. Same scenario with version 7.4.x trying to upgrade to 8.2.0.1793. Failed due to unable to stop the service, googled it, found this. Killed it with TaskMan and now it's removing.

    We're on Server 2008R2 STD and OMSA was a x32 install whereas I'm trying to upgrade (and thus migrate) to X64 so that's another thing it complained about meaning I had to remove OMSA totally.

    Cheers again and have a great week ahead.

  • Thanks for this. I couldn't for the life of me figure out why it didn't want to install.