RACADM command line has certificate error. Anyway to supress "Security Alert" warning? - Dell Systems Management General Forum - Systems Management - Dell Community
Systems Management Forums

RACADM command line has certificate error. Anyway to supress "Security Alert" warning?

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

RACADM command line has certificate error. Anyway to supress "Security Alert" warning?

  • I use RACADM to configure quite a few servers using BAT scripts. Is there anyway to supress the "Security Alert" message without actually using CERTIFICATES? (I really should use CERTS but don't want to manage 100xs of them!)

    Example command:

     racadm config -g cfgLanNetworking -o cfgNicIpAddress 172.21.1.10

    Output:

    Security Alert: Certificate is invalid - Certificate is not signed by Trusted Third Party  

    Continuing execution. Use -S option for racadm to stop execution on certificate-related errors.

    Object value modified successfully

     

    The command works - but I just want to get rid of the warning in bold.

  • The only way to hide this message is uploading a signed certificate to iDRAC.

    Thanks-

    Shine

  • For those of you who google this issue and this is your first hit, but you're reciving this error in Open Manage Essentials -  the answer is that you should NOT include "racadm" in your command line task. So your task should be:

    config -g cfgLanNetworking -o cfgNicIpAddress 172.21.1.10

  • racadm --nocertwarn

    so for example:

    racadm -r 10.10.10.10 -u root -p calvin --nocertwarn set idrac.time.timezone "Europe/Amsterdam"