iDRAC v6 firmware update using racadm from a remote Windows desktop - Dell Systems Management General Forum - Systems Management - Dell Community
Systems Management Forums

iDRAC v6 firmware update using racadm from a remote Windows desktop

Systems Management

Systems Management
Dell Systems Management Solutions: Dell OpenManage, iDRAC, Repository Manager, Microsoft SCCM, Chassis Managment Controller, and more

iDRAC v6 firmware update using racadm from a remote Windows desktop

  • I have an iDRAC v6 with firmware v1.9 that I need to update.  It resides on a dell r610 VMware host.

    The browser based update fails (this is a known problem according to Dell).

    I can putty to the iDRAC and have run 

    racadm fwupdate  -u -g -d "C:\Sources\Dell\iDRAC 6\ESM_Firmware_9GJYW_WN32_2.90_A00.exe"

    where the path is a path on the Windows machine from which I am accessing the iDRAC.  This fails as well.  All other racadm commands I have tried work fine, except the update firmware command.

    Can you provide an example of the exact syntax needed to upgrade v6 iDRAC firmware from a remote windows desktop location.

  • To update iDRAC firmware using SSH you need to use firmimg.d6 file with TFTP server.

    firmimg.d6 file is available @ Link. Download file "iDRAC6_2.90_A00_FW_IMG.exe". this is a self extractable file and once you extract you can get firmimg.d6 file from it. 

    Below is syntax of racadm command to update iDRAC FW with TFTP

    racadm fwupdate -g -u -a < path >

    where path is the location on the TFTP server where the firmimg.d6 is stored including the TFTP server IP address

    Path: < TFTP Server IP > -d < Firmware image path on TFTP server >

    Case1: If firmimg.d6 image is in tftp root folder, path

          racadm fwupdate -g -u -a < TFTP Server IP Address >

    Case2: If firmimg.d6 image is in sub folder of tftp root

          racadm fwupdate -g -u -a < TFTP Server IP Address > -d < Sub folder Path >



  • Thank you for this answer.  These are the details I was looking for.

    But because I don't have a TFTP server handy, we took down the VMware host, booted it using a Server2016 on a USB stick, and ran the windows-64 version of the install program.

    That worked fine.

  • If yo don't want to use TFTP then you can update iDRAC FW remotely using remote racadm. To do this you need to install Racadm SW (Link) on a remote windows machine and run below command to update iDRAC FW.

    racadm -r <iDRAC IP> -u <username> -p <password> fwupdate -p -u -d <Path to folder where firmimg.d6 image available>

    E.g. racadm -r -u root -p calvin fwupdate -p -u -d c:\iDRAC62.90

    Note : This command will take around 15 to 20 minutes to update iDRAC



  • OK.  This is a great tip.  I did download the iDRAC manual, but the instructions were not as specific as what you just provided.

    I'll use this method next time.

    Thank you so much.