Dell Md3200i Urgent question on enabling cache - General - Forum - Storage - Dell Community

Dell Md3200i Urgent question on enabling cache

Storage

Storage
Gain insight and information on Dell EMC Storage products from engineers, peers and experts in the industry.

Dell Md3200i Urgent question on enabling cache

This question is not answered

Hi there

We have 2 Dell MD3200 dis shelves.

We have created a new virtual disc, which we have some virtual machines on, its not until we deployed it with many users that we noticed the performance is not correct. Upon further investigation we have noticed that the cache has the following notice on...

Cache setting is enabled but currently suspended

Now we need to activate this, but can we do it while the virtual disc is in use? Do we need to take any precautions before activating this by the cli?

Any assistance would be greatly appreciated.

Kev

All Replies
  • Hello Kev,

    When you check in the Recovery Guru are there any errors listed? Normally when the cache is suspended there is something that has changed. If needed can you gather a support bundle from your MD3200i and we can review them to see why the cache is suspended.

    Please let us know if you have any other questions.

    DELL-Sam L
    Dell | Social Outreach Services - Enterprise
    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)

  • Hello ,

    Thanks for coming back. We built a new volume after having some more discs. I think by default the cache is suspended , and so we worked out the commands to disable the mirror feature and switch on the cache.

    Anyway last night we backed all the VM's up and then shut them down on the disc shelves and run the command to enable the cache.

    To disable the mirroring feature and enable caching: as shown below, substituting array name with our arrays.

    smcli.exe -n Array0 -c "set allVirtualDisks mirrorEnabled=false;"

    Once we did this the performance burst into life, so a process we were running was taking 1 hour, now only takes 15 minutes. Plus all the users are no longer ringing me saying its slow.

    Thanks anyway!