about ASM/ME Alter settings

Storage

Storage
Gain insight and information on Dell Storage products from engineers, peers and experts in the industry.

about ASM/ME Alter settings

This question is answered

Hello all,

I have installed ASM/ME in the windows 2008 r2 server, and enabled email alter settings. But, I find a strange thing. I have not enabled infrmational alter, such as, smart copy succeeded. as show in the follwoing photo.

But, I still can receive a mail about "HIT/ME Alter: Create Smart Copy - Success on host XXX" when the smart copy created successfully. Why?

 

Verified Answer
  • Well by the looks of this, you have a torn smart copy or missing component.  

    This happens when a smart copy is scheduled but you missed a warning message that you may not have read or corrected first.  You most likely will not be able to do anything with these copies until the problem is fixed.

    When creating the schedule using the Schedule Task Wizard in ASM, you would have seen a Missing Components or Volumes message and needed to correct this first.

    You should also be seeing torn copy messages too.

    You can delete this schedule, and recreate it to see the warning message.  Note that the Schedule Wizard will still let you save the schedule even with warnings.

    So, this isn’t a message from the informational alerts, but a message telling you to correct the warning.

    Any of the smart copies that were created with this schedule should be removed as well.

    The ASM User Guide has more information on Torn Smart copies (with an example) that can explain how it happens and what to do to avoid it.

    -joe

    Follow me on Twitter: @joesatdell

     

  • Most likely if you have done this then yes, this would generate the warning.

    -joe

    Follow me on Twitter: @joesatdell

     

All Replies
  • Ensure that ALL the hosts that ASM is installed on are configured for this setting.  In the middle panel select all hosts and then verify the settings.

    You can also View/Change the setting on each host using the ASMCLI:

    (You will need to navigate to the directory C:\Program Files\EqualLogic\bin or add the ASM/ME CLI commands folder to your path by editing your Windows PATH environment variable)

    To View settings on each host:

    Syntax: ASMCLI -alert -category={"category_name" | "category_abbreviation"} |

    Example shows the current settings for informational Alerts:

    ASMCLI -alert -category=Informational

    or

    ASMCLI -alert -category=I (this is the abbreviation for informational)

    To change ALL the informational alerts to disabled

    -disableall={"category_name" | "category_abbreviation"}

    Example to disable all informational messages on the host (do this for each host)

    ASMCLI –alert –disableall=Informational

    This is discussed in more detail in the ASM User Guide.

    If you are still having problems, you will need to open a support case.

    -joe

    Follow me on Twitter: @joesatdell

     

  • Thank you, Joe,

    I am sure that ALL the hosts with ASM installed on are configured for this setting. - the same settings.

    I also checked it with ASMCLI ...

    all informational alerts are disabled.

     

  • what version of java is installed?

    Use:

    c:\java -version

    c:\java -fullversion

    -joe

    Follow me on Twitter: @joesatdell

     

  • no java installed, ASM/ME needs Java ?

  • No, Java is not required; in fact the HIT v4.0 no longer installs it.  I was checking to see if you did have Java installed and what version (for conflicts, etc.).

    I also did some testing on our W2K8 R2 (without SP1 installed, pretty much a basic install), and was NOT able to reproduce your problem.  If the Smart Copy Successful is checked, I receive the email, if unchecked I do not.

    You can try to re-run the HIT/ASM install, but choose the “repair” option (this will require that the host is rebooted).

    If the repair doesn’t fix the problem, gather the following information and open a support case:

    Msinfo32, save the file as an .nfo

    Systeminfo > host_systeminfo.txt (this redirects the command to a text file)

    -joe

    Follow me on Twitter: @joesatdell

     

  • Thanks.

    I've reparied the HIT/ASM installation, but it did not repair my problem.

    before opening a support case, would you like help me check the mail from EQL

    I noticed there is a warining message in the mail though it is a succed mail, do you think it is the reason why I can still receive mail?

  • Well by the looks of this, you have a torn smart copy or missing component.  

    This happens when a smart copy is scheduled but you missed a warning message that you may not have read or corrected first.  You most likely will not be able to do anything with these copies until the problem is fixed.

    When creating the schedule using the Schedule Task Wizard in ASM, you would have seen a Missing Components or Volumes message and needed to correct this first.

    You should also be seeing torn copy messages too.

    You can delete this schedule, and recreate it to see the warning message.  Note that the Schedule Wizard will still let you save the schedule even with warnings.

    So, this isn’t a message from the informational alerts, but a message telling you to correct the warning.

    Any of the smart copies that were created with this schedule should be removed as well.

    The ASM User Guide has more information on Torn Smart copies (with an example) that can explain how it happens and what to do to avoid it.

    -joe

    Follow me on Twitter: @joesatdell

     

  • Thank you, Joe

    In my schedule, I create a smart copy that includes multiple database. (no missing component) I checked the user guide and found

    is it the reason why I received mail?

  • Most likely if you have done this then yes, this would generate the warning.

    -joe

    Follow me on Twitter: @joesatdell

     

  • There is a specific email setting that you have to uncheck to disable the "Multiple Application Component Warning" you got in the bottom of you alert.

    All you need to uncheck is:  "Critical: Collection Multiple Writers or Component Error".

  • Thank you, Apepin,

    Do you think that my schedule about creating smart copies for mutilple database is ok?

  • I would NOT recommend disabling the “Critical: Collection Multiple Writers or Component Error” message.  The reason for this is if you do have this condition, the Smart copy may not be usable.

    Since you are creating a Smart Copy set with multiple application components (i.e, in your case you stated that you have more than one database contained in the smartcopy).   The downside to this is that it will result in the following when restoring from this Smart Copy set: all components will be taken offline.

    To avoid unnecessary interruption of the other database during a restore, you should consider making a separate Smart Copy set for each component.”

    If this is a scheduled operation, it is recommend that you cancel this Schedule, then either move each component to its own volume, or create a collection that includes all dependent components or volumes.

    -joe

    Follow me on Twitter: @joesatdell

     

  • One more bit of information:

    The cause of the issue is a collection is made with multiple Exchange components or sometimes Exchange components and another application like SQL.  It is recommended to create a schedule at the application layer for you mailbox database by right clicking on the mailbox and setting up a schedule that way.

    If you see torn copy message on the application when trying to create a smartcopy you will need to fix this issue first.  Typically by creating a separate volume for each component and or database/log.  

    Setting up a schedule at the application layer will pick up the logs as opposed to creating a collection within ASM/ME for all database components.  The problem will come when you try to restore that smartcopy from ASM/ME it is not designed to work this way and it warns since all IO will have to be paused to restore.  

    Creating collection of multiple databases and logs causes issues with multiple components warning.  It will send emails on all successful smartcopies because of the potential issue with restoring multiple components.  Many customers like to set up one schedule for Exchange with all datasets and unfortunately that is not recommended for restore since it will on a restore stop all io for all components.   Thus the need to set up and schedule with the writer using application pane of the GUI.

    To get to TR1040 go to the following link:

    support.equallogic.com/.../tech_reports.aspx

    sign in and search for title document below:

    "Deploying Microsoft Exchange Server 2010 with Dell EqualLogic PS Series Arrays"

    Or link:

    support.equallogic.com/.../DownloadAsset.aspx

    -joe

    Follow me on Twitter: @joesatdell

     

  • I know I'm late to this party by a couple years but the problem was that he had multiple components in his collection which is creating the warning. Even though it shows the completed smart copy the warning is what triggered the notification.