DR4000 mount NFS from ESXi host - General - Forum - Storage - Dell Community

DR4000 mount NFS from ESXi host


Gain insight and information on Dell EMC Storage products from engineers, peers and experts in the industry.

DR4000 mount NFS from ESXi host

This question is not answered

We have been given a Dr4000 to test with, our aim is to use VMWare's VDR product to backup our large datastores.

Therefore we need to mount the DR4000 as an NFS datastore to allow VDR to see/write to it. I have configured the DR4000 for both CIFS and NFS and can see and write to the CIFS side of things from Windows fine.

In VMWare I am attempting to mount NFS and I'm coming up against an issue. 

After I attempt to mount the store [SERVER :   -   FOLDER : /containers/backup/vmware] I get a error:

Call "HostDatastoreSystem.CreateNasDatastore" for object "datastoreSystem-5896" on vCenter Server "SERVER20.local" failed. 
NFS mount NATTHDR4X:/containers/backup/VMWare failed: The mount request was denied by the NFS server. Check that the export exists and that the client is permitted to mount it.

The NFS container is configured like this :

You will notice in the error message that I am attempting to mount to /containers/backup/vmware. This is a folder I created. however I have tried to mount the data store directly to /backup, I have created alternate containers and attempted to mount the datastore there.

I have tried with Insecure ticked and unticked. I have also 'Mapped root to :' all three of those options.

I have checked that the VM host has NFS services installed and firewall options are enabled and set to allow access to/from any host (See here : http://blog.jeffcosta.com/2011/01/10/hostdatastoresystem-createnasdatastore-for-object-ha-datastoresystem-error-when-setting-up-vmware-nfs-data-store/

I can reach the DR4000 from the VM host (ping the DR4000 hostname seems ok).

Any thoughts on how this can be configured?



All Replies
  • On a Linux NFS server, I usually restart the NFS service and that resolves it.   Not sure how to do that with a DR4000.  

    Make sure that you can VMKPING the NFS server from the ESX console.  

    Social Media and Community Professional
    Get Support on Twitter - @dellcarespro

  • Well, this has only just been installed so I'd hope not. I'll try restarting the service, back to google for that.

    (Does anyone know how to remotely reboot one of these things?)

    VMKping works fine from the host I'm trying to attach from.

  • The DR4000 uses NVS v3.

    Remote reboot can be done thru admin GUI or

    ssh in as administrator `system - -reboor`

  • Mount the container directly , instead of giving sub-directory paths.

    Use just  "NATTHDR4X:/containers/backup" for doing the nfs mount. It should work.