List view threshold and qListView - SharePoint Customization - SharePoint for All - Dell Community

List view threshold and qListView

List view threshold and qListView

This question has been answered by kenny.wu-quest

Greetings,

We are running SP 2010 and Quick Apps 6.3.  We have a list containing 11,000+ rows.  Using a native SP view with a filter, my query returns 4 rows. 

When I attempt to do the same query using a qListView web part and a CAML filter, I get the error "The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator".

Why does the qListView query not return the same 4 rows?

I've seen several discussions on this subject in the forum.  One said it was being addressed in version 5.7.  It seems like maybe this didn't happen?

Other discussions suggested changing Central Admin or Configuration Editor settings.  We use a SP service provider who will not change any of the default settings.  And from what I'm reading, that's probably a good thing.

I see in the release notes for 6.4 that one of the resolved issues is: "qListView gets error if the number of the items in the list exceeds the list view threshold", Issue ID 296799.  Will that resolve this issue?

We will be implementing 6.4 later this summer.  in the meantime, is there a workaround for this issue?  We have several productions lists approaching the threshold.

Thank you for any help you can provide.

Wendy

Verified Answer
  • Hi Wendy,

    There has a workaround for you. You need to set the index for the search fields. For example, you set a CAML for the “Title” field, so you need to create an index for the “Title” field.

    This threshold is the limitation for SharePoint, it will be ignore if you are in the administrators group. For the performance consideration, I suggest that use the CAML filter(you are suing that) or turn on the “Turn On List Searcher Mode” option in qListView. But all the fields you are using to search must have an index.

     

    Kenny.

All Replies
  • Hi Wendy,

    There has a workaround for you. You need to set the index for the search fields. For example, you set a CAML for the “Title” field, so you need to create an index for the “Title” field.

    This threshold is the limitation for SharePoint, it will be ignore if you are in the administrators group. For the performance consideration, I suggest that use the CAML filter(you are suing that) or turn on the “Turn On List Searcher Mode” option in qListView. But all the fields you are using to search must have an index.

     

    Kenny.

  • Hi Kenny,

    Thanks for the response.  I'll give that a try.

    Will I be able to select using qSelector too, once the "Title" field is indexed?  Many of our pages use this feature, and that too is failing on this list.

    Also, I see in the release notes for version 6.4 that one of the resolved issues is: "qListView gets error if the number of the items in the list exceeds the list view threshold", Issue ID 296799.  Will that resolve this particular issue?

    Thanks again.

    Wendy

     

  • Hi Wendy,

    Yes, you can use it in qSelector too.

    About the #296799, the detail of this ID is: user turn on the “Turn On List Searcher Mode” setting in qListView, and query the data by using some search criteria, but the returned data exceeds the threshold, the search panel is gone, and user unable to reset the search criteria.

    The web parts are not query the data form the view, they design to get the data form the list directly for some advance features. So for the performance consideration, we follow Microsoft suggestion and didn’t ignore the SharePoint threshold.

     

    Kenny.

  • Hi Kenny,

    Thanks for the information and response.  The indexing is working as described! 

    I'm having a slight issue with using qSelector on the indexed field.  If I can't resolve it I'll create a new post.

    Thanks again!

    Wendy