ERROR: ERR_DISABLED_PRODUCT - Product is disabled - Foglight for Databases - Foglight for Databases - Dell Community

ERROR: ERR_DISABLED_PRODUCT - Product is disabled

ERROR: ERR_DISABLED_PRODUCT - Product is disabled

This question is answered

Hi,

in the windows application Foglight Performance Analysis for Oracle I've used Shutdown StealthCollect to shutdown all agent processes on a monitored DB instance. According to the document Foglight Performance Analysis for Oracle, the processes should be automatically restarted upon any subsequent connection attempt. But it failed in my case, no matter if the command below was executed on the foglight middle tier or on the monitored instance:

On middle tier:

quest_launcher -command -start -product StealthCollect -all -f -port 3566 -user quest

On monitored DB:

quest_launcher -command -start -product StealthCollect -all -f -port 3568 -user quest

(3566 is the default port of the foglight middle tier; 3568 ist the port of the monitored DB)

The error messages are respectively:

On middle tier:

ERROR: FAILED starting StealthCollect@7.0@quest_sc_mw@<Instance name>
ERROR: FAILED starting StealthCollect@7.0@quest_sc_rep@<Instance name>
ERROR: ERR_DISABLED_PRODUCT - Product is disabled

On monitored DB:

ERROR: FAILED starting StealthCollect@7.0@quest_sc_collector@<Instance name>
ERROR: ERR_DISABLED_PRODUCT - Product is disabled

Middle tier and foglight repository DB have already been restarted. Monitoring any other instances functions as usual.

Can somebody help me out of the dark?

Regards,

Ning

Verified Answer
  • Thank you for your help.

    I went to the site Agent Manager and found that StealthCollect for this instance is disabled (option DISABLE is set to YES), and it seems that the command I gave in my initial post can not change DISABLE back to NO.

    After changed DISABLE back to NO manually, everything goes well.

All Replies
  • Going through open items on the community I noticed this was still in an opened state. 

    I see several KB articles with stealthcollect startup issues so hopefully this was resolved with the help of support 

    Golan 

  • Thank you for your help.

    I went to the site Agent Manager and found that StealthCollect for this instance is disabled (option DISABLE is set to YES), and it seems that the command I gave in my initial post can not change DISABLE back to NO.

    After changed DISABLE back to NO manually, everything goes well.