XPS 13 9360 8Gb Developer Edition freezing - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

XPS 13 9360 8Gb Developer Edition freezing

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

XPS 13 9360 8Gb Developer Edition freezing

This question is not answered

Hi all, finally I got my XPS 13 DE / i7 / 8 GB. 

Arch linux installed, and I got a full system freeze with few apps.
Reboot with power button and I add system monitor to see how memory used.
I found that Google chrome(with few gmail tabs or long usage), PhpStorm, atom, skype betta - can
reach memory limit(last I see on system monitor - 7.7G) and freeze.

Like en.community.dell.com/.../ described - I update my system.
I update it almost every day. But no result.
Then I found somewhere that it could be BIOS. I follow Wiki and update BIOS for arch linux.
And with first boot after that - was just perfect:
I run PhpStorm, WebStorm, Google chrome with 40 tabs + mail tabs, Atom IDE, VCode IDE and many other stuff - result
My memory was near 7.4 and NO any freezes for hole day.

I was happy till reboot.

On next day - I turn on my laptop and I see memory issues again, again I can reach limit and get freeze.

Please, If you can help me message me. Please ask me any logs, configuration...

Eugene

All Replies
  • Hi. Are you sure that it's a memory related issues? Have you tried to use swap? I have same looking freezes on Linux >= 4.10

    bugs.freedesktop.org/show_bug.cgi

    What version of kernel do you have?

    Have you tried to ping your laptop when it freezes?

  • @Yury

    I'm not sure that this is memory issue :(

    1) I don't use swap

    2)kernel version:  $ uname -r

    4.11.6-3-ARCH

    3) ping. I think that it will be possible, because even music continue playing(but with interruptions) when all windows and apps in freeze.

  • Monitor screenshot: drive.google.com/open

    In this status - no sound , cursor can move but with delay in 30 seconds and veeeery slowly, clicks not fired.

    That's the freezing for me :(

    Any arch linux  users ?