Kernel panics - XPS 9360 with TB16 dock - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

Kernel panics - XPS 9360 with TB16 dock

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

Kernel panics - XPS 9360 with TB16 dock

This question has suggested answer(s)

Hi,

On the load of certain program/kernel modules, and only when the XPS is plugged onto the TB16 via usb-c, it goes into kernel panic -- hard lock-up. Only the finger can bring it down to a halt.

I am currently running opensuse tumbleweed - kernel 4.10.13.

Example of things that make it kernel panic.

- Lunch VirtualBox or modprobe vboxdrv

- sudo powertop

- sudo sar -I XALL 1

There are probably others.

If undocked, these 3 examples do _not_ cause the laptop to go into kernel panic and the programs run.

If launched while undocked and left running, docking the laptop to the TB16 does not trigger the kernel panic either.

Thanks for any feedback.

Cheers,

fred

All Replies
  • Interesting.  I was running Ubuntu 16.04 and I too started experiencing complete system lockups when starting Virtualbox.  I thought it was perhaps a corrupt expansion pack install.  I purged numerous times without success in fixing the issue.

    I am not using the TB16, but am using the DA200 and another type-c adapter.  I hadn't thought about a type-c adapter/doc causing the problem.

    Recently I've done a clean install of Ubuntu 17.04, and Virtualbox.  I tried running Fedora in Virtualbox in 17.04, and experienced lockups of VBox, not the entire system.  I tried running Ubuntu in Virtualbox with no problem.

    Is there a guest kernel incompatibility with the adapter somehow?

  • When you're saying "guest kernel" what are you saying? If virtualbox guest modules, then I don't think so. Must be something else that triggers, since powertop and sar also trigger a kernel panic.

    There may be progress in kernel 4.11 soon regarding Thunderbolt support. But I believe firmware in the TB16 and the XPS itself would play a big role in there.

    It's like the TB16 ethernet port just not working after a few minutes. We hope Dell can achieve better Linux support and provide more to the kernel community; for now, it kind of falls short of expectations.

  • After upgrading my XPS BIOS to 1.3.5, having an ethernet cable plugged onto the TB16 causes an immediate kernel panic now. Still on kernel 4.10.13.

  • I'm running Ubuntu 17.04 with kernel 4.10.0. I use virtualbox every day with no issues while connected to the TB16 dock. Ubuntu 16.04 guest.

    I'm not sure what BIOS I'm running. I updated it to the latest as of about April 10. I was not able to update the TB16 firmware.

  • I have tried only once right now after having updated to kernel 4.11. No panic on first try. Will see on the longer run. Hope it holds!

  • Sorry to resurrect this old thread but I was having a very similar problem with my XPS 13 9360 and found a solution. I have my XPS connected to a USB-C dock from Pluggable, and I was having issues with a complete system lock up on login. I eventually traced it back to Virtualbox drivers loading on boot that was causing the lock up (running VB 5.0.40 which is what comes with Ubuntu 16).

    I've since switched back to kernel 4.4 (had to re-run dkms to get the Virtualbox modules compiled for it) from kernel 4.10 and my system is now rock solid. Someone else commented here that 4.11 is working, as is Ubuntu 17, so this seems like a specific issue with kernel 4.10 and Ubuntu 16, and isn't necessarily related to a problem with Dell docks.

    As far as BIOS goes, I was originally on 1.3.2 and updated to 2.3.1 before I switched kernels and that didn't seem to fix anything at all. Only the switch back to kernel 4.4 solved this problem for me.

    I saw someone also commented about plugging in the ethernet port on their dock caused an immediate crash, and as far as that goes, there was an update to the realtek ethernet driver in the Xenial release of kernel 4.4 and 4.10 just a couple days ago that may solve that. I was having an issue with the ethernet port in my Pluggable dock getting disconnected, and since that kernel patch my ethernet port has been working great also.