Ongoing version support? - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

Ongoing version support?

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

Ongoing version support?

This question has been answered by bit101

I  bought a Dell XPS 13 9360 last year and it came with Ubuntu 16.04. October came and went and there was no sign of an official Dell 16.10 upgrade that I could see. Now 17.04 has been released and I see no word of an official Dell release yet. I understand it may take a while to get it ready after the Canonical release. And maybe you only plan to support the *.04 releases. I'd just like to know what I can expect.

I've tried other distros with the machine, even vanilla Ubuntu 16.04 and had lots of problems, particularly with sound. So I'm kind of stuck with what Dell provides, unfortunately. Thus, I'd love to know what will be provided going forward. I know Ubuntu is planning some big changes in 18.04 - dropping Unity and replacing it with Gnome. I paid a good amount for this computer and plan on having it at least that long. I'd hate to be stuck on a 2 year old release because Dell gave up on updating it.

An even better solution would be to provide the custom drivers, etc. that make the Dell image work, so that I could install whatever distro I want and still be able to get the sound card to work. One of the main benefits of using an open source OS like Linux is choice. I'm disappointed that I cannot install another distro, and am stuck with a Dell version of one particular release of one particular distro.

Verified Answer
  • @bit101,

    Yuri is correct.  We (Dell) only officially support the LTS's.  For the interim releases we will make "best efforts" to support.

    thanks for your support!

    Barton George

  • The drivers are pushed upstream into the kernel so that other distros can leverage them as well.  Other places on this forum you can see a bunch of other distros that folks are using in place of Ubuntu.

    Barton George

  • julio:  en.community.dell.com/.../20002634

All Replies
  • To clarify a little bit, I love the machine. And I don't really have a problem with Ubuntu. I'm currently running i3wm, so I don't even see the Unity desktop. I would like the choice though. And I really need to know what kind of support will be coming in the next year or two.

  • Hello

    As I know Dell supports only LTS releases (12.04, 14.04, 16.04, etc)

  • @bit101,

    Yuri is correct.  We (Dell) only officially support the LTS's.  For the interim releases we will make "best efforts" to support.

    thanks for your support!

    Barton George

  • Thanks. Actually, I did find another page that listed 10.04, 12.04, 14.04 and 16.04 as downloads, so I figured that was what's going on. Any chance of making the drivers and other special bits available for use in other distros?

  • The drivers are pushed upstream into the kernel so that other distros can leverage them as well.  Other places on this forum you can see a bunch of other distros that folks are using in place of Ubuntu.

    Barton George

  • Thanks again. I understand that's the concept. I had very bad luck with other distros and even tried to go back to vanilla Ubuntu 16.04. Lots of issues with sound and touch screen. Reinstalling from the Dell image fixed everything. But that was 6 months ago. I know some changes had not made it upstream by then. Maybe that's been handled by now. I have no big reason to change my distro now, but it's good to know that it should be possible.

  • Just wanted to follow up on this. I just installed stock Ubuntu Gnome 17.04 and so far everything seems to work just great. The only issue was some slow wifi. Set up the new drivers per another thread here and that seems like is better.

  • ThX, can you link the other thread? Regards

  • julio:  en.community.dell.com/.../20002634

  • ThX, very kind of you. I'll probably install LUbuntu 17.04 + The fix in the link above.