CPU speed capped after suspend/resume in Ubuntu - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

CPU speed capped after suspend/resume in Ubuntu

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

CPU speed capped after suspend/resume in Ubuntu

  • I am experiencing a capped very low (418 MHz) CPU speed after suspend/resume on a Dell XPS 9550 in Ubuntu. It seems related to having a device plugged into the Type-C port and triggering the suspend via a power adapter disconnect - for instance if the system is configured to suspend when the lid is closed on battery, but not on the adapter.

    There are some relevant discussions on the kernel bugzilla - the issue seems to affect several Dell models including the XPS 9350

    https://bugzilla.kernel.org/show_bug.cgi?id=90041

    https://bugzilla.kernel.org/show_bug.cgi?id=189861

    There seems to be some patches to mitigate the issue (not yet upstream), but the kernel developers seem to believe the issue is related to Dell's BIOS.

    For me this is probably the only annoying issue on an otherwise great Linux laptop.

  • Thanks for putting this together. I am running into exactly the same issue. Sometimes after resuming the laptop is totally unusable. I have found a workaround though, which is to switch to the "performance" governor.

    I have also run into this issue (which will be patched in 4.11) which I believe that it is not the same problem git.kernel.org/.../

  • For the record I have an xps 9360 with the following kernel version

    4.10.0-19-generic #21-Ubuntu SMP Thu Apr 6 17:04:57 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

  • Looking at the bugzilla threads this issue seems to go beyond the XPS series and affects other Dell laptops as well.

    I also found a nice discussion on the Arch Linux forums with some workarounds - haven't had time to test them yet:

    bbs.archlinux.org/viewtopic.php

    Switching to performance governor also seems to remedy the issue.

  • Thanks for the information.

    What's your kernel version? I am wondering if this is a regression added in newer versions of the kernel, because I can not believe that everybody is living with this issue. This makes my laptop unusable.

    @dell, do you have input on this? Is there any Bios update in the works?  

  • I fall back to use `acpi-cpufreq` instead (intel_pstate=disable) as suggested here git.kernel.org/.../

    I'll re-enable intel_pstate once 4.11 is our there.