Dell XPS 13 (9360): Disappearing Sound Card in Ubuntu - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

Dell XPS 13 (9360): Disappearing Sound Card in Ubuntu

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

Dell XPS 13 (9360): Disappearing Sound Card in Ubuntu

  • audio_combined.txt

    I just bought a brand new Dell XPS 13 laptop to run Linux and the sound card intermittently disappears from the device list on boot. In the attached file, you will see the two outputs of lspci: the first being when the sound card exists, the second being when the sound card disappears. When the sound card happens to exist, sound works perfectly on all fronts. This is so bizarre.

    I'm running Linux 4.4.0-53-generic #74-Ubuntu SMP Fri Dec 2 15:59:10 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux under Ubuntu Gnome 16.04.

  • Took a while for this thread to appear on the forum...

    I merely wanted to say that switching my system to 16.10 (which uses the 4.8 kernel) has solved the issue so far. I need to do more testing still to be absolutely sure this isn't a fluke, but so far the sound is rock solid. I decided to upgrade to 16.10 because it runs the 4.8 kernel (installing 4.8 under LTS is not currently straightforward), which has changes that were merged starting on 4.6 involving sound card detection on Dell laptops.

    I will report back if I encounter any more issues.

  • I had this problem and it took me a very long time to figure it out.  Something gets screwy with the user pulseaudio config.  If you:

    cd .config

    mv pulse pulse-bak

    All of the sudden, voila the output appears immediately.

  • had same behaviour under mint 18.1, upgraded bios (no change), upgraded mint kernel to 4.8 and issue solved