XPS 13 (9360) Trackpad issues... - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

XPS 13 (9360) Trackpad issues...

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

XPS 13 (9360) Trackpad issues...

  • Hi dev's,

    I received my dell xps 13 (9360) this week and I'm overall really happy with it. This gotta be probably one of the best notebooks I've ever had, hands down!

    However one thing that is bothering me immensely is that the track/touchpad is pretty unusable.

    It's seems that the mouse cursor is frozen, no matter in which direction i'm going.... the only thing that is then working is navigating through the touch screen or using a mouse (bluetooth or wired).

    Does this happen to anyone else as well?

    I've also noticed that I can re-produce this error. Whenever I need to enter something in a textbox (browser searchbar, etc...) and then try to navigate away on the touchpad it's frozen!

    I'm happy to provide any logs that you might regard as helpful!


    Thank you once again for creating such a kick-*** laptop. Kudos to everyone at Dell! Thanks!

    cheers,
    theresa

  • I posted about a trackpad issue just a few minutes before you.

    Mine will sort of freeze, but also seems to think I'm doing gestures and will start switching applications or scrolling a window instead of moving the cursor.

    Haven't found the cause of it yet... only had my system about an hour now.

  • I didn't experience exactly your symptoms (or maybe I did, but I was so angry I don't remember), but my touchpad was mostly unusable until I blacklisted the psmouse driver.


    See my posts in http://en.community.dell.com/support-forums/laptop/f/3518/t/19996875 for more info...

  • @Community,

    One of my colleagues worked on this and supplied the following document:

    http://www.dell.com/support/article/us/en/19/SLN304721

    Justin C

    Dell Technical Support L3 | Project Sputnik

    Dell Support is also on Twitter! https://twitter.com/DellCaresPRO

     

  • I have had psmouse blacklisted since I did my own install on my 9360. Blacklisting it was advised back on the 9350 and was on the Arch wiki for the laptop for a while.

    Unfortunately, my erratic behavior with it has persisted. Someone had mentioned some 3 finger trackpad taps take care of it, but not quite for me. I have found if I put the laptop to sleep and then wake it back up, it clears it up for a while. However I generally just find the 9350 a far more usable machine.

    My 9360 is past the return period, unfortunately. I may send it in for service, but wouldn't expect much, or will add it to my pile of forgotten hardware.

  • That sounds extremely frustrating. I really hope you don't have to add it to the pile of forgotten hardware (at least every few months see if a kernel update fixes something?). Is using a USB mouse that much of a pain? If you do that, can you turn the trackpad completely off so it doesn't cause any of the trouble you mentioned? Don't lose hope! Something has to work! Best of luck and best wishes.

  • I've been extremely frustrated with the trackpad ever since I got my 9360. First thing I tried was to blacklist psmouse, but the trackpad still intermittently stopped working. I really should've returned it at this point, but I thought I'd stick it out and would find someway to make it work if I scoured the internet enough. I eventually created a workaround script that makes the machine actually usable, but unfortunately, it still isn't quite reliable enough to bring to work or anything...just more for tinkering until I get frustrated!

    I put these commands into a little shell script that I run every time it stops working and it seems to reset the trackpad. Unfortunately it doesn't always persist very long and I end up having to run it several times.

    First you need to run: xinput --list | grep Touchpad

    and use the output from this of the name of the device as the string in the script below.

    #!/bin/bash

    xinput disable 'DLL075B:01 06CB:76AF Touchpad'

    xinput enable DLL075B:01 06CB:76AF Touchpad'

    sudo modprobe -r i2c_hid

    sudo modprobe i2c_hid

    Hope this helps, until someone else finds a more permanent solution. I'm still under the assumption that this is not actually a hardware issue, but I haven't necessarily proven that assumption.

  • @Tjotx,

    Do you still need assistance? If so, send me a friend request and we'll start a support case together.

    Justin C

    Dell Technical Support L3 | Project Sputnik

    Dell Support is also on Twitter! https://twitter.com/DellCaresPRO

     

  • I am also suffering this problem on my machine - had it since last thursday and mouse freezes after about half an hour....am running the installed ubuntu16.04

    sometimes. can't get a support request as the diagnostics dell want me to use is an exe file..

  • You're not alone in this. I just bought a 9360 as well and have been VERY frustrated with this touchpad. For the amount of money that was spent on this, I'd expect MBP or similar usability on the touchpad front. Blacklisting psmouse hasn't helped terribly well; however, your shell script above (thanks for that by the way!) helps once it does its "lock up" thing. At this point, the things about to go back to Dell as it's merely a "sexy laptop" that's *** frustrating to get actual work done on. =/

  • Amen. I really, really want to love this laptop but the trackpad ... *sigh*

  • ***... These TouchPad issues started from day 1 when I first took it out of the box. Spent a couple hours on the phone with Dell last night to no avail; they said they are going to let me know on a day or two if they decide the touch pad needs to be replaced, but I think I might be better off just bringing it back to Costco. Really fortunate to have a good return policy and I've only had it less than a month, but I spent weeks researching laptop specs before I decided to buy this, such a fail....

  • @DELL-Justin C

    Could you assist me with the same problem? My 9360 (with Win10) touchpad freeze from time to time. I just got my XPS a few weeks ago and since then it's impossible to use trackpad.

  • @V.E.Loft,

    Sure. Send me a friend request with your service tag. I'll see what I can do.

    Justin C

    Dell Technical Support L3 | Project Sputnik

    Dell Support is also on Twitter! https://twitter.com/DellCaresPRO

     

  • @Community,

    Technical support has produced a brand new document with steps you can take to help improve the touch pad when running Ubuntu.

    It's here: http://www.dell.com/support/article/us/en/19/sln308258/precision---xps--ubuntu-general-mouse-issue-fix?lang=en

    If the steps in the document do not help please contact Dell technical support and mention Document ID SLN308258.

    Justin C

    Dell Technical Support L3 | Project Sputnik

    Dell Support is also on Twitter! https://twitter.com/DellCaresPRO