Can not install Ubuntu on brand new Win 10 XPS 13 9360 (tried all known guides!) - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

Can not install Ubuntu on brand new Win 10 XPS 13 9360 (tried all known guides!)

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

Can not install Ubuntu on brand new Win 10 XPS 13 9360 (tried all known guides!)

  • I understand this problem tends to be unique to the individual when it comes to linux, but I've been trying to install Ubuntu 16.10 on my one day old Kaby Windows 10 XPS13 9360. I'm stuck, and I've tried all the usual guides.

    When I boot from USB I get as far as the GRUB loader. When I select "Try Ubuntu" I see the loading screen for a few seconds and then I get dumped out to the console with the following two sets of errors:

    scsi 0:0:0:0 rejecting I/O to offline device
    blk_update_request: I/O error, dev sda, sector 752
    Buffer I/O erro ron dev sda, logical block 256, async page read
    ...
    (initramfs) stdin: I/O error
    mount: mounting /dev/loop0 on //filesystem.squashfs failed: No such device
    Can not mount /dev/logo0 (/cdrom/casper/filesystem.squashfs) on //filesystem.suashfs

    or...

    SQUASHFS error: squashfs_read_data failed to read block 0x53c58f

    I can confirm:

    • ISO checksums are valid
    • Safeboot is DISABLED
    • AHCI mode is ENABLED (also tried OFF)
    • USB created with Rufus
      • Tried both MBR for Bios or UEFI as well as GPT
      • 8192 bytes (default)

    Things I tried...

    Being a Linux novice, I'm out of ideas. Can anyone help? Thanks!

  • Sorry for probably useless comment but is safeboot the same as secure boot? If not, did you try turning of secure boot in BIOS?

  • You might have tried this already, but let me propose a stupid test: have you tried some other USB device? Because your steps seem proper to me.

  • Any update on this issue? I'm having the same issue.

  • Any update on this issue? I'm having the same problem.

  • Have you tried Ubuntu 17.04??  Perhaps it is an install issue with 16.10.  I had no issues installing 17.04 though I did install via an external DVD drive, not a USB flash drive.

  • Dell sells Developer edition XPS's with Ubuntu pre-installed and other people have had success installing it themselves so I was happy to continue trouble shooting. However, the particular XPS 13 I bought suffered from the dreaded coil whine (high pitched squeal when using the trackpad) which drove me crazy in my quiet room. Considering the price of the machine, I felt it was unacceptable and then had a terrible and rude experience returning it to Currys PC World (UK). It turned me off from the Dell / XPS experience, and Apple will begrudgingly get money the next time around. :/

    If you follow nightsky3535's method below then let us know if it works for you too. Good luck!

  • @joshkh,  i apologize for your experience and can understand your frustration.  We are continuing to work on the coil whine issue and hope to have some more updates soon.  While it is a subset of the systems that are affected, if you receive one with the issue thats of little consolation.

    Once again, please accept my apologies

    Barton George