XPS 13 9350 - Anybody running an external monitor of any type? - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

XPS 13 9350 - Anybody running an external monitor of any type?

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

XPS 13 9350 - Anybody running an external monitor of any type?

  • Hi,

    I was just about to pull the trigger on a 9350 as a coding machine (with a 27" 1440 external monitor) when I got a bit worried about the lack of any dedicated video output ports. A long google later, I am more worried than ever! Has anybody actually managed to get a 9350 working with an external monitor via a real video stream at all? I say real video stream to distinguish between Thunderbolt adapters that tap the native video stream and the various docks that are actually using the USB part of Thunderbolt via a Displaylink chipset. I have experience of displaylink under linux and they just don't work well (and in fact Displaylink are quite clear that until the Linux kernel changes the way it does screen refreshes they aren't going to get any better). 

    So, the question again - is anybody actually running an external monitor of any type via a "normal" usb-c video adapter? E.g. usb-c to dp, to HDMI, to duallink DVI(the one I am hoping to get working!). 

    Any info would be gratefully received - ideally with  model name or a link to a working adapter if you found one.

    C

  • The Type C port isn't just for Thunderbolt or USB. It's for native HDMI and DisplayPort. DisplayLink is in no way involved.

    --
    Project Sputnik development lead
    Software Principal Engineer
    Linux OS Architecture
    Dell | Client Product Group

  • I have a xps 13 9350 DE, bought a week ago or so.

    I have been using the VGA output port of a Dell DA200 adapter for a couple of days. Not sure if it works as a thunderbolt or usb-c port, but I did not have any problems with the video so far (there is an issue with the size of the elements on screen, as one monitor is high density and the other isn't, but it isn't related)

    The ethernet port seems to work as well from a very quick test. HDMI was not tested.

    Instead, I have been having problems with connecting the keyboard to the USB port (of the adapter): it worked fine for the first day, and now often skips some keystrokes or keeps repeating one multiple times.

  • I am using my 9350 with USB-C to DisplayPort cable connected to Dell U3415W at WQHD 3440 x 1440 resolution. It is working fine with my other QHD 2560x1440 monitor as well.

  • Hi Jared,

    I am not quite sure what you mean here. As I understand it, the USB-C connector on the 9350 is what is  known as a Thunderbolt Alternate Mode connection (as indicated by the thunderbolt symbol on the port) . The thunderbolt 3 controller on Skylake provides 4× PCI Express 3.0, DisplayPort 1.2, HDMI 2.0 and USB 3.1 gen. 2 natively (according to Wikipedia) and intel's own Thunderbolt 3 page has this to say:

    Thunderbolt 3 is a superset solution which includes USB 3.1 (10Gbps), and adds 40Gbps Thunderbolt and DisplayPort 1.2 from a single USB-C port. This enables any dock, display, or data device to connect to a Thunderbolt 3 port, fulfilling the promise of the USB-C connector.

    So that would seem to imply it is all about Thunderbolt 3 - there is nothing else providing any services via that Type-C port other than Thunderbolt 3. So the question is - how do we attach an external monitor to that port - what protocol can we access? If you look at Dell's own offerings released for the port, 2 of the 3 are definitely only using the USB protocol to deliver video, via DisplayLink drivers (they are The Dell Dock and the Dell Dongle). The 3rd one, the Dell Thunderbolt Dock, apparently is actually accessing the video protocol directly from TB 3 - but based on the various discussions on this forum, video output from that dock is not working under Linux due to the drivers for TB3 not being ready yet. So you can see my worry - it looks like all the services this port offers are coming from the TB 3 chipset - including any video ones. It may well be that a single adapter (e.g. a usb-c(tb) to dp) is able to passively access video without the need for the full TB 3 drivers - and that is my question, has anyone actually got this working with a solution that definitely isn't just using a DisplyLink driver via the USB part of the TB3 port...

    C

  • Excellent Bboby - do you have a model for that cable, or a link to it?

    Cheers,

    C

  • I am not able to make it work via usbc->displayPort but it works via usbc->HDMI.

    What displayport cable adapter are you using? Are you using Ubuntu 14.04 that comes with the machine?

    Thanks.

  • I got the cable from Google to use with Chrome Pixel originally.

    My 9350 is running 15.10.

  • Just to clarify a couple of points in my earlier post - TB3 is not offering native HDMI 2.0, despite what the wiki entry says, it looks like that came from an earlier leak and was dropped from the actual release. Also, I am not certain now that the DA200 (aka The Dell Dongle) is using DisplayLink (although there are various suggestions online that it is) - it may well be accessing the DP stream and doing a normal conversion from that to the HDMI/VGA outputs it has. I say that as I found the manual for it and it specifically says it doesn't require any drivers which would imply it is not using DisplayLink.

    Just for the record, Displaylink are a third party company who make chipsets that OEM's incorprate into their products. They specialise in chipsets that create a GPU that is fed via a USB port. Most of the USB 3.0 dock solutions are using their chipsets for example. The problem is it is effectively a software solution. The video stream is compressed by the Displaylink drivers, fed out through UISB to the adapter/dock with the DL chipset on it which then converts the stream back into a video output. There are a few implications to this approach - it eats CPU power, the video displayed has lost some detail through the compression process and the whoile thing relies on the DL drivers. When it comes to linux, because of the way linux refreshes the screen (basically all at once, even if only a mouse cursor is moving across the screen), then the DL drivers struggle to keep up and can appear very laggy (at least that was my experince with a USB 3.0 -> 4K displaylink adapter under ubuntu).  So a DL solution is never going to be ideal from a linux point of view. 

    Reading some more about TB3 under USB-C Alternate Mode TB, it looks like the DP stream is exposed at the port in the same way as a USB-C Alternate Mode DP port (e.g. the Macbooks ), although obviously only DP 1.2 rather than the DP 1.3 on offer under Alternate DP ports. If that is true that any USB-C -> DP connector should just work, assuming the current linux TB3 drivers are offering that mode. See this Intel TB3 presenstion - it has a description of all of the different modes a TB3 USB-C port should be capable of.

    So - we have a report of at least 1 USB-C-DP cable working, from BBoby. hopefully s/he will come back and let us know what model that was. Anyone else have any success? I wonder if anyone has tried the Google Pixel USB-C->DP cable? 

  • ColmB

    ...

    So - we have a report of at least 1 USB-C-DP cable working, from BBoby. hopefully s/he will come back and let us know what model that was. Anyone else have any success? I wonder if anyone has tried the Google Pixel USB-C->DP cable? 

    I am using the same cable on Precision 5510 with 2560x1440@60 resolution.

  • I have the XPS13 DE and uses the cheap Color-3D CAC-1504 USB-C to HDMI 2.0 adapter. It works perfectly with my older 1680x1050 Dell monitor (via a HDMI to DVI adapter). The adapter should be capable of 4K@60Hz, but haven't tried it though.

  • BTW. I am actually able to drive two external monitors

    1. Connected via USB-C <-> Display Port cable to 2560x1440@60 monitor.

    2. Connected via HDMI <-> HDMI cable to 1920x1080@60 monitor.

    I have to connect and enable HDMI monitor first, then the other one.

  • @wrobell The 9350 doesn't have a HDMI port  - are you talking about a different model? Or is that from one of the docks?

  • I have Precision 5510. I assumed XPS does have HDMI port like 5510, sorry for the mess.

  • Hi,

    I have had success with a USB-C to VGA adapter, which runs my 1920x1200 monitor.

    This is using a CableCreation adaptor from Amazon (CableCreation Gold USB 3.1 Type C (USB-C) to VGA Adapter for Apple The Macbook, Chromebook Pixel and More, Black)

    I have not had success with a USB-C to DVI adaptor from Camac (Amazon - Camac The New MacBook USB 3.1 Type-C to DVI Adapter Cable Converter High Quality Ultra-thin USB 3.1 Type C male Connector to DVI female for Apple New 12 inch MacBook Laptop - White). 

    The monitor is detected correctly, but no display...

    Using Ubuntu 16.04.