Where are the WD15 drivers on your support page for linux - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

Where are the WD15 drivers on your support page for linux

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

Where are the WD15 drivers on your support page for linux

  • How do I get the WD15 dock working with the precision 5510 to output 2 displays. I can't understand why you guys sell products that do not work with linux or do not provide driver links in your support pages for docks.

  • Does a single display work for you?


    Dell lists WD15 as supported under Linux:

    www.dell.com/.../SLN301105

  • No. This dock sits as a paperweight and I have to use an adapter (www.bhphotovideo.com/c/product/1208733-REG/j5create_jca140_usb_type_c_to_4k.html) to get output and then I am planning to get another adapter to get more outputs natively using DisplayPort 1.2 Multi Stream Video Output (www.amazon.com/StarTech-com-Triple-DisplayPort-Multi-Monitor/dp/B00JLRBB8I/ref=sr_1_1?ie=UTF8&qid=1460523520&sr=8-1&keywords=startech+displayport+MST+hub)

  • I can confirm that with the XPS 15 9550 FHD combined with the WD-15, I have two 1920x1080 monitors working via HDMI and VGA in addition to the FHD working with Ubuntu 16.04 and Kernel 4.6 from Ubuntu mainline. Ethernet, USB, and Charging also work. Audio does not work. All of the above "just worked" by hotplugging the dock into the laptop.

  • it works for me to with the kernel:

    4.5.4-1-ARCH

    DP/eth/power. For me also no audio yet.

    I did not try debugging yet to get audio working.

  • Audio started working for me with Ubuntu 16.04/ Kernel 4.6. I discovered a device in pavucontrol called "USB Audio Analog Stereo" which works out of the headphone jack from the front of the dock, this port also supports mic. The audio jack at the back of the dock does not work.

  • For anyone else reading this thread I'd like to point out something that I couldn't find any information on: the WD15 does support dual 1920x1200 screens. I did have trouble trying to daisy chain with the DP connector, though mirroring worked, so I switched to using both the DP and HDMI.

  • Got the WD15 working on debian 8 and alienware 17R3.

    Installed kernel 4.5.0-2 and it did not work. It detected eth and USB ports but the display did not work until I've disconnected and reconnected usb cable. After that picture appeared but the mDP monitor was flickering. One reboot solved it all. Audio is also working.

    Now for some more testing - cold boot and so on.

  • Not sure if this is a problem with my dock or with the OS, but after being plugged for 1-5 minutes, my USB keyboard will totally drop. A replug works for about 10-30sec before dropping again. Audio doesn't work at all through the dock - Alsa detects that it exists, and pulseaudio swears it was trying to play audio through it, but I hear nothing and can't control the mixer through alsamixer.

    Arch Linux, kernel 4.6.1-2-ARCH, Dell XPS 13 9350 FHD/8GB model. Dmesg below. Note that I *did* flash the latest WD15 firmware from Windows this morning; the issues persist.

    [ 2332.826721] hid-generic 0003:1E54:2030.0010: input,hiddev0,hidraw2: USB HID v1.10 Device [TypeMatrix.com USB Keyboard] on usb-0000:05:00.0-1.3/input1
    [ 2344.545978] usb 3-1.3: reset low-speed USB device number 9 using xhci_hcd
    [ 2346.369033] usb 3-1.3: reset low-speed USB device number 9 using xhci_hcd
  • I can confirm the above issue is either OS (Kernel) or the XPS device hardware itself, because the HP Elite USB-C Dock does the same set of shenanigans (on top of being a simply inferior dock).

  • For anyone who stumbles across this post via the Googles, I so far seem to have fixed my dock on Linux 4.6.2-1-ARCH with the following line. The issues I was facing seemed to be related to the still-iffy Type-C hotplug support in the kernel. I'm about 30 minutes strong with no disconnect/reset issues after running this immediately after plugging the dock in.

    echo 1 | sudo tee /sys/bus/pci/rescan

  • It's been a year since this thread has been alive, but maybe somebody will find this useful or have something more to contribute.

    I'm running Gentoo Linux with the latest 4.9.31 kernel (I usually stick to the LTS kernels).  I updated the BIOS on my 5510 before installing Linux, and the dock was already at the latest firmware level (I tried updating it under Windows--apparently there's no update procedure available except in Windows).

    The USB and ethernet work flawless for me.

    I'm using the HDMI video, and it works fine.  The only issue is that it sometimes hangs when switching back and forth from X11 to the console; I think that's an Intel driver issue (setting 'Option "DRI" "False"' in the driver config helped with that).  I've also used the VGA output, which also seems to be fine.  I don't have a DisplayPort cable to test that.  I don't see any option to use the audio over HDMI, but my monitor doesn't support audio, so I haven't looked very hard.

    Audio is a problem, as others have noted.  It shows up on the USB bus:

    Bus 003 Device 010: ID 0bda:4014 Realtek Semiconductor Corp.

    It shows up in Alsa as card 2 (I have a USB webcam as card 1), but trying to play to it from mplayer fails:

    mplayer -ao alsa:device=hw=2.0 *.mp3

    ...

    [AO_ALSA] Format s16le is not supported by hardware, trying default.

    [AO_ALSA] Unable to set format: Invalid argument

    Failed to initialize audio driver 'alsa:device=hw=2.0'

    Could not open/initialize audio device -> no sound.

    At this point, I'm under the impression that the kernel drivers are incomplete.  I'm not an expert at Alsa configuration, so I would welcome any advice.  I may try a 4.12-RC kernel to see if there are any updates.

  • Hi All,

    Any chance to update the WD15 by Linux ?

    Thank you so much!

    All my best

    David

    Ubuntu 16.04 - Gnome 3.18 - Kernel Linux version 4.4.0-59-generic - XPS 13 9360 - BIOS version: 1.2.3

  • I'm running 4.12.0-rc7 with the WD15. The audio device shows up in the GNOME Sound settings panel with 4.11 or 4.12, but I've never tried to use it to see if it works.

    Let me know if you want me to reproduce any issues you observe...

  • I've had no issues with the WD15 with both Xps 15 and 13 on kernels 4.6, 4.7, 4.8, 4.9, 4.10, and 4.11. There were problems with earlier kernels.