xps 13 developer edition wifi does not work - Dell XPS 13 developer edition / Project Sputnik Feedback - OS and Applications - Dell Community

xps 13 developer edition wifi does not work

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

xps 13 developer edition wifi does not work

  • I just got  the XPS 13 developer edition a few days ago.  The WIFI is unstable and has a lot of dropped connection and packet lost making the laptop pretty much useless.  I upgraded to ubuntu 13.04 but still no luck, then I upgraded to the latest stable kernel 

     3.10.16-031016-generic #201310131935 SMP Sun Oct 13 23:36:07 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

    Still lots of packet lost with the 3.10.x kernel.  Dell support sucks also.  Got  a recording "Due to care and attention to all our callers our agents are busy. We are sorry all agents are busy, please try your call again later".   I've wasted too much time with this laptop.  The only reason I got this laptop was because it was certified to run ubuntu linux so that I can avoid wasting my time on issues like this. If your time is precious, don't buy this laptop. It does not work as advertise

  • I believe Dell is trying to generate a Linux line. Linux is not quite as supported as the Windows line when it comes to drivers. In order for there to be a line of Linux computers, Dell and the Ubuntu team they are working with, need to establish a stable platform.

    I am waiting for my laptop that I ordered last week. I was aware of the wireless networking issues prior to my purchase. To even find this laptop for purchase took a bunch of searching on this site. This lead me to these forums and I did a bunch of reading prior to purchase. I believe they slapped “developer” in the name in hopes of getting more technical people purchasing.

    Some company is going to need to bite the bullet and produce machines to establish a base line. I am glad Dell has decided to do this. I would also recommend sticking to 12.04 LTS. The LTS is a version that will be receiving patches over time. It will have better support than the non-LTS versions. I was reading that the 12.04 is planned for support until 2017.

  • I kept trying different kernels. finally tried 3.12.x daily build kernel to work without any packet loss

    download the packages at


    sudo dpkg -i  linux-headers-3.12.0-999-generic_3.12.0-999.201310140405_amd64.deb linux-headers-3.12.0-999_3.12.0-999.201310140405_all.deb 


  • I hope dell is monitoring this and ships a kernel that just works so that people don't have to waste their valuable time to fix problems like this. How can they even ship a kernel that has such a fatal bug to the usability of the device?

  • When I upgraded to ubuntu 13.04, the mult-touch feature of the trackpad stopped working but thats a problem I can live with

  • Hi Sonny,

    Im sorry about all the pain you had to go thru and sorry that support was not helpful.  To help me look into this, what country are you in and what wireless access point(s) were you trying to connect to?


    Barton George

  • George,

    Thanks for responding.  I'm in the NYC, US.  The access point I am using is a HTC One google edition running the latest version of android (4.3). The problem was fixed using the 3.12 daily build kernel

  • Thanks ill check it out.  BTW any chance you'll be at DevOps days NYC on Thurs and Friday?  I will be there and if so it would be great to meet up.



    Barton George

  • Hi Barton,

    sorry I wouldn't be at that conference.  ubuntu 13.10 was recently released. I'm happy to inform that everything runs out of the box with ubuntu 13.10 even multi-touch touchpad