Cant install windows 2012 r2 on new R330 - OS and Applications - Forum - OS and Applications - Dell Community

Cant install windows 2012 r2 on new R330

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

Cant install windows 2012 r2 on new R330

  • Hello,

    We just received a new R330 in the office this week and I'm trying to install our ISO of Windows Server 2012 R2 onto it. I dont understand how but it has been a complete pain the entire time.

    I followed the steps in the "Setting up your dell poweredge server using dell lifecycle controller" document and when it got to the point where it would start the install of the OS it said it couldnt recognize the USB drive that the iso had been "burned" onto. I thought okay well maybe ill boot directly to usb. That brought up the windows installation just fine but it wouldn't find any disks. As I had already gone through the raid setup and saw it was already configured this confused me. It then stated that it couldnt find any drivers to, I presume see the drives. So I first went out of the setup, did a CTRL+R to see if RAID was in fact configured and it was. I then tried it again but same issue.

    So I instead burned it to a dvd to try that, this time when booting using the DVD drive it wouldnt even get to the part about not seeing any disk drives, instead it would go straight to saying it was missing drivers.

    I then tried to use the lifecycle controller to install the OS using the dvd instead of usb. It failed at validating the disc. So I thought maybe my iso was old or out of date. Downloaded the most current one from microsoft, burned it to a disk and had the same issue, cant validate.

    Did a little more research saw that people have downloaded the RAID controller drivers and just put them on a USB stick and used that during windows setup when it asked for drivers. I tried that but the drivers are an .exe so windows setup cant recognize them. I tried browsing the .exe with 7-zip but the drivers aren't there as just a "file" so i couldnt manually extract them.

    I then attempted to use the .exe on another 2012 r2 server we have and then manually copy them after installed, but it would not install, presumably because it didn't have a RAID controller in it (none of our others do).

    So at this point I have no idea what I'm doing wrong. For reference my RAID controller is a PERC S130, and this is 64bit Server 2012 R2

    • Cant Install through Lifecycle with disk or USB because it says its invalid
    • Confirmed its not invalid because booting directly to USB or DVD initializes but fails when looking at the disk drives to install onto, talking about missing drivers.
    • Confirmed through Lifecycle and CTRL+R that RAID has been configured.
    • Tried to get the most recent DL of Windows 2012 R2 ISO from Microsoft and use that in either USB or DVD, same issue.
    • Attempted to download the drivers from dell, from here, but its an exe so I cant get the actual drivers off of it, even with 7-zip or attempting to install on another 2012 R2 server.

    Am I missing something basic? I don't understand where the hangup is at this point.

    Thanks for any help,

    Geoff

  • While you can use any format of the driver, the Hard Drive format is the easiest:

    http://downloads.dell.com/FOLDER02302311M/55/SAS_RAID_DRIVER_WS2012R2_S130_4.0.0-0035_A00_ZPE.exe

    Download to any computer and run it to extract the files. Don't use any extracting tools - just run it - it is a self-extracting EXE. It will extract the files by default to C:\Dell\Drivers\F9VT6\. Copy that whole folder (F9VT6) to a flash drive - it can be the same flash drive as you install with. 

    When Windows says it can't find any drives, click Load Drivers, and browse to that folder.

  • Thank you for the reply, it looks like this is going to work! In regards to not using the LifeCycle controller to install, will I lose any functionality or void any sort of warranty/support that you know of?

    Thanks!

  • None. They only do that for convenience. The only thing you get with LCC/SMTD that you don't get with installing directly from the media is the Utility Partition - diagnostics loaded in the boot menu of the machine. The latest version of the diags can be downloaded and installed from their website and run from floppy, CD, USB, or the network, so not having a Utility Partition is not a big deal.

  • Good to know, I appreciate the help you've been very informative.

    Thanks,
    Geoff