"autorun.dll" error upon install Windows Server 2012 R2 after 7.3.0 Open Systems setup - OS and Applications - Forum - OS and Applications - Dell Community

"autorun.dll" error upon install Windows Server 2012 R2 after 7.3.0 Open Systems setup

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

"autorun.dll" error upon install Windows Server 2012 R2 after 7.3.0 Open Systems setup

  • Hello,

    New bare metal install on a PowerEdge T320.

    I've run the OpenManage Systems Management Tools disc and have setup the hardware configuration (RAID), and selected the OS.  The only one listed was "Windows Server 2012 x64".

    Upon reboot, I'm prompted to insert my W2k12 Server R2 disc.  The dialog box responds that it is a valid installation, and then proceeds to run.  Shortly after, I"m prompted with the following message:

    the file 'autorun.dll' could not be loaded or is corrupt. setup cannot continue. error code is (0xc1)

    The licensed MS OS was downloaded as an ISO.  I've burned a data DVD, and after failure the first time, I made another copy of the OS, and that too failed with the same message.

    Upon exploring the file contents of the ISO, the autorun.dll file is located in the sources folder.  So, it does exist.  As for stability of this file, that is unknown.  However, if I boot off this MS OS disc bypassing the OSM, I get to the point where I'm prompted to install drivers for media.

    Was there any firmware that needed to be updated prior to doing this?

    Also, by having W2K12 Server R2, versus W2K12 Server (no R2), would that nix the installation?

    Please advise,

    Thank you in advance.

    Irwin

  • According to the docs, 7.3 does not support 2012 R2 ... it sometimes happens in the transition of new machines, SMTD versions, and OS's that they don't all match up on the version of SMTD that ships and/or is currently available from Dell.  I would watch for 2012 R2 support possibly in 7.4, due out probably in a month or so.

    It is unlikely that the LLC is 2012R2-ready either, but you can try using that for the install.

    In the meantime, I would suggest installing R2 directly from the OS media.  Be sure to configure/initialize RAID first.  Depending on your RAID controller, Windows may already have the driver built-in.  Which controller do you have?

     

  • Hi Flash,

    Thank you for replying quickly! Smile

    I have The Perc H310.  I've downloaded the current driver, and pointed to the folder with .inf files during the W2K12 R2 install.  However,  it is not able to load up the Perc H310 driver.

    BTW, there are 2 drivers listed and I choose both, but no go:
    - DELL PERC RAID Virtual Device (nodev.inf)
    - PERC H310 Adapter (percsas2.inf)

    The message displayed is:
    No new devices drivers were found.  Make sure the installation media contains the correct drivers, and then click OK.

    There are 3 drives on the back-plane, the 1st two drives are configured RAID 1, and the other just a standard drive for backup (not hot spare).

    Currently, I'm downloading the Dell Server Update Utility v.7.4 (release 2/1/14) and will apply.  Hoping this will resolve...at least so I could run the Window Server OS install normally instead of using the System Build and Update Utility.

    ...more thoughts are welcome.

    Thank you,

    Irwin

  • The H310 driver should be "native" to Server 2012 R2, which is why no driver is listed for 2012R2 on the download page:
    http://en.community.dell.com/techcenter/b/techcenter/archive/2013/09/05/windows-server-2012-r2-rtm-inbox-driver-support-on-dell-poweredge-servers.aspx

    During the install, are you just not seeing any drives to install to, or are you getting another message?

  • There's no drives listed to install. Perhaps I'm missing a step?

    I configured the RAID and initialized, but maybe something went wrong?

  • https://www.facebook.com/media/set/?set=a.10202239103553775.1073742014.1075784085&type=1&l=52a56eef74

    those are screenshots related to this install

  • The driver should be built-in ... check.

    RAID has been configured ... which should be fine, but even if not, the H310 supports non-RAID (H710 does not), so disks left unconfigured (you said you had a single non-RAID disk installed for backups?) should still be seen by the OS ... check.

    Hmm ...

    Is your BIOS version at least 2.0.21?

    Try booting to Repair Your Computer (instead of Install Now), Advanced, Command Prompt, diskpart, list disk ... does it show either of the disks?  If so, run 'clean' on the RAID 1 disk (probably disk 0).

    Booting in BIOS or UEFI mode?

    You might try reconfiguring RAID ... making sure to select Advanced/Initialize.

  • I deleted the RAID and recreated RAID 1 drive 0 & 1.  Drive 2 is not configured.  The RAID array was Fast Initialized.

    BIOS is 2.0.22

    Right now, I'm running the MS server install. Trying INSTALL NOW...leads me on the same path.

    Then Repair computer (and your path with command), I get this:

    https://www.facebook.com/photo.php?fbid=10202239266637852&l=ab91d0d4aa

    Disk 0 Status = Online 1862GB size  free 1862GB

    I didnt' do RAID - Advanced mode yet. and currently booting from BIOS.

  • Before going back to the RAID config, I decided to try "Attempt Repair" from the Windows Setup GUI...it's "Attempting Repairs", the RAID drives are active, seems like something is happening.

    Strange....anyway, I'm going to let this continue and see what happens.  Will have to sign off for today, but will be back later tonight.

  • i finally came back to this...sorry for non-reply..I've been sick and away from this server. BTW the Attempt Repair didn't work.

  • Solution!!

    I've been using the Systems Management Tools 7.3.0.  In addition, my original download of Windows Server 2012 R2 from Microsoft's Volume LIcensing site was used.  This combination did not allow me to install.  I was stopped at either the "autorun.dll" error popping up, or if I installed straight from the W2K12R2 server DVD, I'd get prompted for a media driver which I could never find.  This was after I downloaded and every single driver for the T320.

    To reiterate, I installed via these methods; using the SMT disc AND straight from the Server OS media.

    Thinking that something may be wrong with the T320 using W2K12 R2, I used an actual Microsoft Windows Server Small Business 2011 disc to test the installation.  I got the same result as above, either the autorun.dll error or couldn't find a media driver.

    So, I waited...then Dell released System Management Tools 7.4.0.  With that in hand, I was able to install separately (to test) both W2K12R2 AND SBS2011.  Since, I've recreated the RAID virtual disk, and setup the 3rd drive as a hot spare.  Windows Server 2012 is now happily running on the computer.

    I was hoping that this server installation was a more pleasant experience...but far from it.  There was nothing more that could've been done on my end and was at Dell's mercy.

    Hopefully, if someone finds this information useful.

  • IRWINPKS: Sorry for the hassle. It's would be helpful to know the little things like this that make it harder for customers like you to get the work done.

    It does seem the System Management Tools were created specifically for instances like this. Although I can't pinpoint exactly where the error occured, but I would imagine a lot of the issue probably pertained to the PERC controller as well as the RAIDCFG configuration used, which this version (7.4.0) addresses. 

    Thank you for posting your solution!

  • __Joe
    Although I can't pinpoint exactly where the error occured

    It is documented here (under Known Issues) and matches the OP's experience:
    http://ftp.dell.com/Manuals/all-products/esuprt_software/esuprt_operating_system/ms-win-srvr-2012-r2_User's%20Guide_en-us.pdf

    SMTD 7.4 (and later) should be used to install 2012 R2.

  • Hey Joe,

    Thank you for the confirmation...I thought I was going nuts...or at least missing an intermediary step.

    Have a good day! Smile

    Irwin

  • Hi Irwin,

    I have the exact same server T320 and I am Trying to do the exact same thing. Install Win2012R2 with SMT 7.4 but I am still getting the same error. My discs are the same as well, as yours, 3 1tb drives two in raid 1 with a HOTSPARE.
    I have tried about 6 times to install the OS but have the no luck. I must be doing something wrong during the process as I have never had trouble doing install on a dell server before.

    Any words of advice about install and raid config.?