PE2850 and Windows Server 2012R2 - OS and Applications - Forum - OS and Applications - Dell Community

PE2850 and Windows Server 2012R2

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

PE2850 and Windows Server 2012R2

  • Hello,

    I'm trying to install Windows Server 2012R2 on an old PE2850 without success. When I'm trying to install from fresh (boot via USB), it loads but suddenly fails with a Error Code: 0x000000C4. It seems this is the result of a driver problem.

    I've tried to update BIOS/firmware to all the latest possible, without success.

    So I've tried to install Windows Server 2012, which is possible. Unfortunatelly, I can't get the USB drivers to work.

    I know this is an old Server but I'm surprised that drivers doesn't work ?

    Anyone successfully installed Windows 2012R2 ?

    Regards,

  • Hi, 

    Could you please post which CPU you have? Looks like your CPU don't support x64 Architecture. 

    Best regards

    Flo 

  • It's a Xeon (socket mPGA 604 - Nocona) which support 64 bits (the server is running windows 2008R2 x64).

    Regards,

  • Ok, 

    could you please check if your HW components are on that list?

    http://en.community.dell.com/techcenter/b/techcenter/archive/2013/09/05/windows-server-2012-r2-rtm-inbox-driver-support-on-dell-poweredge-servers.aspx

    If not, could you post which one? 

    But looks like it is the same issue like with Windows Server 2012 

    http://en.community.dell.com/support-forums/servers/f/1466/t/19465175.aspx

    PE 28x0 is no longer supported, that the storage driver are no longer part of the installation and no longer avail. for download. 

  • No component is on the list.

    Here is what I have on my PE2850 (Bios A07) (what is listed during boot) :

    -SiI 0680 ATA/133 Controller BIOS Version 3.4.1027 from Silicon Image, Inc. (virtual floppy/virtual CDRom)

    -PowerEdge Expandable RAID Controller BIOS H435 (Build Apr 23, 2008)

    -Perc 4e/Di Standard FW 5B2D

    -Dell Remote Access Controller 4/I Firmware 1.75

    -IPMI Server Management Configuration Utility 1.1

    -Baseboard Management Controller Revision 1.83

    -Primary Backplane Firmware Revision 1.00

    -Secondary Backplane Firmware Revision 1.00

    It's not the same issue as with Win2012 ; with 2012, you just need the Perc 4 drivers, and using 2008R2 drivers it works perfectly. With 2012R2, the setup itself can't launch.

    Regards,

  • Where is setup stopping?  What is the last thing you see?

  • It reboot after all the files have been loaded and just when we see the Windows logo (the same as when you boot normally on the OS).

    As I said on the first post, I see Error Code: 0x000000C4 on a BSOD and then it reboot automatically.

    I guess it's drivers related.

  • I am also experiencing the same issue. Have you found a solution ?

  • Unfortunatelly, no. I think DELL needs to update the drivers, but i'm not sure it will happen :/

    If you find a solution thanks to update this topic though

  • Has anyone found a solution to this problem?  I am trying the same thing and getting the same errors.

  • yes im successfully running Microsoft WIN2012 on my PE2850 it just needed the perc drivers to make it work when I'm trying to get the WIN2012 R2 there is a error it cannot boot the setup so I can give it drivers or what ever it needs
  • Can you please elaborate on your post.  Are you saying you were able to install 2012 successfully and from there you upgraded to 2012 R2 and it worked for you?  What exactly do you mean  "give it drivers or whatever it needs" can you tell us in detail what you did?

  • well I said before I did not successfully get win server 2012 r2 on it windows server 2012 runs fine on it I am not using it any more I purchased a new dell PowerEdge t20 to replace it since I am just a student needing a server to train on. I traced back the issue with the dell PowerEdge 2850 back to the features that the bios has it does not have the required secure boot to make the windows server 2012r2 installer to start. might of missed the a few others don't remember that well.

  • Thanks for the quick reply & additional information.
  • Same here with R2. Even an in-place upgrade from RTM 2012 to R2 will get stuck in a reboot cycle.