Unable to bind Super to 'Show launcher' in Compiz - OS and Applications - Forum - OS and Applications - Dell Community

Unable to bind Super to 'Show launcher' in Compiz

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

Unable to bind Super to 'Show launcher' in Compiz

  • I'm very pleased with my Dell XPS 13 Developer Edition, but my only real gripe at the moment is that I'm unable to bind my Windows button, or Super on Ubuntu, to show the launcher.

    So far I have installed the Compiz Settings Manager and when trying to configure the Show launcher shortcut in the Unity plugin I can bind it to Super, but about 2-3 seconds later it switches back to Disabled.

    It also switches back if you try and capture the keys. The capture picks up the correct keys, but when you close the capture window it just swaps back to 'Disabled' again.

    I've tried this by also clicking the <[x] button which resets the binding to default. This will temporarily set the binding to Super before swapping back to disabled after about .5 seconds.

    Does anyone have any idea's why I can't bind this button? I have checked the Keyboard configuration and it looks like it's set okay to me, so this is even more confusing.

  • Turns out this is a bug in Unity.

    bugs.launchpad.net/.../1151786

  • So it looks like Dell installed a package to disable the button!

    bugs.launchpad.net/.../1154430

    `sudo apt-get remove dell-super-key`

  • Can someone from Dell answer why this package was included? I was hoping it was a package to allow us to disable/enable the super key at will.