Latitude 10 ST2 UEFI USB Boot - OS and Applications - Forum - OS and Applications - Dell Community

Latitude 10 ST2 UEFI USB Boot

OS and Applications

OS and Applications
Dell OS and Applications Solutions on Dell TechCenter - Project Sputnik, Microsoft Windows, Red Hat Linux, SUSE, Ubuntu, and more

Latitude 10 ST2 UEFI USB Boot

  • I am using a Latitude 10 with the Dell factory release of Win 8 pre installed, and I need to install a customised 'Corporate' image from MDT 2012 (update 1) onto it using a USB (as there are no Ethernet ports on the device).

    The USB has been formatted to FAT32 (to accommodate UEFI), using the regular diskpart commands. Secure Boot has been disabled, and the USB can be seen in the Boot Configuration.

    If I copy the Microsoft Windows 8 x86 contents from the ISO to the USB, the device will boot ready to install a new version of the OS. However, if I copy the contents of my customised corporate Windows 8 ISO (generated from MDT2012 update 1), the device does not boot from the USB.

    The 'Corporate' image on the USB boots fine on different models, so that isn't an issue.

    I have also updated the firmware to the latest release (A03).


    In summary:

    Windows 8 out of the box - USB boots fine

    Windows 8 MDT image - USB does not boot

    Any help is greatly appreciated.

    Many Thanks

  • Any luck getting a fix on this? I am trying to do the same thing with SCCM 2007, no luck.  Also tried using a bootable USB, no luck.

  • You need to use the ADK with WinPE 4 to boot the Latitude 10 since it is UEFI only.  SCCM 2007 does not support OS Deployment of Windows 8 since SCCM 2007 does not support UEFI.

  • I am having essentially the exact same issue only I am using ADK with WinPE 4. I have built up a new Windows 2012 server with MDT 2012 update 1 and created a custom task sequence using the OEM install.wim and have verified task sequence works via legacy bios boot. I have also tried removing all the drivers except the drivers for the Latitiude 10ST and have also tried importing the Dell WinPE 4.0 drivers from as well as set the scratch space to 512 per the comments in another thread.

    What rules should I be using and do I need to change anything in the bootstrap.ini? Pretty much at a lose at this point and would appear I am not the only person with this issue.

  • I was able to resolve this issue by reducing the file size of the boot wim used in my custom task sequence. I created a seperate selection profile that included only the drivers for the Latitude 10 ST and nothing else and this reduced the wim to approx 195MB and now I am able to boot and image the system using my task sequence.

  • Thanks for all the good positive feedback here. I have now solved my issue as well.

    Despite using MDT2012 Update 1, I had to update the version of WinPE to version 4.0 by downloading and installing the Windows ADK for Windows 8 on the MDT server from here:

    (I only chose to install the WinPE option, as this was the only component relevant to my needs).

    I then reviewed the deployment share properties and then Updated the deployment share. MDT knew about the new WinPE files available and updated the boot image to incorporate them accordingly.

    To test if the boot image was updated, I confirmed my 16Gb USB stick was FAT32 and bootable then copied the contents of the LiteTouchPE_x86.iso to it. It booted perfectly. I have since recreated my 'Corporate' image media and copied that onto the USB and it also boots fine. Incidentally, I have not created a custom WIM, it is still the out-of-box Windows 8 WIM so I have no issues with the FAT32 restrictions for file size.

    This is what we now know:

    USB needs to be FAT32 format (for UEFI)

    Secure Boot needs to be disabled

    WinPE v4 needs to be used for Windows 8

    Ensure file sizes are less than 4Gb (FAT32 restrictions) unless the USB has different partitions of FAT32 and NTFS to house the boot files and image respectively


  • So to reiterate information I have gleaned here and from other locations, for those who may have encountered one or more roadblocks:

    Set up your USB flash drive. Important note that UEFI cannot read NTFS so it needs to be FAT formatted: 

    1.) Format via diskpart as directed elsewhere, clean, create partition primary, format fs=fat quick, active.

    2.) Copy files to your USB drive from your WinPE source folder - note that with Win8 ADK if you're following the instructions you're directed to use copype.cmd to build an x64-bit instance but you need a 32-bit one for the Latitude 10's Atom processor.

    3.) In your USB drive's source folder remove or rename boot.wim

    In Microsoft Deployment Toolkit 2012, you need to: 

    4.) Import the 32-bit drivers from the Dell WinPE 4 CAB. 

    5.) In your Depoyment Share properties you need to go into the WinPE tab, set the platform to x86, and set the scratch space size to 512

    6.) Rebuild your deployment share. 

    7.) Copy the LiteTouchPE_x86.wim from your Deployment Share to the source folder on your USB drive and rename it to boot.wim. 

    Ensure your Dell Latitude 10 tablet is configured as follows:

    8.) Hit F2 from dock w/keyboard or volume- rocker at startup and ensure that your Latitude 10 has correct settings in the BIOS UEFI.

    System Configuration > USB Configuration > Boot Support = Enabled

    Secure Boot > Secure Boot > Secure Boot = Disabled

    Apply settings and Exit.

    9.) Hit F2 from dock w/keyboard or hold down volume+ rocker at power-on. Choose your USB drive.

  • Would any of you be able to zip up the contents of a bootable USB stick for this dell tablet and FTP or use another method to get it to me? Imaging this has been a nightmare for me. I can do the "diskpart" steps to make the USB stick bootable - - if I have the correct contents I'll be good. That would really really get me out of a bind.

  • Right on Zabagar!

  • It looks like UEFI is a Microsoft lock out against using other operating systems.(It's my computer.) 

  • Are you still in this bind?  I got the USB stick in a safe place some where.........    If I find it I can try posting it to a dropbox.

    Note this is NOT for the RT version  only Intel

  • It's not a pressing issue anymore but it would be VERY USEFUL to have. Sure, if you have a ZIP you can post/drop that would be fantastic.


  • So I made an image of the USB stick, it is 8GB.   I zipped the image, it is 4.x GB.   That is too big for free drop box.

    Send me a note privately if you can and I will send you (or anyone else)  a URL I can place it for download. 

  • That sounds good to me. I don't know how to send you a note privately. How do I do that? 

  • Hey , it looks like I can't private message you. But I would like to get a copy of the USB stick also. Feel free to email me over at yahoo with the username of tation29. I am also getting replies to this post via email too.