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Quick Start

The following sections outline the steps to install a typical Dell OpenManage Network Manager 
system and its subsequent first use. Because the software described here is both powerful and 
flexible, this quickstart cannot describe all the details of available installations. Instead, this Guide 
refers to those descriptions elsewhere or in online help. It also includes a Installing and System 
Startup, below. A typical installation includes the following:

• Installing and System Startup
• Configuring Dell OpenManage Network Manager Users
• Discover Your Network
• Resource Management
• Configuration Management
• Fault Management - Problem Diagnosis
• Performance Management - Troubleshooting
• Create Reports
• Collaborative Diagnosis

NOTE:

Before you begin installing Dell OpenManage Network Manager, make sure your hardware and network 
are correctly configured. For more about that, see the Dell OpenManage Network Manager User Guide

Pre-Installation Checklist
The following helps you avoid trouble in your OpenManage Network Manager installation.

Pre-Installation
• Select devices (IP addresses) and ports to monitor.
• Select IP address for your server.

• Configure its IP address as a management station and receiver of SNMP traps on each 
device.

• Determine IP range of devices being discovered.
• Verify firewalls have open ports between devices and your server. Best practice is to take down 

the firewall, install the application, then put it back up.
• Review device documentation and release notes.
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Other Software to Install

Install these: ActivePerl (then reboot your host), Latest Adobe Flash player, Latest Adobe Reader. 
You will also need access to an FTP / TFTP server.

NOTE:

You must disable User Account Control if installing on Windows Server 2008. Temporarily disable the 
system firewall or any anti-virus software prior to installing, too. Install this software and the wizard will 
walk you through initial setup. Dell OpenManage Network Manager installs as a service and starts 
automatically. Refer to the User Guide and release notes for additional setup information.

Installation

Installation host—Log in as an administrative user. An administrative user can write to the 
installation target directory. Do not log in with user name admin, administrator, or a name 
that contains spaces on Windows, or as user root on Linux. 

You now cannot install as user administrator on Windows or root on Linux. The installer 
confirms you are not one of those users. If you attempt this or other prohibited practices, you 
may see a message like the following:

The installer cannot run on your configuration:

- Please verify that you are not logged in using the windows “Administrator” account or with 
the linux “root” account.

- The installation supports 64 bit Windows and Linux architectures.

- If this is a Windows upgrade that was previously installed with The Administrator account, 
contact your server administrator to perform the steps below. These may vary based on the 
Windows operating system.

1. As an administrator, create a new user and place that user in the administrator group.

2. In Windows Explorer, navigate to the target installation directory and change ownership of 
all directories, subdirectories and files to the new administrator user. Do this by right clicking 
the directory and select Properties > Security > Advanced > Owner tab. Then add the new 
administrator user as an owner. Make sure to check the check box for “Replace owner for sub-
containers and objects.”

3. After applying the changes, login as the new administrator user and proceed with the 
upgrade. 

If you are upgrading from a Windows installation you already installed as user administrator, 
you must change the ownership of the OpenManage Network Manager installation 
directories to another user with administrative permissions before you upgrade.

Windows 2012 —When installing on this platform, right click win_install.exe and select 
Properties > Compatibility. Select compatibility mode for Windows 7 /Vista.

Directories—The source directory should not be the same as installation target directory
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Fixed IP Address—OpenManage Network Manager requires a static IP address. 

 CAUTION:
You must have root access to install on Linux, but do not install as user root (or user dorado).

Starting OpenManage Network Manager (After installation)

Database Running, Connected—Make sure your database is running. MySQL installs 
automatically as a service (daemon).. Do not install on Linux with MySQL already installed 
(uninstall any included MySQL first).

Start Application Server—If you installed this software as a service and application server is 
down, in Windows right-click the startappserver icon, and start application server. This icon 
may prematurely indicate application server has started. Workaround: Wait a little, and the 
application server will catch up to the icon.

When initiated from the tray icon, startup changes its color from red to yellow to green, when 
complete. Once the icon has turned green, the web client may display the message “The 
server is currently starting up. This page will refresh when the server has fully started.” This 
message indicates the application server requires extra time to start. When the message does 
occur connect the web browser again after a few minutes.

Login—Default OpenManage Network Manager login is admin, password admin.

 CAUTION:
The first time you start the application after you install it, you may have to wait some additional minutes 
for Application to completely start. One indication you have started viewing your web client too soon is 
that the Quick Navigation portlet does not appear properly. Workaround: Force Redcell to re-initialize the 
admin user. To do that: Login as Admin. Go To > Control Panel > Users and Organizations. Select and edit 
the Admin user. Edit any field (Middle Name for example). Save. Sign out. Log back in with admin. 

For Successful Discovery (After startup) Have the Following:

Connectivity—Ensure application server has connectivity to devices to discover. One easy way to 
do this is to ping the discovery target from application server.

Device Login/Passwords—Needed for discovery targets. Typically these include SNMP 
communities and CLI login / password combinations. Determine what version of SNMP you 
are using, too.

Device Access—Insure OpenManage Network Manager’s host is authorized to manage to the 
device(s). When necessary, configure devices’ ACLs to admit this application’s access / 
management.
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Backup / Restore / Deploy (After device discovery)

FTP/TFTP Server—Make sure an external FTP/TFTP server is running and has network access to 
the target device(s). Typically FTP/TFTP servers must be on the same side of firewalls as 
managed devices. OpenManage Network Manager’s internal FTP/TFTP server is for testing 
only. If these are separate processes, configure them so they write to the same directory.

Alarms / Monitoring

Minimize Network Traffic—Configure “chatty” devices to quiet down. Use Suppress Alarms to 
keep performance at acceptable levels, and configure database archiving so the database does 
not fill up.

NOTE:

Some OpenManage Network Manager features do not work without internet access. In particular: Maps, 
because the maps OpenManage Network Manager uses need internet access to retrieve maps and plot 
locations. But if you do not need functioning map portlet(s), then running OpenManage Network Manager 
without internet access works well as long as the network is properly configured and resolves the localhost 
name to application server’s IP address.

Installing and System Startup
Initiate installation by opening index.html then clicking the install link (or by executing 
win_install.exe [Windows], or linux_install [Linux]). Click through the installation wizard, 
accepting the license and making the appropriate entries. 

NOTE:

Firewalls and applications already on your host may interfere with the correct operation of this software. 
You must disable Microsoft’s IIS, for one example. To see all the ports where such interference can 
occur, see the OMNM User Guide. Also: The installation wizard controls the presence of its console. To 
see the console's contents, look in the installation's target directory for install.log.

During installation, one screen lets you select the application’s memory size. Best practice is to 
select the largest available after 1 - 4 GB is set aside for the operating system.

NOTE:

You can reset the selected memory size after installation too, with the following properties in 
\owareapps\installprops\lib\installed.properties:

oware.server.min.heap.size=1024m

oware.server.max.heap.size=1024m

When you have installed and successfully deployed Dell OpenManage Network Manager, you can 
continue to the next steps. See the Dell OpenManage Network Manager User Guide for step-by-
step instructions for a typical installation. For more complex installations, consult the 
OpenManage Network Manager’s first chapter of the User Guide.
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Finally, you must do the following to see Dell OpenManage Network Manager:

1 If you did not install it as a service, manually start application server. You can use the Start > 
menu in Windows, or simply type startappserver in a command shell. 

If it is installed as a service, and the tray icon is red, right-click that icon and select 
Start. Application server monitors your network even when the client is not running.

2 If it is not already running, start the web server. Right-click the tray icon for web server 
and select Start service.

NOTE:

On Linux start (or stop) the webserver with scripts startportal.sh start (or startportal.sh stop) located in 
the oware/synergy/tomcat-x.x.x/bin directory.

3 To see the client interface, open a browser, and enter this in the URL field: 
http://[hostname or host IP address]:8080.

NOTE:

Screen resolution must equal or exceed 1280 x 1080 pixels.

4 Log in for the first time as admin (password admin).

5 Dell OpenManage Network Manager should appear with the standard set of page 
configurations for your package. You can typically reconfigure these defaults. See the User 
Guide for guidance about how to do that.

NOTE:

Instead of oware, in Unix systems type . /etc/.dsienv —[dot][space]/etc/[dot]dsienv)

Configuring Dell OpenManage Network 
Manager Users
As an Administrator, you can configure Users, and Roles to identify support teams (examples: 
administration, engineering and operations) and configure permissions. After creating them, add 
Users to roles which configure their permissions for access and action. The following describes how 
to do this.

How To:
Add Users and connect them to Roles

Add Users with the following steps:

1 Click Go to > Control Panel and navigate to Portal > Users.

2 Click the Add > User menu item at the top of the Users screen.
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3 Enter the details of the new user. If you are editing an existing user, more fields appear. Screen 
Name, and Email Address are required. Optionally, you can enter Name, Job Title, and so on.

4 After you click Save notice that the right panel expands to include additional information. 
Make sure you specify a Password. 

5 Notice that if you are editing an existing user, or creating a new one, you can use the links on 
the right to configure connections with Roles. Roles, in particular, configure the OpenManage 
Network Manager functional permissions for that user. For example the group of Operators 
would likely have more limited capabilities than Administrators.

6 Click Save again, and the user you just configured should appear listed in the Users screen 
when you select View > All Users.

7 To assign a user to a role, click Action > Permissions and check the appropriate box next to 
the role. Configure OpenManage Network Manager functional permissions for these roles in 
Roles.

How To:
Add and Configure User Roles / Permissions

Add and configure User Roles with the following steps:

1 Click Go to > Control Panel and navigate to Portal > Roles.

2 Click the Add tab under the heading at the top of the page, and select Regular Roles. Notice 
that you can also add roles that configure permissions for sites. 

3 Enter the details of the new role (Name, Title, Description), then Save it.

4 Click Portal > Roles’ View All button to see a list of available roles, including the one you 
added.

5 By clicking the Action icon to the right of any listed Role, you can also select the role’s 
permissions to alter web portal access in a subsequent screen. 

6 Click Add to add permissions. Click the checkboxes to enable the type of permission desired.

7 To do more with Dell OpenManage Network Manager’s functional permissions, go to the 
Redcell > Permission Manager, and click to open this screen.

8 The Role to Permission mapping screen appears. Click the Edit button to the right of listed 
Roles to see and configure available permissions.

9 Click Advanced to see available permissions organized by Read, Write, Execute, Add or Delete 
actions.

10 After you have selected permissions, click Apply to accept them and add them to the role.

Notice that you can revisit this role, manage it and its membership with the Action button to 
the right of the role. You can also add users to the group by selecting and editing that user.
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How To:
Discover Your Network
To begin managing resources in your network, you must discover them to store their information in 
the application database. This begins either with the Resource Discovery Quick Navigation button 
or the Discovery Profiles portlet. 

Discovery profiles configure 
equipment discovery for Dell 
OpenManage Network Manager. 

The summary view displays the 
Name, Description, Default (the 
green check indicates the 
default profile), whether the 
profile is Scheduled and Next 
Execution Date for scheduled 
discovery. Follow these steps to 
start discovering equipment on 
your network.

1 Right click the Discovery 
Profiles list and select New.

2 The Discovery Profile Editor appears, with a step-by-step set of screens to configure resource 
discovery. You can navigate through it by clicking the screen tab names at the top, or by 
clicking the Next button at the bottom of the page.

General

3 General Parameters — Set the Name, Description and whether this profile is the baseline 
discovery default.

4 Profile Options — Select the Device Naming Format and other parameters for discovery. 

Network

5 After you click Next, the Network screen appears.

Network Type and Addresses — Select the type of entry in the pick list (IP Address(es), CIDR 
Address, Hostname, SNMP Broadcast, Subnet). 

NOTICE

(For IPv4) You can specify an IP Address range by separating the beginning and end with a dash. For 
example: 192.168.1.1 - 192.168.1.240.

The tooltips in the data entry field describe what valid entries look like. 
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6 Authentication — Here, you can Create New, or Choose Existing authentications to add to 
discovery. Authentications appear with Edit / Delete icons and Up / Down arrows on their 
right. The Up / Down arrows reorder them so the application tries the top authentication first, 
then the next, and so on. 

If you have an authentication like admin/abc123 and one that is identical with an enable-level 
login / password (admin/abc123/enable/enable123), make sure the enable authentication 
appears first in the list, otherwise, you will discover the device, but not access its enable 
functionality.

The Edit icon opens the authentication editor. Click the arrows to arrange the order in which 
credentials are tried (top first). Ordering only applies when two credentials are of the same 
type.

Actions

7 Actions — Here, you can configure Actions to run as part of discovery. The application 
executes these in top-to-bottom order.

Inspection

8 Inspect lets you preview the application’s access to devices. Click Start Inspection to begin the 
process that validates the device is available, and the application has the correct credentials.

When they are successful, the authentications appear in a nested tree under the Discover 
checkbox.

9 Save — Click Save to preserve the profile. You can then right-click it to select Execute and 
begin discovery. If you select Execute from the profile editor, the application does not save the 
profile to execute later.

Results

10 Execute — Clicking Execute begins discovery, after you confirm, the message traffic between 
Dell OpenManage Network Manager and the device appears on the Results screen.

This is a standard Audit screen whose results appear in the Audit Trails portlet.

11 A message (Discovery Profile Execute is complete) appears in the Messages at the bottom left 
of the status bar.

NOTICE

You can also schedule discovery profiles to run periodically, updating your Dell OpenManage Network 
Manager database with any network changes. 
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12 The devices in your network now appear in the Managed Resources portlet, and elsewhere (in 
Topology, for example). 

NOTE:

The application automatically adds discovered devices to the default ICMP (ping) monitor.

Incomplete Discovery
If the device is detected and responds to ping, but does not respond to Dell OpenManage Network 
Manager actions (for example: Adaptive CLI), you may have only partially discovered it. Right-click 
the device in the Managed Resources portlet and select Direct Access > Telnet. If that menu 
option does not exist, it is only partially discovered. Right-click to edit the device, and add a Telnet 
Management Interface and Authentication in those two tabs of the editor.Dell OpenManage 
Network Manager automatically adds discovered devices to the default ICMP monitor.

Install Perl
If you install Perl to take advantage of this application's Perl Scripting capabilities, you must install 
it on the path on the application server host. 

NOTE:

We recommend Perl version 5.10 or later. Some applications also require Perl as well as the Perl module 
Net::Telnet.

This application does not package Perl. If you want to use the Perl scripting features, you must 
make sure your system has Perl installed. You can find information about Perl at www.perl.com. 
Follow the downloads link to find the recommended distribution for your specific platform. 

You can find one of the recommended Perl packages from ActiveState at: www.activestate.com/
activeperl/.
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Resource Management
The Managed Resource portlet displays all the devices you have discovered.

Right-clicking a listed resource displays a menu with options described in the User Guide.

Common Setup Tasks
This portlet appears on the first page 
after you sign in, and reminds you of 
the following common tasks:

• SMTP Configuration—This 
configures how Dell OpenManage 
Network Manager sends 
notification e-mails.

Netrestore File Servers—See 
Configure an FTP/TFTP Server setup instructions below, or its description in the User Guide.

A red flag appears with the “Setup required” message in the Status column when these are not 
configured. Configuring them displays a green flag with the “Setup complete” message. Click the 
edit link in the Action column to open editors for each of these.
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Quick Navigation
The Quick Navigation portlet lets you quickly click some links to 
basic tasks:

Resource Discovery—Discover devices in your network. See 
Discover Your Network on page 9 or the User Guide for details

Link Discovery—After you have discovered resources, this 
discovers their connections. See the User Guide for more 
information.

Backup Config Files—This lets you back up discovered devices’ 
configuration files. Before you can use this feature, you must 
have servers configured as described in Configuration 
Management below, or the User Guide.

OS Image Upload—Upload firmware updates for devices. See the 
User Guide for more about these capabilities.

Deploy OS Image—This deploys firmware updates. To deploy 
images, you must have File Servers configured, as described 
above for Backup. See the User Guide for details.

License Management—This lets you see, update and manage the 
licensed capabilities of Dell OpenManage Network Manager. 
See the User Guide for details.

NOTICE

To import a license when application server is not running, type oware then licenseimporter 
[license file path] on a command line.

Configuration Management
Dell OpenManage Network Manager lets you manage device configurations. Before you begin that 
management, you must first configure an Configure an FTP/TFTP Server to get or send such 
configurations from / to devices. After configuring the Configure an FTP/TFTP Server, you can do 
Do Configuration File Backup / Restore described below.
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How To:
Configure an FTP/TFTP Server

Follow these steps to configure a server:

1 Click either the Common Setup Tasks portlet’s Netrestore File Servers link, or right click and 
select New in the File Servers portlet. 

2 After entering all required details click Save to save new file server.

3 Optionally click Test to validate the new file server is working.

How To:
Do Configuration File Backup / Restore

Provided you have permissions, you can backup configuration file(s) for a single device or group of 
devices, either on demand or as scheduled. Follow these steps:

1 In the default Dell OpenManage Network Manager screen layout, go to the Configuration 
Management > Summary page.

2 In the Managed Resources portlet, select (click on) a Managed Resource of interest.

3 Right-click on selected resource in the Managed Resources portlet, and then click File 
Management > Restore or Backup. See the OMNM User Guide for more details.

4 Enter the information needed to create the backup or restoration.

5 Optionally click Add Schedule to schedule the backup task. See the OMNM User Guide for 
details.

6 Click Execute to immediately do backup or Save to save the configured backup to run later.

How To:
Restore a single configuration to many target devices

The following steps describe restoring a single configuration to many discovered devices without 
overwriting those devices’ essential information.

1 Back up a single device’s configuration that is nearest to the kind you would like to see 
generally.

2 Right-click this backed up file in the File Management portlet, and Promote it so it appears in 
the Image Repository portlet.

3 Right-click > Edit the promoted configuration in the Image Repository.

4 Name the file, and, if necessary, configure a filter In the General Parameters tab of the editor.
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5 In the Configuration tab, locate the parameters you want to preserve in discovered devices 
when you restore this file. This can include items like the device’s DNS Hostname, IP 
Address, and so on. Delete the file’s specifics and double-click to insert the Target Params in 
place of these variables. 

6 Save the configuration.

7 Right-click to deploy this configuration.

8 You can check Generate and save for configuration only if you simply want to configure 
deployment for later, and save for now. You can also optionally name a label for the deployed 
files.

9 Select the devices, or groups of devices to which you want to deploy.

10 Click Save, Execute or Add Schedule depending on your desired outcome.

11 If you click Execute, you will have to confirm this action.

When Dell OpenManage Network Manager performs the restoration (deploy), it reads the 
Target Params from those discovered for each device, inserts those in the config file, then 
restores it, device by device, skipping any that do not pass the filter set up in step 4.

Fault Management - Problem Diagnosis
Dell OpenManage Network Manager lets you diagnose network problems with its Alarms viewer, 
and lets you monitor performance with its Performance Management - Troubleshooting 
capabilities, as described below. The following briefly outlines these capabilities.

Alarms
Alerts about network performance issues can include alarms about the following:

• Excessive interface utilization
• Unexpectedly high CPU load 
• Loss of available memory
• Slow response time 
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• Excessive interface errors 

When you receive an alarm you can take any of the following action on the alarm itself, or the 
target of the alarm:

• Assign User
• Acknowledge Alarm
• Unacknowledge Alarm
• Clear Alarm
• Show Performance

Follow these steps to get started:

1 Click to go to the Alarms page from the default screens.

2 In the Alarms portlet, click on an Alarm of interest.

NOTICE

If your Alarms portlet displays a graph of different alarm types, clicking on a particular alarm severity 
filters the list below to only display that severity. Click again to undo the filter effect.

3 Right-click on the selected alarm, and then click Acknowledge Alarm to take ownership of the 
alarm.

4 Right-click then click Assign User to select a user owner for the alarm.

5 Right-click then click Clear Alarm to remove the alarm from list.

6 Click the plus (+) in the upper right corner of the Alarms portlet to go into Expanded mode 
where you can view more details about an alarm.
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Performance Management - 
Troubleshooting 
In addition to troubleshooting faults, you can also monitor device performance with Dell 
OpenManage Network Manager. 

Monitors
Monitors display some critical performance 
metrics for devices on the network, 
including:

•Network availability 
•Bandwidth capacity utilization 
•Buffer usage and errors 
•CPU and memory utilization 
•Interface errors and discards 
•Network latency 
•Node and interface status 

To get started using monitors, follow these 
steps:

1 Click the Performance Management > Summary page, and find the Resource Monitors 
portlet on that page.

2 Hover the cursor over a Monitor of interest to see a tooltip of details about it.

3 Click to select a Monitor of interest.

4 Right-click the selected monitor in the Resource Monitors portlet, and then click Open to 
edit its details, including enabling/disabling it.

Dashboard Views
With permissions, you can view the performance data collected by the monitors, in graphical and 
tabular form including:

• Excessive interface utilization
• Unexpectedly high CPU load 
• Loss of available memory
• Slow response time 
• Excessive interface errors 

To view this data, follow these steps: 

1 Click the Performance Management > Summary page and find the Top Problem Nodes 
portlet. (
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2 Hover the cursor over a Device/Interface of interest to see a tooltip of details about its status.

3 Right-click and select Show Key Metrics, or Show Performance which opens a dashboard. 

How To:
Create Reports

If your want to automate month-end reports Dell OpenManage Network Manager lets you 
schedule either recurring reports or a single scheduled occurrence. With the correct permissions, 
you can run Inventory Reports on demand or as scheduled. You can use the Reports to troubleshoot 
and monitor performance and historical data that has been collected during the operation of the 
network. 

1 Find the Reports portlet.

2 Click to select a Report of interest.

3 Right-click, and then click Execute to run report

4 Report generation runs in the background. When it is complete, a message appears in the My 
Alerts tab at the bottom left corner.

5 Click on Messages tab to open, then click on the Report of interest and click on the View 
Details icon at the right end of entry, to view completed report.

Collaborative Diagnosis
Once Dell OpenManage Network Manager notifies you about a network problem with Fault 
Management - Problem Diagnosis or Create Reports, you can consult with other network experts 
through Dell OpenManage Network Manager’s built-in chat system. You can even meet online 
with more than one user, and share the problem report, or alarm. See the Dell OpenManage 
Network Manager User Guide for the specifics about how to do this.

Some examples of easy solutions provided by chat:

• You cannot use an FTP server. Asking a coworker with Dell OpenManage Network Manager’s 
chat reveals it is out of commission. Because you can share specific servers as a chat 
attachment, there’s never a question about which server you are discussing.

• Confirm the format of a report. Again, attaching the report to chat lets coworkers see exactly 
what you are talking about, and quickly.

• When a report reveals a problem, you can attach it to chat, and consult with coworkers about 
solutions.

• You can similarly attach schedules to chat to make sure everyone agrees they are correct.
• What you can do with a single chat session is also true of Dell OpenManage Network 

Manager’s “conferences” which amount to collaborative chat sessions, attended by more than 
one other person.
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