M8024-K Drops DHCP requests

Networking

Networking
Learn how to modernize & transform the network with the latest solutions from Dell Data Center, Campus and Wireless networking solutions.

M8024-K Drops DHCP requests

This question has suggested answer(s)

Hi All

We have a customer with a M1000e with 4x PC8024-K. I'm implementing VMware 5 (vCenter+2xHosts 5.0).

I was deployed a DHCP VM, to assign IP's to others VMs.

When clients are in same host, can obtain IP from DCHP server. If I move this client to another Host (different from DHCP Server), i can not to obtain IP Address.

The problem is in PC8024-K, because drops DHCP Requests from clients.

I'm configured DHCP Relay, IP Helper and DHCP Snooping is Disabled.

My config:

!Current Configuration:

!System Description "PowerConnect M8024-k, 4.2.0.4, VxWorks 6.6"

!System Software Version 4.2.0.4

!Cut-through mode is configured as disabled

!System Operational Mode "Normal"

!

configure

no mode simple

vlan database

vlan 172

vlan routing 1 1

exit

slot 1/0 2    ! PCM8024-k

slot 1/1 3    ! DELL 10GBaseT Card

stack

member 1 1    ! PCM8024-k

exit

interface out-of-band

ip address 192.168.200.103 255.255.255.0 0.0.0.0

exit

interface vlan 1

no ip dhcp relay information check-reply

exit

username "root" password 5f4dcc3b5aa765d61d8327deb882cf99 privilege 15 encrypted

line telnet

login authentication defaultList

enable authentication enableList

exit

line ssh

login authentication defaultList

enable authentication enableList

exit

no iscsi enable

no ip dhcp snooping verify mac-address

dhcp l2relay

dhcp l2relay vlan 1,172

dhcp l2relay circuit-id vlan 1,172

dhcp l2relay remote-id 82 vlan 1

dhcp l2relay remote-id 82 vlan 172

!

interface Te1/0/1

ip dhcp snooping log-invalid

dhcp l2relay

dhcp l2relay trust

ip arp inspection trust

switchport access vlan 172

exit

!

interface Te1/0/2

ip dhcp snooping log-invalid

dhcp l2relay

dhcp l2relay trust

ip arp inspection trust

switchport access vlan 172

exit

!

interface Te1/0/3

ip dhcp snooping log-invalid

dhcp l2relay

dhcp l2relay trust

ip arp inspection trust

switchport access vlan 172

exit

exit

Any help are welcome!

Thanks in Advance!

Regards:

Antonio

 

All Replies
  • I do not see the IP Helper in your configuration. You will need it to get the DHCP working.

    To configure the helper address, identify the router interface that will receive the broadcasts for UDP services. In interface configuration mode, use the "helper-address" command to define the address to which UDP broadcasts for services should be forwarded.

    Sample config:

    console(config)# interface vlan 11

    console(config-if-vlan11)# helper-address 10.0.0.55 113

    Console(config)#

    Use the ip helper-address command in Global Configuration mode to have the device forward User Datagram Protocol (UDP) broadcasts received on an interface.

    Sample config:

    console(config)#interface vlan 11

    console(config-if-vlan11)# helper-address 10.0.0.55 113

    Console(config)#

    console(config)#  ip helper-address 12.0.0.1 12.0.0.14 112

    console(config)#  ip helper-address 13.0.0.1 12.0.0.14

    Let us know if you have further questions.

    Get Support on Twitter @DellCaresPro

    Download the Dell Quick Resource Locator app today to access PowerEdge support content on your mobile device! (iOS, Android, Windows)