Network bridge prevention powerconnect

Networking

Networking
Learn how to modernize & transform the network with the latest solutions from Dell Data Center, Campus and Wireless networking solutions.

Network bridge prevention powerconnect

  • Our network consists of Dell Powerconnect 3548s and 5548s connected to a stack of 6248's at the core. All of the client ports are configured for PortFast mode. We had an issue where one of the users had bridged their wireless and LAN connections while at home so when they connected back to our network it wreaked havoc. I would have thought that spanning-tree would have disabled the port upon receiving the bpdu. spanning-tree mode is RSTP.

    The log shows:
    25-Aug-2011 9:06:32 :%STP-I-EDGEPORT: Attention: port e5 from which the bpdu was received is configured as Fast Port

    25-Aug-2011 9:04:26 :%LINK-I-Up: e5

    25-Aug-2011 9:04:26 :%STP-W-PORTSTATUS: e5: STP status Forwarding

    How can I configue the swicthes to prevent these loops? I know cisco has bpdu guard and it looks like the 6248 supports "spanning-tree bpdu-protection". What about the client access switches? Or is there some other configuration?

    Thanks,
    Ken
  • Looks like the 3548 does have a per port setting of "spanning-tree bpduguard". The PowerConnect 3500 Series CLI manual does not include this command which has me a little worried. I'll test it. Also looks like the 5500 series has the same command and it is documented.

    This is likely what I'll try:
    interface range ethernet e(1-48)
    spanning-tree portfast
    spanning-tree bpduguard
    exit