Dell 4032F - Forwarding state to the Blocking state in instance 0 - Networking - Forum - Networking - Dell Community

Dell 4032F - Forwarding state to the Blocking state in instance 0

Networking

Networking
Learn how to modernize & transform the network with the latest solutions from Dell Data Center, Campus and Wireless networking solutions.

Dell 4032F - Forwarding state to the Blocking state in instance 0

This question is not answered

Dear Support,

I have two Dell switch 4032F (stacking), firmware 6.3.2.7 and the port 10G (trunk) connected to Nutanix server.
The problem is when moving vm to other node, the port on dell switch going up and down. please see the detail log

Topology

Logging:

1 Aug 13 19:15:49 2017 Te2/0/3 is transitioned from the Learning state the Forwarding state in instance 0
2 Aug 13 19:15:46 2017 Te2/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
3 Aug 13 19:15:46 2017 Link Up: Te2/0/3
4 Aug 13 19:15:45 2017 Te2/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
5 Aug 13 19:15:45 2017 Link on Te2/0/3 is failed
6 Aug 13 19:15:45 2017 Link Down: Te2/0/3
7 Aug 13 19:15:39 2017 Te1/0/3 is transitioned from the Learning state to the Forwarding state in instance 0
8 Aug 13 19:15:36 2017 Te1/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
9 Aug 13 19:15:36 2017 Link Up: Te1/0/3
10 Aug 13 19:15:35 2017 Te1/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
11 Aug 13 19:15:35 2017 Link on Te1/0/3 is failed
12 Aug 13 19:15:35 2017 Link Down: Te1/0/3
13 Aug 13 19:12:48 2017 Te2/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
14 Aug 13 19:12:45 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
15 Aug 13 19:12:45 2017 Link Up: Te2/0/2
16 Aug 13 19:12:44 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
17 Aug 13 19:12:44 2017 Link on Te2/0/2 is failed
18 Aug 13 19:12:44 2017 Link Down: Te2/0/2
21 Aug 13 18:22:16 2017 Te2/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
22 Aug 13 18:22:16 2017 Te1/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
23 Aug 13 18:22:13 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
24 Aug 13 18:22:13 2017 Link Up: Te1/0/2
25 Aug 13 18:22:13 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
26 Aug 13 18:22:13 2017 Link Up: Te2/0/2
27 Aug 13 18:22:12 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
28 Aug 13 18:22:12 2017 Link on Te2/0/2 is failed
29 Aug 13 18:22:12 2017 Link Down: Te2/0/2
30 Aug 13 18:22:12 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
31 Aug 13 18:22:12 2017 Link on Te1/0/2 is failed
32 Aug 13 18:22:12 2017 Link Down: Te1/0/2
33 Aug 13 18:20:52 2017 Te2/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
34 Aug 13 18:20:52 2017 Te1/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
35 Aug 13 18:20:49 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
36 Aug 13 18:20:49 2017 Link Up: Te2/0/2
37 Aug 13 18:20:49 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
38 Aug 13 18:20:49 2017 Link Up: Te1/0/2
39 Aug 13 18:20:48 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
40 Aug 13 18:20:48 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
41 Aug 13 18:20:48 2017 Link on Te1/0/2 is failed
42 Aug 13 18:20:48 2017 Link Down: Te1/0/2
43 Aug 13 18:20:48 2017 Link on Te2/0/2 is failed
44 Aug 13 18:20:48 2017 Link Down: Te2/0/2
45 Aug 13 18:15:12 2017 Te2/0/3 is transitioned from the Learning state to the Forwarding state in instance 0
46 Aug 13 18:15:12 2017 Te1/0/3 is transitioned from the Learning state to the Forwarding state in instance 0
47 Aug 13 18:15:09 2017 Te2/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
48 Aug 13 18:15:09 2017 Link Up: Te2/0/3
49 Aug 13 18:15:09 2017 Te1/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
50 Aug 13 18:15:09 2017 Link Up: Te1/0/3
51 Aug 13 18:15:08 2017 Te2/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
52 Aug 13 18:15:08 2017 Link on Te2/0/3 is failed
53 Aug 13 18:15:08 2017 Link Down: Te2/0/3
54 Aug 13 18:15:08 2017 Te1/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
55 Aug 13 18:15:08 2017 Link on Te1/0/3 is failed
56 Aug 13 18:15:08 2017 Link Down: Te1/0/3
57 Aug 13 18:13:42 2017 Te1/0/3 is transitioned from the Learning state to the Forwarding state in instance 0
58 Aug 13 18:13:42 2017 Te2/0/3 is transitioned from the Learning state to the Forwarding state in instance 0
59 Aug 13 18:13:39 2017 Te1/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
60 Aug 13 18:13:39 2017 Link Up: Te1/0/3
61 Aug 13 18:13:39 2017 Te2/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
62 Aug 13 18:13:39 2017 Link Up: Te2/0/3
63 Aug 13 18:13:38 2017 Te2/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
64 Aug 13 18:13:38 2017 Link on Te2/0/3 is failed
65 Aug 13 18:13:38 2017 Link Down: Te2/0/3
66 Aug 13 18:13:38 2017 Te1/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
67 Aug 13 18:13:38 2017 Link on Te1/0/3 is failed
68 Aug 13 18:13:38 2017 Link Down: Te1/0/3
69 Aug 13 18:13:37 2017 Te1/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
70 Aug 13 18:13:37 2017 Link Up: Te1/0/3
71 Aug 13 18:13:36 2017 Te1/0/3 is transitioned from the Forwarding state to the Blocking state in instance 0
72 Aug 13 18:13:36 2017 Link on Te1/0/3 is failed
73 Aug 13 18:13:36 2017 Link Down: Te1/0/3
74 Aug 13 18:10:42 2017 Te2/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
75 Aug 13 18:10:39 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
76 Aug 13 18:10:39 2017 Link Up: Te2/0/2
77 Aug 13 18:10:38 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
78 Aug 13 18:10:38 2017 Link on Te2/0/2 is failed
79 Aug 13 18:10:38 2017 Link Down: Te2/0/2
80 Aug 13 18:07:37 2017 Te1/0/1 is transitioned from the Learning state to the Forwarding state in instance 0
81 Aug 13 18:07:34 2017 Te1/0/1 is transitioned from the Forwarding state to the Blocking state in instance 0
82 Aug 13 18:07:34 2017 Link Up: Te1/0/1
83 Aug 13 18:07:33 2017 Te1/0/1 is transitioned from the Forwarding state to the Blocking state in instance 0
84 Aug 13 18:07:33 2017 Link on Te1/0/1 is failed
85 Aug 13 18:07:33 2017 Link Down: Te1/0/1
86 Aug 13 18:06:03 2017 Te1/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
87 Aug 13 18:06:00 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
88 Aug 13 18:06:00 2017 Link Up: Te1/0/2
89 Aug 13 18:05:59 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
90 Aug 13 18:05:59 2017 Link on Te1/0/2 is failed
91 Aug 13 18:05:59 2017 Link Down: Te1/0/2
92 Aug 13 18:05:11 2017 Te2/0/1 is transitioned from the Learning state to the Forwarding state in instance 0
93 Aug 13 18:05:08 2017 Te2/0/1 is transitioned from the Forwarding state to the Blocking state in instance 0
94 Aug 13 18:05:08 2017 Link Up: Te2/0/1
95 Aug 13 18:05:06 2017 Te2/0/1 is transitioned from the Forwarding state to the Blocking state in instance 0
96 Aug 13 18:05:06 2017 Link on Te2/0/1 is failed
97 Aug 13 18:05:06 2017 Link Down: Te2/0/1
98 Aug 13 18:01:46 2017 Te2/0/1 is transitioned from the Learning state to the Forwarding state in instance 0
99 Aug 13 18:01:43 2017 Te2/0/1 is transitioned from the Forwarding state to the Blocking state in instance 0
100 Aug 13 18:01:43 2017 Link Up: Te2/0/1
101 Aug 13 18:01:42 2017 Te2/0/1 is transitioned from the Forwarding state to the Blocking state in instance 0
102 Aug 13 18:01:42 2017 Link on Te2/0/1 is failed
103 Aug 13 18:01:42 2017 Link Down: Te2/0/1
104 Aug 13 17:37:58 2017 Te2/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
105 Aug 13 17:37:58 2017 Te1/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
106 Aug 13 17:37:55 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
107 Aug 13 17:37:55 2017 Link Up: Te2/0/2
108 Aug 13 17:37:55 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
109 Aug 13 17:37:55 2017 Link Up: Te1/0/2
110 Aug 13 17:37:54 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
111 Aug 13 17:37:54 2017 Link on Te1/0/2 is failed
112 Aug 13 17:37:54 2017 Link Down: Te1/0/2
113 Aug 13 17:37:53 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
114 Aug 13 17:37:53 2017 Link on Te2/0/2 is failed
115 Aug 13 17:37:53 2017 Link Down: Te2/0/2
116 Aug 13 17:36:36 2017 Te2/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
117 Aug 13 17:36:36 2017 Te1/0/2 is transitioned from the Learning state to the Forwarding state in instance 0
118 Aug 13 17:36:33 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
119 Aug 13 17:36:33 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
120 Aug 13 17:36:33 2017 Link Up: Te2/0/2
121 Aug 13 17:36:33 2017 Link Up: Te1/0/2
122 Aug 13 17:36:30 2017 Te2/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0
123 Aug 13 17:36:30 2017 Te1/0/2 is transitioned from the Forwarding state to the Blocking state in instance 0

Best Regards,

All Replies
  • Is link aggregation configured on these ports? Or are the servers using a form of switch independent bonding?

    Are these server facing interfaces configured for portfast? What spanning tree mode is being used? Do you have spanning tree priorities manually configured on the switches?

    Is it just these three servers that are affected? Or does the logging go on to show other interfaces making this transition?

    Daniel Covey
    Dell EMC | Enterprise Support Services
    Get support on Twitter: @DellCaresPRO

    Download our QRL app: iOSAndroidWindows

  • Is link aggregation configured on these ports?
    >> no, only trunk configuration

    Or are the servers using a form of switch independent bonding?
    >> yes using switch independent bonding

    Are these server facing interfaces configured for portfast?
    >> no use portfast

    What spanning tree mode is being used?
    >> rstp

    Do you have spanning tree priorities manually configured on the switches?
    >> no

    Is it just these three servers that are affected?
    >> four server

    Or does the logging go on to show other interfaces making this transition?
    >> no 

    ***************** Show Spanning-tree *****************
    Spanning Tree: Enabled - BPDU Flooding: Disabled - Portfast BPDU Filtering: Disabled
    Mode: rstp
    CST Regional Root: 80:00:14:18:77:E9:E5:9B
    Regional Root Path Cost: 0
    ROOT ID

    ***************** Show Running Config ***********

    !Current Configuration:
    !System Description "Dell Networking N4032F, 6.3.2.7, Linux 3.7.10-20383c08"
    !System Software Version 6.3.2.7
    !Cut-through mode is configured as disabled
    !
    configure
    vlan 10-30,50
    exit
    vlan 10
    name "SERVER"
    exit
    vlan 20
    name "CLIENT"
    exit
    vlan 30
    name "CLIENT"
    exit
    vlan 50
    name "MANAGEMENT"
    exit
    ip telnet server disable
    hostname "DELL-4032F"
    slot 1/0 3 ! Dell Networking N4032F
    slot 1/1 8 ! Dell 10GBase-T Card
    slot 2/0 3 ! Dell Networking N4032F
    slot 2/1 8 ! Dell 10GBase-T Card
    clock timezone -1 minutes 0
    stack
    member 1 2 ! N4032F
    member 2 2 ! N4032F
    exit
    no ip http server
    interface vlan 1
    exit
    interface vlan 50
    ip address 192.168.50.2 255.255.255.0
    exit
    ip default-gateway 192.168.50.1
    ip ssh server
    application install SupportAssist auto-restart start-on-boot
    !
    interface Te1/0/1
    description "CONNECTED TO NUTANIX NODE A"
    switchport mode trunk
    exit
    !
    interface Te1/0/2
    description "CONNECTED TO NUTANIX NODE B"
    switchport mode trunk
    exit
    !
    interface Te1/0/3
    description "CONNECTED TO NUTANIX NODE C"
    switchport mode trunk
    exit
    !
    interface Te1/0/4
    description "CONNECTED TO NUTANIX NODE D"
    switchport mode trunk
    exit
    !
    interface Te1/0/5
    switchport mode trunk
    exit
    !
    interface Te1/0/6
    switchport mode trunk
    exit
    !
    interface Te1/0/7
    switchport mode trunk
    exit
    !
    interface Te1/0/8
    switchport mode trunk
    exit
    !
    interface Te1/0/9
    switchport mode trunk
    exit
    !
    interface Te1/0/10
    switchport mode trunk
    exit
    !
    interface Te1/0/11
    switchport mode trunk
    exit
    !
    interface Te1/0/12
    switchport mode trunk
    exit
    !
    interface Te1/0/13
    switchport mode trunk
    exit
    !
    interface Te1/0/14
    switchport mode trunk
    exit
    !
    interface Te1/0/15
    switchport mode trunk
    exit
    !
    interface Te1/0/16
    switchport mode trunk
    exit
    !
    interface Te1/0/17
    switchport mode trunk
    exit
    !
    interface Te1/0/18
    switchport mode trunk
    exit
    !
    interface Te1/0/19
    switchport mode trunk
    exit
    !
    interface Te1/0/20
    switchport mode trunk
    exit
    !
    interface Te1/0/21
    switchport mode trunk
    exit
    !
    interface Te1/0/22
    description "CONNECTED TO HP SERVER"
    switchport mode trunk
    exit
    !
    interface Te1/0/23
    description "STACKING"
    exit
    !
    interface Te1/0/24
    description "STACKING"
    exit
    !
    interface Te1/1/1
    description "CONNECTED TO NUTANIX NODE A-IPMI"
    switchport access vlan 2
    exit
    !
    interface Te1/1/2
    description "CONNECTED TO NUTANIX NODE B-IPMI"
    switchport access vlan 2
    exit
    !
    interface Te1/1/3
    description "CONNECTED TO ILO PORT - HP TAPE"
    switchport access vlan 2
    exit
    !
    interface Te1/1/4
    channel-group 1 mode active
    description "CONNECTED TO CORE-SW"
    switchport mode trunk
    exit
    !
    interface Te2/0/1
    description "CONNECTED TO NUTANIX NODE A"
    switchport mode trunk
    exit
    !
    interface Te2/0/2
    description "CONNECTED TO NUTANIX NODE B"
    switchport mode trunk
    exit
    !
    interface Te2/0/3
    description "CONNECTED TO NUTANIX NODE C"
    switchport mode trunk
    exit
    !
    interface Te2/0/4
    description "CONNECTED TO NUTANIX NODE D"
    switchport mode trunk
    exit
    !
    interface Te2/0/5
    switchport mode trunk
    exit
    !
    interface Te2/0/6
    switchport mode trunk
    exit
    !
    interface Te2/0/7
    switchport mode trunk
    exit
    !
    interface Te2/0/8
    switchport mode trunk
    exit
    !
    interface Te2/0/9
    switchport mode trunk
    exit
    !
    interface Te2/0/10
    switchport mode trunk
    exit
    !
    interface Te2/0/11
    switchport mode trunk
    exit
    !
    interface Te2/0/12
    switchport mode trunk
    exit
    !
    interface Te2/0/13
    switchport mode trunk
    exit
    !
    interface Te2/0/14
    switchport mode trunk
    exit
    !
    interface Te2/0/15
    switchport mode trunk
    exit
    !
    interface Te2/0/16
    switchport mode trunk
    exit
    !
    interface Te2/0/17
    switchport mode trunk
    exit
    !
    interface Te2/0/18
    switchport mode trunk
    exit
    !
    interface Te2/0/19
    switchport mode trunk
    exit
    !
    interface Te2/0/20
    switchport mode trunk
    exit
    !
    interface Te2/0/21
    switchport mode trunk
    exit
    !
    interface Te2/0/22
    description "CONNECTED TO HP SERVER"
    switchport mode trunk
    exit
    !
    interface Te2/0/23
    description "STACKING"
    exit
    !
    interface Te2/0/24
    description "STACKING"
    exit
    !
    interface Te2/1/1
    description "CONNECTED TO NUTANIX NODE C-IPMI"
    switchport access vlan 2
    exit
    !
    interface Te2/1/2
    description "CONNECTED TO NUTANIX NODE D-IPMI"
    switchport access vlan 2
    exit
    !
    interface Te2/1/3
    description "CONNECTED TO ILO PORT - HP SERVER"
    switchport access vlan 2
    exit
    !
    interface Te2/1/4
    channel-group 1 mode active
    description "CONNECTED TO CORE-SW"
    switchport mode trunk
    exit
    !
    interface port-channel 1
    switchport mode trunk
    exit
    snmp-server engineid local 800002a203141877e9e597
    exit

  • Here are a couple of suggested changes.

    Enable portfast on the server facing interfaces. This will allow the interfaces to transition directly to the forwarding state.

    Manually configure spanning tree priorities. The core switch should have a priority of 4096, distribution can be set to 16384, and the access layer left at the default 32768. The numbers can vary based on how large the network is, but i am sure you get the general idea.

    Then test to see if this changes the behavior at all.

    Daniel Covey
    Dell EMC | Enterprise Support Services
    Get support on Twitter: @DellCaresPRO

    Download our QRL app: iOSAndroidWindows

  • A. yesterday enable portfast on the server facing interfaces already done and I tried moving or live migration the VMs again, but the port status still down and up, please see the log, 

    1 Aug 21 15:59:20 2017 Te2/0/1 is transitioned from the Learning state to the Forwarding state in instance 0

    2 Aug 21 15:59:20 2017 Te2/0/1 is transitioned from the Forwarding state to the Blocking state in instance 0
    3 Aug 21 15:59:20 2017 Link Up: Te2/0/1
    4 Aug 21 15:59:19 2017 Te2/0/1 is transitioned from the Forwarding state to the Blocking state in instance 0
    5 Aug 21 15:59:19 2017 Link on Te2/0/1 is failed
    6 Aug 21 15:59:19 2017 Link Down: Te2/0/1

    B. This is log of interface facing to Backup Server (running symantec Backup Exec) before enable  portfast, the interface status down and up. 

    42 Aug 16 18:14:34 2017 Te1/0/22 is transitioned from the Learning state to the Forwarding state in instance 0
    43 Aug 16 18:14:34 2017 Te2/0/22 is transitioned from the Learning state to the Forwarding state in instance 0
    44 Aug 16 18:14:31 2017 Te1/0/22 is transitioned from the Forwarding state to the Blocking state in instance 0
    45 Aug 16 18:14:31 2017 Link Up: Te1/0/22
    46 Aug 16 18:14:31 2017 Te2/0/22 is transitioned from the Forwarding state to the Blocking state in instance 0
    47 Aug 16 18:14:31 2017 Link Up: Te2/0/22
    48 Aug 16 18:14:28 2017 Te2/0/22 is transitioned from the Forwarding state to the Blocking state in instance 0
    49 Aug 16 18:14:28 2017 Link on Te2/0/22 is failed
    50 Aug 16 18:14:28 2017 Link Down: Te2/0/22
    51 Aug 16 18:14:28 2017 Te1/0/22 is transitioned from the Forwarding state to the Blocking state in instance 0
    52 Aug 16 18:14:28 2017 Link on Te1/0/22 is failed
    53 Aug 16 18:14:28 2017 Link Down: Te1/0/22

    It's possible the problem when the port interface traffic high such as vms live migration, running backup make the interface down and up?

    Is there additional configuration for solved this problem?