iDRAC9 with Lifecycle Controller firmware version 3.00.00.00 enables Dell Update Package (DUP) dependency feature for all the Dell PowerEdge servers. Prior to the 3.00.00.00 release, a situation could have occurred where a firmware may have dependencies on a previous version of firmware to be installed on a given component or even another component.

Now, with this version of firmware, customers who want to use the Lifecycle Controller user interface for firmware update with dependencies can see required dependencies and block the new firmware updates in case all required dependency firmware are not installed. This will result in proper firmware update or rollback.

This technical white paper will explain how to detect and report the necessary Update Package dependencies to help the customer understand and apply these dependencies in a proper order.