Last Logged On User always Admin when restarting with FBWF On (Domain Users) - Wyse and Windows Embedded Standard (WES7, WE8S) - Wyse Thin Clients - Dell Community

Last Logged On User always Admin when restarting with FBWF On (Domain Users)

Last Logged On User always Admin when restarting with FBWF On (Domain Users)

  • The setup:  6 Wyse Z90 thin clients with WES7 SP1 connecting to a WinServer 2012 R2 Terminal Server via RDP.  The clients are added to the domain and can successfully connect to the terminal server.  All domain profiles have been added  to the NetXclean.ini file and the profiles persist after a restart with the FBWF on or off.

    The issue: When restarting the computer with the FBWF On, the user logon always defaults to Administrator.

    Desired behavior: The client should present the last logged on user if a restart occurs.

    Attempted: 1. FBWF Off - The last user is presented at logon.  However, the file structure is open to writes. Does not solve issue.

    2. Change [Profiles] P1 to desired user.  Administrator presented at logon.  Does not solve issue.

    3. Changed [Parameters] SaveDynamicProfiles=1 to 2. Then to 7 to try to save all profiles (P1 = Adminisrtrator, P2 = User, P3 to P7 = Other users) and when FBWF = On, it always shows Administrator instead of last logged in user. Does not solve issue.

    I look forward to any tips or questions! I will try to answer as quickly as possible and I hope that there is some easy solution out there that I just can't think of or find.

  • The solution is:

    • Login as administrator
    • Disable the Write Filter
    • Login as Administrator
    • Open the Control Panel
    • Launch the WinLog applet
    • Change the username, password and domain desired
    • logout and verify
    • Login as administrator
    • Enable Write Filter

    That should take care of this problem.

    Note: To login as administrator from another account once WinLog is changed to another user, press and hold the "Left-Shift" and from start select "Logout". You should be presented with the configured users.

    Roger Montalvo

    Here are some helpful links:

  • Thank you for the answer!  That will only change the defaults permanently, it doesn't cause the behavior of having the last logged in user saved after a system restart.

    I've decided to just enable local security policy to have the user and password fields always be blank at startup  (Admin tools -> Local Security Policy -> Local Policy -> Security Options -> "Interactive logon: Do not display the last user name" = [Disabled -> Enabled])

    This will at least make people aware that they shouldn't try to log in as admin and need to enter their login details each time.

  • Check under the Admin Control Panel the WinLog applet and verify that the box Enable AutoLogin is not enabled. See below.

    Roger Montalvo

    Here are some helpful links: