User Profile Settings Wont Stay After Reboot - Wyse and Windows Embedded Standard (WES7, WE8S) - Wyse Thin Clients - Dell Community

User Profile Settings Wont Stay After Reboot

User Profile Settings Wont Stay After Reboot

  • User Profile Settings Wont Stay After Reboot

    I have a D90D7 that I am trying to configure. I need the device to auto login as a local user. When that user logs in I need it to auto launch an RDP session with cached credentials. I am able to do all of these things but after rebooting everything under the local profile is removed and it defaults back to the way it was before I configured it. I have tried disabling write filter> make changes> re-enable and it still wont keep them. Even with the write filter off the setttings will not hold through a reboot.

    I found a utility that someone mentioned can be edited to keep the profile from being "refreshed" after logout and added this profile in the list of profiles to ignore. This did not resolve the issue.

  • I'm having the same problems. Sometimes when the Wyse is rebooted it goes to state "Applying Settings" and stays there forever. The only way to have access to the desktop is to pull out the Ethernet cable, reboot the Wyse and after it's started, connect the Ethernet cable again. It's configured with Fixed IP address and the XML config file is in a local folder.

    Any suggestions?

    Thanks,
    Fernando

  • same problem :-(

    I am having the same problem,
    I have 16 thin client to configure in the same way, trying to use the WCM tool.

    I need them all to auto login as a local user.
    When it logs on it should auto launch an RDP session with cashed credentials.

    anyone have any

  •  Thumbs downUpdate

    I am working with Wyse support right now and they have yet to resolve the issue. The tech keeps telling me that its weird and shouldnt be happening..... a lot of help that does. Just to make sure we are all on the same page. My WCM version is 1.2.1.0 and Wyse client information is:

    Wyse D90D7 Thin Client
    Version: 9.04 (build 0855.4096)
    Windows Embedded Version: 6.01 Build (7601) Service Pack 1


    Technician thinks the best solution is going to a complete reload of firmware. Can't wait to waste my time fixing what was supposed to be an easy/quick deployment solution.

  • Agarner565,
    What you need to do is login as the Administrator (logoff from user while pressing the left shift key). Once logged in as the administrator, "Disable" the FBWF. This will reboot your thin client and log you in as the default user. Make the changes you need to make and save them. Reboot the thin client. Login as Administrator and "Disable" the FBWF. This will reboot your client to the default user. Now you can verify proper operation.

     

     

     


    Roger Montalvo 
    Visit our Dell Wyse Thin Client Knowledge Base and Manuals web site at www.wyse.com/KB
    Visit our Dell Wyse PocketCloud Knowledge Base and Manuals web site at http://pocketcloudsupport.wyse.com/forums
    [SIGPIC][/SIGPIC]

  • Is there any solution to this problem? The procedure mentioned above i.e. of Disable the FBWF make the required changes and then again Disable it does not work.

  • Hi,

    In Agarner565 post,

    the last step is ENABLE the FBWF.

    Also, while FBWF is DISABLED you can edit NETXCLEAN.ini, add the proper lines for the user account you want to exclude from deleting changes upon logoff or reboot.

    After you edited NETXCLEAN.ini, and save the changes, you have to restart the netxclean service (I do not know the proper name of that service from my head right now).

    All that have to be done while FBWF is DISABLED.

    So, in short:

    Login as Administrator

    DISABLE FBWF - restart

    Log in as user you want to make changes and make changes

    Logoff and login as Administrator

    Edit NETXCLEAN.ini (more about it at: http://www.dell.com/support/article/us/en/19/SLN291067/EN )

    Save NETXCLEAN.ini

    Restart "NETXCLEAN" service

    Logoff - login as user check if the changes are still there.

    Logoff - login as Administrator

    ENABLE FBWF  - restart

    That is how we done it in our environment and it works !

    Kind regards,

    Neven Kottni

  • What if we do not use this NETXCLEAN utility? And what if Agarner565 post solution does not work? What could be the root cause of this problem?

  • Hi Humayun Muzaffar,

    What if...?

    Agarner565 and myself posted solutions which are working in our environments, together with some "rules"

    for working with users/profiles in Windows Embedded with FBWF.

    For first troubleshooting/testing step I would recommend to you to DISABLE FBWF.

    Then make any changes/installations under user account you are testing with.

    While FBWF is still DISABLED logoff/rrestart/shut down Wyse and see if changes are permanent.

    If they are not then NETXCLEAN.INI probably should be involved in the process or there is some other problem I am not aware off.

    If everything is OK with that "setup", ENABLE FBWF and see are the changes still there (all of them, some,...)

    If they are - problem solved.

    If they are not, follow the steps mentioned in our earlier posts carefully (step by step) and see the results.

    If they are OK - problem solved.

    If not - contact the Wyse/Dell support because....

    In meantime try to describe what exactly you would like to install/set up under "default user" account, is Wyse ina Active Directory or in Workgroup,...

    Kind regards,

    Neven Kottnig

  • Hi

    I read the post because i had the same issue, i follow all the provided instructions and it connects as a user without forgetting my preferences, but now i have this issue:

    When i connect as a Administrator everything goes very well, but, as a user, the connection ask for my credentials password and i want to connect automaticaly.

    I write down my USER and Password and mark the propper option.

    What could be wrong?

    I'm using a Windows 7 computer as a server and trying to connect my wyse in RDP Mode under a work group. 

  • Make sure :

    • Disable the FBWF from the Administrator account. 
    • Login as User and launch your RDP client.
    • Enter the required credentials and save your configuration.
    • Login as Administrator
    • Open the control panel
    • Select the File Explorer Options
    • Select the View tab and check the radio button "Show Hidden files, folders, or drives"
    • Click ok to save
    • Open File Manager
    • Go to c:\users\user\appdata\roaming\microsoft\windows\start menu\programs\startup
    • Copy the RDP file to this location
    • Logoff Administrator and Login as user to verify
    • Is this is correct, go back to the Administrator account and Enable the write filter.

    Roger Montalvo

    Here are some helpful links: