Wyse T50 Tx0 problems with autologin - Wyse and Linux - Wyse Thin Clients - Dell Community

Wyse T50 Tx0 problems with autologin

This question is not answered

Wyse T50 Tx0 problems with autologin


I am new to these forums and forgive me if I am posting in the wrong category.

I have configured this terminal to use autologin using GUEST user and also using wlx.ini to load configuration automatically.

Everything works fine, I am able to login into out Citrix XenApp farm, then logout.

Then after I have logged out, if I press the power button on the unit I am presented with a menu to either logout, shutdown, suspend etc. So I click shutdown.

The terminal shuts down correctly.

When I switch it on next, for some reason it has switched to ADMIN user for the autologin, therefore all my settings are open to anyone to be changed.

This must be a bug or I am doing something wrong.

I replicated this scenario multiple times and the autologin will revert to the ADMIN user.

Can anyone help me here?

Thanks and regards


All Replies
  • Can anyone help?

  • Hi,

    How do you manage your clients, are you using WDM, ini file configuration or something else?

  • I just use ini files (no WDM) by pointing the terminal in the admin ini section to a server that has c:\inetpub\ftproot\wyse\wlx\wlx.ini. Of course I do not use this path in terminal setting, I use ftp://server_name/wyse.

    The problem that I have is, that after setting the terminal for autologin from the guest account, it automatically connects to the citrix farm using the wlx.ini file, but when I shutdown the terminal and then start it again, the terminal autologin account has switched from guest to admin by itself.

    This is a security problem because users can escape out of the autologin and they are presented with the admin settings that can be tempered with.



  • Good stuff, that's how we use it too - though we use RDP not Citrix, I'm sure the autologin should be the same.
    Any chance you could post your wlx.ini?

  • Here it is:


    DeskColor="000 000 000"
    privilege=high Lockdown=no

    # ica information (needs line continuation character “\”)

    # New XenApp Farm Connector

    connect=ica \
    HttpBrowsing=yes \
    browserip=xen:8080 \
    description="XenApp Desktop" \
    application="XenApp Desktop" \
    icon=fsulogo.bmp \
    domainname=fsunion \
    Fullscreen=yes \
    autoconnect=yes \

    Thanks and regards


  • First thing instantly stands out is the last line of your ICA config - where you have the line:
    autoconnect=yes \

    Remove that trailing \ - the instructions aren't all that clear, but the last line of a connection doesn't need the \ else it can get confused!

    Did you use anything to make this wlx file, or did you build it from scratch? Wyse keep recommending an unofficial tool called 'ConfGen' (available here: http://www.freewysemonkeys.com/modul...name=Downloads) - I'm not too keen on it, but it can help make sure you've got all the syntax and layout correct. 

    Just for reference, I'll post mine with all the important bits blanked for security:

    #================================================= ============#
    #====== WLX ini File for Wyse T50 ======#
    #=Last Modified 15/01/2013====================================#


    TimeFormat="24-hour format"
    TimeZone="GB" ManualOverride=yes
    AutoLogin=yes Countdown=0

    #RDP Session

    Host=****** \
    Description="Remote Desktop" \
    Domainname=*** \
    Fullscreen=yes \
    LocalCopy=no \
    NLA=true \
    Reconnect=no \


    Description="Chromium" \
    Icon=chromiumnew.png \
    LocalCopy=no \
    CleanProfileOnClose=false \
    Reconnect=no \
    Resolution=FullScreen \

    EDIT: Strangely all the '\' symbols I've written in that quote have turned into | symbols!

    EDIT 2:

    Also forgot to mention:
    I would remove 'SignOn=0', add in the lines:
    AutoLogin=yes Countdown=0

    Think that *should* do it - but keep a backup of your old wlx just in case!