s50 rdp login issue with connection broker - Wyse and Linux - Wyse Thin Clients - Dell Community

s50 rdp login issue with connection broker

s50 rdp login issue with connection broker

  • s50 rdp login issue with connection broker

    Using s50, winserv 2008r2, and connection broker.

    Connecting to a rdp connection broker using round robin.
    First login works fine.

    If you try and connect to the same rdp session from a different terminal the login fails resulting in you sitting at an rdp login screen with a username/domain that looks like it is written in chinese. If you then click on login as different user and put the full username(including domain) then the login procedes normally and the session is restored.

    The problem seems to happen more frequently when your open session is on one server, server2, and you connect to rdp through dns roundrobin to a different server, server3. Connection broker will then redirect your connection back to server2 and that is where it fails.

    The problem does not happen with rdp sessions through windows, only on the terminal. Could it be an issue with the rdp version on the terminal is not compatible? We did purchase an ssl cert and set all 3 servers, the connection broker and the 2 other rdp servers, to use that cert for rdp connections.

  • I'm having this same issue with V50Le's. When i type in credentials and login, the RDP session immediately disconnects with no error.... anyone make any progress with this issue???

  • Quote Originally Posted by schasteen View Post
    I'm having this same issue with V50Le's. When i type in credentials and login, the RDP session immediately disconnects with no error.... anyone make any progress with this issue???

    Same issue here, though we're using a load balance system through our broker - are you doing the same?

  • Same thing happening on T50 thin client using Windows 2008 R2 RD FARM and round robin DNS for redirection, While Searching for solution on the internet I came across many blogs and threads assuming this issue is related to Linux RDP client.

  • Hi guys, found a temporary fix that works for us:

    Enable Network Level Authentication (ini command is nla=true in your RDP connection settings).
    This gives you a bit of an ugly login prompt when you open your connection, but because all the authentication is done before it hits the broker it gets you on the right server first time!